Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

VLAN in Windows NT

I'm Having an ethernet flat network in a single domain, lately We implement a VLAN to eliminate excessive broadcast but Work Stations from the other VLAN (subnet) could not browse in network neigborhood particularly in VLAN1 where all my servers are located? anybody got an idea?

20 REPLIES

Re: VLAN in Windows NT

you will need a layer 3 device, either a router of layer 3 switch to route between the different vlans

hope this helps

dave

Re: VLAN in Windows NT

Leonardo,

As already said you will require a min of a L3 device to get between VLAN's. Also a good practice is not place any user PC's/Servers or general user traffic in VLAN1.

For Windows PC i would suggest WINS for netbios to IP name resolution and to config the following on the router

There are other ways of resoving names via B/cast's, this is done through forwarding of UDP.

Community Member

Re: VLAN in Windows NT

Thanks for the reply sir, but...still didn't work.

Here is the my setup, the 6509 has already L3 card on it, The fact is its running on the Sup. 2 engine with MSFC card. VLAN seems working at first you look at it, You can login to network and run the TCP/IP applications such as...Lotus Notes Email, ping the address of the servers and other work station... Yes they do reply...

" THE only trouble so far is When you click the network neighborhood icon from the desktop to see the other users of the network and to access the resources of the other PC across the VLAN. That failed...

The network neigborhood display only the station in the same Vlan where it is belong (ex. If I login from VLAN10, I can see all user in Vlan10 but not in vlan1) that limits my access to the other PC on the Network.

Is there any parameters need to used in my core switch?

Re: VLAN in Windows NT

the possible reason for this is that to browse the different networks broadcasts are used and by default routers do not forward broadcasts (part of the reason for having vlans) pings will work because they are directed at individual ip addresses. i don't know if this will work but try putting helper address statements in and see if that works

hope this helps

Community Member

Re: VLAN in Windows NT

Sir,

Thanks and welcome to join me on this... The IP helper addres is already there pointing to the wins server. but still not working.

Re: VLAN in Windows NT

Leonardo,

As said in previous posting, you best bet is to configure a WINS server on your NT box and config clients with WINS IP address, this way the WINS provides the name resolution and is generally the master browser on a windows net.

The other way is to use helper-address to point to the master browser, this is used in conjunction with the global command ip forward-protocol udp ports 137, 138 and 139. These ports are all NETbios on IP, which are BROADCASTED by windows machines... Aggh!!!! Use Linux.. :))))

So config would look similar to

ip forward-protocol udp 137

ip forward-protocol udp 138

ip forward-protocol udp 138

int vlan x

ip helper-address xxx.xxx.xxx.xxx (address of Master browser)

----------------------------

You try and skip the helper address, all that this does is take a IP Broadcast which the router drops by default and turn into a UNICAST.

Regards

Dale

Community Member

Re: VLAN in Windows NT

Hi Dale,

Your advice...

As said in previous posting, you best bet is to configure a WINS server on your NT box and config clients with WINS IP address, this way the WINS provides the name resolution and is generally the master browser on a windows net.

I already done it sir , I tried in Dynamic and static addressing to see if theyre different but same result i get....

Your Advice...

int vlan x

ip helper-address xxx.xxx.xxx.xxx (address of Master browser)

It is already defined pointed to the wins server Ip adresses (my master Browser) But didn't work too...

Also... on my switch I add these parameters.

router ospf 1

network Ip address subnet (of VLAN9) area 0

network IP address subnet (of VLAN10) area 0

network IP address subnet (of Vlan1) area 0

Re: VLAN in Windows NT

Hi Leonardo,

Have you included the ip forward command.?? If so you have done all you can to get this going.

The fact that you have configured WINS and that did not work is a bit worrying, i know this is a stupid question but are you sure the WINS service is running and the node type for NT is hybrid.

If you have a WINS server there is no actual need to configure extra parameters on the routers.

to insure connectivity from the router do and extended ping to the various segments using say int vlan 9 then 10 then 1.

ipconfig /all - should give you node type on NT.

Community Member

Re: VLAN in Windows NT

on your DHCP server for the different VLANs, do you have the server option configured? This may not be the issue with your switch. for example: if you have two VLANs, VLAN1 172.29.1.0/24; vlan2:172.29.2.0/24, you will have two DHCP servers (it could be on the same NT DHCP server box), for the VLan1, if you configure the VLAN1 IP on the layer3 interface as 172.29.1.1, and VLAN2 interface:172.29.2.1, then the DHCP server option should be setup for the two default gateway point to the two vlan interface cards. You may use the same DNS and WIN server IP which point to your DNS and the WIN server. Hope this will help

Community Member

Re: VLAN in Windows NT

This may get long - bear with me. Here is the best way to set this up, and I know it works because I have done it multiple times. Use a DHCP server and a WINS server. (1) Configure a DHCP scope for each subnet. (2) In the configuration of the DHCP server include the "router" option (option 003) and configure the proper default gateway for each subnet. (3) In each scope include the IP address of the WINS server ( option 042?) and the Node Type (option 044?). Set the node type to "H node". This will cause name resolution to use the WINS server first and fall back to broadcast in the event that WINS fails to resolve the name. (4) For all statically assigned servers or workstations, be sure to include the WINS server IP address (don't forget the WINS server itself!). (5) For all DHCP devices, be sure there is no statically assigned WINS server. (6) Include an "ip helper-address where necessary in the roputer config. This will be the address of the DHCP server. You don't need to include the address of the WINS server because the devices will be using NETBios over TCP/IP. (7) If necessary, reboot the servers and workstations. (8) Use ipconfig or winipcfg to verify that the device received an IP address, the address of the DHCP server, the address of the WINS server, and the node type. (9) Be patient. It can take up to 45 minutes for WINS to fully update. (10) While you wait for WINS to update you can test continuity. Ping the WINS server. This will verify that the device can reach the WINS server via IP. Connect to other devices by using their NETBios name. This will prove connectivity using NETBios over TCP/IP. Once WINS has updated, you should see all of your devices and be able to connect to them using the GUI. One other thing; be sure the device names are unique. WINS will not allow duplicate names to be registered. I hope this helps.

Community Member

Re: VLAN in Windows NT

I forgot one thing. On all windows 95/98 PCs be sure to disable the "Master Browser" capability. If enabled it will screw up browsing. It is on by default.

Community Member

Re: VLAN in Windows NT

Hello;

Thanks I double check my configuration from the above advice.

1. Here's my WIns(DHCP) configuration under the scope option

003 Router Vlan10 Ip address gateway (for the Vlan10 subnet)

015 DNS My domain Network

044 Wins/NBS server Wins Ipaddress (primary and secondary)

046 Wins/NBT node type 0x8

005 name server wins ipaddress

2. Here's my L3 configuration

Current configuration:

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname MSFC2_Core

!

boot system bootflash:c6msfc2-is-mz.121-2.E

boot bootldr bootflash:c6msfc2-boot-mz.121-2.E

enable password cisco

!

ip subnet-zero

ip cef

!

!

!

!

interface Vlan1

ip address (this ip from Vlan1) xxx.xx.xx.xxx 255.255.240.0

!

interface Vlan9

ip address xxx.xx.x.xx 255.255.255.0

ip helper-address WINS/DHCP Server IP address

ip helper-address Backup Wins IP address

interface Vlan10

ip address xxx.xx.x.xx 255.255.255.0

ip helper-address WINS/DHCP Server IP address

ip helper-address Backup Wins IP address

!

router ospf 1

network Vlan9 ip address subnet area 0

network Vlan10 ip address subnet area 0

network Vlan1 ip address subnet area 0

!

ip classless

ip forward-protocol udp netbios-ss

no ip http server

!

!

line con 0

line vty 0 4

!

end

3. The master browser from work station was already set to disable, from the default automatic setting.

But still not working...what else to do?

Regards

Leo

Community Member

Re: VLAN in Windows NT

Try this. I don't know what option 005 in your scope is. I know you don't need it for WINS to work. If you don't need it for some other purpose, remove it. Also , you don't need to forward netbios session service packets, so you may as well remove that from your router config. Next check these things: Do your workstations get an IP address from the DHCP server? Do they get the DHCP options (WINS server, Node Type)? Can the workstations ping the WINS server? In other words, make sure TCP/IP is fully functional on all devices. If TCP/IP isn't working, nothing else will. Next, check the WINS data base. Are the workstations registered in the data base? Is the WINS server registered in the WINS data base? If the devices are not registered in the WINS data base they will not appera in "network neighborhood". If the workstations are in the WINS data base but not networtk neighborhood, can you get to them specifying the name in "windows explorer"? Also, what VLAN is your WINS/DHCP server on? You don't need a helper address on the interface that your server is attached to. If the config shown is complete, the server must be on either VLAN 9 or VLAN 10. The helper address is only needed on one of the two.

Community Member

Re: VLAN in Windows NT

Hi,

your question.

Try this. I don't know what option 005 in your scope is.I know you don't need it for WINS to work. If you don't need it for some other purpose, remove it.

My setup

Option 005 is a name server, almost same thing it do with the wins server a already taken out. after your advice.

your question.

Also , you don't need to forward netbios session service packets, so you may as well remove that from your router config.

My setup

no problem.. Il remove that but same result so far.

Your question...

Next check these things: Do your workstations get an IP address from the DHCP server?

my setup.

Yes they do get the the IP address from the DHCP, The wins and even the gateway IP is all there

Your question.

Do they get the DHCP options (WINS server, Node Type)?

my setup.

Yes. node type is hybrid

your question.

Can the workstations ping the WINS server? In other words, make sure TCP/IP is fully functional on all devices.

my setup.

Yes no problem it can ping almost everybody on VLAN1 network. (as many as i tried)

your question.

If TCP/IP isn't working, nothing else will. Next,

check the WINS data base. Are the workstations registered in the data base? Is the WINS server registered in the WINS data base?

my setup.

The answer is yes on these two question.

If the devices are not registered in the WINS data base they will not appera in "network neighborhood".

your question.

If the workstations are in the WINS data base but not networtk neighborhood, can you get to them specifying the name in "windows explorer"?

my setup.

You're right on that, When I execute a Find computer the work station can find it..but to give the same instruction to about 700 network users is a big task.

your question.

Also, what VLAN is your WINS/DHCP server on?

my setup.

it is on Vlan1...my work station is on vlan10

You don't need a helper address on the interface that your server is attached to. If the config shown is complete, the server must be on either VLAN 9 or VLAN 10. The helper address is only needed on one of the two.

my setup.

Ok the vlan1 where the servers are connected doesn't have IP helper address

I have question to ask...will it help to put a gateway address of a Vlan in the wins server (ex. Vlan10 is using xxxx.xxxxx.xxxx.xxxx on its interface), I will then add these IP address to my wins server as a gateway for Vlan10?

243
Views
0
Helpful
20
Replies
CreatePlease to create content