Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VLAN Issue

Hi all ,

I have a question regarding VLANS and DHCP server.

I have a Cisco 3750 as a core L3 Switch

I create the 4 VLANS ,vlan 76 ( 172.16.76.0/24) Vlan 77 , Vlan78 and Vlan 81.

I associated one port to Vlan 76, one to Vlan 77 one to vlan 78 and remainimng to Vlan 81 ( DHCP and all other servers are in VLAN 81)

On VLAN 76 vlan 77 and VLAN 78 ,i connected L2 Switch ( all ports of the switch are on same VLAn respectively)

I have set the IP helper address on each VLAN.

Now when i first cconnect the PC to VLAN 76 DHCP server issue the Correct IP to the PC( 172.16.76.X) now when i removed my PC from Vlan 76 and plugged into the Vlan 78 MY PC again get the Ip address from VLAN 76 , where as it should get IP from Vlan 78 ( 172.16 78.x)

Could you please help me in resolving the problem?

Below is the configuration of the port assosiated with VLAN 76

Interface GigabitEthernet1/0/2

description Connect-to-SegmentA

switchport access vlan 76

switchport mode access

switchport nonegotiate

interface Vlan76

description SegmentA-Vlan

ip address 172.16.76.1 255.255.255.0

Ip helper-address 172.16.81.10

172.16.81.10 is the DHCP server.

I want that DHCP should issue the ip address according to VLAN.

Thanks

Looking for help

  • Other Network Infrastructure Subjects
6 REPLIES
Purple

Re: VLAN Issue

Have you created an 'interface vlan78' ? If you have, and if you have given it a 172.16 78.x address, then the DHCP server will assign it an address out of the 172.16 78.x range, providing that you have created a scope on the DHCP server for the 172.16 78.x network.

Paresh

New Member

Re: VLAN Issue

paresh

Thanks for answering

yes i have created the Interface

interface Vlan78

description SegmentC-Vlan

ip address 172.16.78.1 255.255.255.0

ip helper-address 172.16.81.10

also 172.16.78.x scope has been created in DHCP server for distribution.

Thanks

Purple

Re: VLAN Issue

Hi,

Can you confirm that you did a DHCP RELEASE on the PC before trying to acquire a new address when you plugged it into a VLAN 78 port ?

Paresh

New Member

Re: VLAN Issue

hI

yes I confirm you that i first release the DHCP lease by IPCONFIG/release

But reslult is same.

Attached is the Config file for core L3 switch and HP L2 2650 switches.

Please help me on this issue.

Silver

Re: VLAN Issue

Verify your DHCP scopes are defined correctly. If you defined a separate scope with separate router default gateways then your clients should allocate according to VLAN.

New Member

Re: VLAN Issue

make sure you are not using superscopes that was my issue on a problem like this.

167
Views
3
Helpful
6
Replies
This widget could not be displayed.