Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VLAN on 3750 Stack

I am in the process of getting a 3750 switch stack installed. The stack will use layer 3 and will replace a 5505 layer 2 switch. The 5505 has all ethernet ports set to vlan 110.

My 3750 stack will also have all fasethernet ports in vlan 110.

I wanted to do as much of the up front installation prior to cutover, but did not to cause any problems in my vtp domain, so for the moment I have shutdown vlan 110 on the 3750 stack

I noticed that as soon as I did it took the following off of every fastethernet interface in the stack:

switchport access vlan 110

switchport mode access

While I sort of understand why..it has caused a little trouble because I have recently added another 3750 to the stack and was planning on configuring the rest of my interfaces using port range.

I assume the commands will be added back as soon as the interface vlan 110 is taken out of shutdown.

I was just taken by surprise that it modified the configuration as such and has made it hard to configure the other fasethernet ports I have added.

Hope this clear. Can anyone explain this a little more for me. Thanks

3 REPLIES

Re: VLAN on 3750 Stack

Did you create the vlan in the vlan database? Is the vlan in the configuration? Shutting interface vlan should not removed the vlan assignment.

interface Vlan220

no ip address

shutdown

end

3750(config-if)#do show run int gig 3/0/1

Building configuration...

Current configuration : 90 bytes

!

interface GigabitEthernet3/0/1

switchport access vlan 220

switchport mode access

end

3750(config-if)#

Also, as soon as you assign a port to a vlan that does not even exist, the system will create that vlan.

3750(config-if)# int gig 3/0/11

3750(config-if)#switch

3750(config-if)#do show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Gi3/0/11, Gi3/0/12

110 VLAN0110 active

220 VLAN0220 active Gi3/0/1, Gi3/0/2, Gi3/0/3

Gi3/0/4, Gi3/0/5, Gi3/0/6

Gi3/0/7, Gi3/0/8, Gi3/0/9

Gi3/0/10

3750(config-if)#switch access vlan 330

% Access VLAN does not exist. Creating vlan 330

3750(config-if)#do show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Gi3/0/12

110 VLAN0110 active

220 VLAN0220 active Gi3/0/1, Gi3/0/2, Gi3/0/3

Gi3/0/4, Gi3/0/5, Gi3/0/6

Gi3/0/7, Gi3/0/8, Gi3/0/9

Gi3/0/10

330 VLAN0330 active Gi3/0/11

3750(config-if)#

Community Member

Re: VLAN on 3750 Stack

hello,

I already have vlan 110 in the database. I am getting ready to replace a layer 2 5505 in vlan 110 with a layer 3 3750 that will have all its ports in vlan 110. Also, as I understand VTP is layer 2 not layer 3

I'm staging the 3750 getting ready to put it into productiion.

I had the following on every 3750 Fastethernet interface

switchport access vlan 110

switchport mode access

I shut down vlan 110 on the 3750 so that I could hook my Gig ports to my 6500's in the datacenter

When I shut vlan 110 it removed the 2 switchport statements above..I guess its no big deal...I find it somewhat strange however

Community Member

Re: VLAN on 3750 Stack

I want to try and add some clarification

I have 2 3750-48POE's in a stack...so I had 96 ports

each fastethernet interface on both 48 port switches was configured like this:

!

interface FastEthernet1/0/1

switchport access vlan 110

switchport mode access

switchport access vlan 410

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

priority-queue out

mls qos trust cos

no mdix auto

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

!

after shutting down the vlan 110 interface..Here's the config currently:

JDC-3750S-12#sh run int vlan110

Building configuration...

Current configuration : 199 bytes

!

interface Vlan110

description 10th, 11th, 12th Fl - Data

ip address 10.4.110.1 255.255.255.0

ip helper-address 10.4.1.100

ip helper-address 10.25.192.7

ip pim sparse-dense-mode

shutdown

After shutting down the interface for vlan 110, each fastethernet interface became

JDC-3750S-12#sh run int fa1/0/1

Building configuration...

Current configuration : 388 bytes

!

interface FastEthernet1/0/1

switchport access vlan 410

switchport mode access

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

priority-queue out

mls qos trust cos

no mdix auto

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

1.So you see that switchpot commands for vlan 110 got removed.

2. I have added another 3750-24 POE switch since doing this and wanted to use port range to make my additional set of ports like the ones in the original config.

I can't do that now because the vlan 110 info on the interfaces is gone.

I'm just trying to understand what this thing is doing to me. Hope this helps

306
Views
0
Helpful
3
Replies
CreatePlease to create content