Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VLAN problem

Hi all

I have FEDORA installed with VLAN configs

my first config is like this

internet----Eth0 (VLAN Liniux Box)eth1---- Switch port 0/1---switchport 0/2-- client

i have configured the switch port0/1 dotq and switch mode trunk

and i made the client config belong to vlan 3

--

in linux i have configure, eth1 3 vlan 3 and ip

and iam able to connect to VLAN and internet all coming

since i have lot of traffic, i want to loadbalance, and failover the link

i have introduced another switch between

internet----Eth0 (VLAN Liniux Box)eth1---- SwitchX port 0/1

SwitchX port 0/2----SwitchY port 0/2

SwitchX port 0/3----SwitchY port 0/3

SwitchY port 0/4--- client

i made config in cisco switch port 0/2 and 0/3 port group 1

and when i connected the switches and try to connect PC to his gateway , iam not able to ping

waht could be the problem in VLAN

any suggestion will be great

hari

3 REPLIES
New Member

Re: VLAN problem

I'm assuming this was working before you installed the second switch. If not then there are some other things that may need to be addressed. I'm also assuming, based on the etherchannel commands, that these switches are XL's.

If both assumptions are correct here are a couple of things to try.

Make sure that you have configured port groups for 0/2 and 0/3 on both switches.

Also make sure the client on SwitchY port 0/4 is configured to be in Vlan 3 and make sure that you are trunking on switchports 0/2 and 0/3 on SwitchX and switch Y.

Also make sure the client on SwitchY port 0/4 is configured to be in Vlan 3 and make sure that you are trunking on switchports 0/2 and 0/3 on SwitchX and switch Y.

New Member

Re: VLAN problem

Hi thanks for the quick reply

here is my config looks like

Switch X config

----------------

interface FastEthernet0/3

port group 1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

!

interface FastEthernet0/4

port group 1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

!

interface FastEthernet0/5

keepalive 10

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

no cdp enable

Switch Y config

---------------

interface FastEthernet0/2

port group 1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

no cdp enable

!

interface FastEthernet0/3

port group 1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

no cdp enable

!

interface FastEthernet0/4

no cdp enable

!

interface FastEthernet0/5

no cdp enable

!

interface FastEthernet0/6

keepalive 10

switchport access vlan 31

no cdp enable

!

interface FastEthernet0/7

no cdp enable

!

interface FastEthernet0/8

keepalive 10

switchport access vlan 30

no cdp enable

this config on real time server config

i gave the some example , so people can understand

this config , what iam running

client is connected vlan30

thanks if u can help to solve this issue

hari

New Member

Re: VLAN problem

I dont really understand your problem. It looks like you have two switches trunked together and that a client is connected to a second switch which is assigned to vlan 30. The config looks ok, but you need to check a few other things. What mode of VTP are you using (server->client)(server->server)(transparent->transparent)(etc,etc). Check the vlan database to ensure that the vlans are listed in each. Just because they are in your configuration file does not mean they are active in the vlan database. If your using VTP to propagate the vlans, ensure that you have the right vtp domain set as well as server to client or whatever. Where is your gateway come into play and what is it? A cisco router? You must also trunk the switchport to the router and set the router up with dot1q or isl encapsulated sub-interfaces, or use seperate physical interfaces plugged into access mode switchports (static vlan). Could you post a diagram of your config (attachment)?

106
Views
0
Helpful
3
Replies