Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vlan reachability problems

I've setup two subinterfaces on two seperate routers. The etherchannel links connecting them to the switch are trunks w/ no restrictions. Below I've setup two virtual interfaces on the same subnet and same vlan... The layer 3 info is correct as is the vlan encapsulation type and vlan number.

RouterA

interface Port-channel1.201

encapsulation dot1Q 201

ip address 192.168.201.1 255.255.255.0

RouterB

interface Port-channel1.201

encapsulation dot1Q 201

ip address 192.168.201.2 255.255.255.0

When on each router I can ping its local 192.168.201.x address but not the far end address. No acls are in place that would prevent this. Also the arp tables on each router do _not_ show the others 192.168.201.x address - only its own....

I've tried clearing the arp table and uping/downing each interface on both routers - still no connectivity between the two.

Now I can put in a static routes on each router -like so

routerA

ip route 192.168.201.2 255.255.255.255 Port-channel1.1 192.168.0.2

routerB

ip route 192.168.201.1 255.255.255.255 Port-channel1.1 192.168.0.1

And that will give me connectivity but I'm not seeing why this is needed as subnet+vlan info is the same..

On the main sub-interface port-channel 1.1

RouterA

interface Port-channel1.1

encapsulation dot1Q 1 native

ip address 192.168.0.1 255.255.255.0

RouterB

interface Port-channel1.1

encapsulation dot1Q 1 native

ip address 192.168.0.2 255.255.255.0

The above works fine. I'm at a loss as to how exactly the 'native' tag effects vlans in this situation.

I feel I should have connectivity in the 192.168.201.0/24 subnet

Suggestions?

3 REPLIES

Re: vlan reachability problems

On dot1q trunks, ethernet frames belonging to native vlan are not dot1q encapsulated. So for your second config, routers don't dot1q encapsulate ethernet frames leaving po1.1 subifs. And these frames are then switched (by ethernet switch) to the receiving router subif again with no dot1q encap. So you've no physical connectivity issue but problem is about vlans ot trunking.

For the first config are you sure that vlan 201 exists on the switch and allowed on the trunks.

New Member

Re: vlan reachability problems

Ah - yes ---- the problem was on the switch. No other port was a part of vlan 201.... Once a port was part of vlan 201 things were fine..

A 'show interface trunk' on the switch showed that vlan201 wasn't active...

I'll have to do a little research on the nuances of dot1q trunking. I was under the impression that as long as trunk was enabled things were set..

Thanks for the help!

99
Views
0
Helpful
3
Replies
CreatePlease to create content