Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN Routing 3550-SMI

How can I route between vlans between 2 3550 switches. I've read the software configuration guide, which shows how to setup routing using the EMI version. I'm using IOS ver 12.1(9)EA1c. Below is the config I've setup for these two switches.

hostname Annex1

!

interface FastEthernet0/1

switchport access vlan 15

no ip address

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

!

interface Vlan1

ip address 10.14.0.2 255.255.255.0

no ip route-cache

!

interface Vlan15

ip address 10.15.0.1 255.255.255.0

no ip route-cache

hostname Annex2

ip subnet-zero

!

interface FastEthernet0/1

switchport access vlan 20

no ip address

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

!

interface Vlan1

ip address 10.14.0.1 255.255.255.0

no ip route-cache

!

interface Vlan20

ip address 10.16.0.1 255.255.255.0

no ip route-cache

Port Mode Encapsulation Status Native vlan

Gi0/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Gi0/1 1-4094

Port Vlans allowed and active in management domain

Gi0/1 1,15,20

Port Vlans in spanning tree forwarding state and not pruned

Gi0/1 1,15,20

1 ACCEPTED SOLUTION

Accepted Solutions

Re: VLAN Routing 3550-SMI

Both static routes and RIP should be available in SMI since 12.1(11)EA1.

Have you enabled

IP routing

in your config?

See Chapter 30 - Configuring IP Unicast Routing of Cat3550 Software Configuration Guide at

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12113ea1/3550scg/swiprout.htm#wp1027804

and

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12113ea1/3550scg/swiprout.htm#51842.

Regards,

Milan

6 REPLIES

Re: VLAN Routing 3550-SMI

Hi,

you need to add IP routes.

The easiest way is to add static route to 10.16.0.1 255.255.255.0 on Annex1

and static route to 10.15.0.1 255.255.255.0 on Annex2.

You should be able to route between VLAN20 and VLAN15 then.

Or try to start RIP on both 3550s.

Regards,

Milan

New Member

Re: VLAN Routing 3550-SMI

Thanks for the reply.

The SMI IOS doesn't have the command to set static routes or to enable RIP.

Any other ideas?

Re: VLAN Routing 3550-SMI

Both static routes and RIP should be available in SMI since 12.1(11)EA1.

Have you enabled

IP routing

in your config?

See Chapter 30 - Configuring IP Unicast Routing of Cat3550 Software Configuration Guide at

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12113ea1/3550scg/swiprout.htm#wp1027804

and

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12113ea1/3550scg/swiprout.htm#51842.

Regards,

Milan

New Member

Re: VLAN Routing 3550-SMI

There is my problem. I'm using 12.1(9)EA1.

I've downloaded 12.1(13)EA1, but have been unable to tftp the image.

Annex2#show flash

Directory of flash:/

2 -rwx 0 Jan 01 1970 00:01:28 env_vars

3 -rwx 342 Jan 01 1970 00:01:28 system_env_vars

4 -rwx 2667 Mar 01 1993 00:01:57 config.text

5 -rwx 676 Mar 01 1993 00:36:12 vlan.dat

9 drwx 192 Mar 01 1993 00:03:25 c3550-i9q3l2-mz.121-9.EA1c

15998976 bytes total (11633152 bytes free)

annex2#show version

Cisco Internetwork Operating System Software

IOS (tm) C3550 Software (C3550-I9Q3L2-M), Version 12.1(9)EA1c, RELEASE SOFTWARE

(fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Tue 28-May-02 10:06 by antonino

Image text-base: 0x00003000, data-base: 0x004E4568

!

ROM: Bootstrap program is C3550 boot loader

!

Annex2 uptime is 30 minutes

System returned to ROM by power-on

System image file is "flash:c3550-i9q3l2-mz.121-9.EA1c/c3550-i9q3l2-mz.121-9.EA1c.bin"

Annex2#copy flash tftp

Source filename []? c3550-i9q312-mz.121-9.EA1c

Address or name of remote host []? 10.16.0.2

Destination filename [c3550-i9q312-mz.121-9.EA1c]?

%Error opening flash:c3550-i9q312-mz.121-9.EA1c (No such file or directory)

New Member

Re: VLAN Routing 3550-SMI

You mistyped the IOS image name. You substituted a "1" for the letter "L"... the filename is "c3550-i9q3l2-mz.121-9.EA1c".. you typed it as "c3550-i9q312-mz.121-9.EA1c".. try again with the correctly spelled image name.. hope this helps..

- Matt

Bronze

Re: VLAN Routing 3550-SMI

In addition, I would suggest using the 'archive upload-sw' command to copy the image and CMS files from the flash.

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/1219ea1/3550cr/cli1.htm#1859762

Also, use the 'archive download-sw' command to download a new image to the switch and overwrite or keep the existing image.

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/1219ea1/3550cr/cli1.htm#1859567

238
Views
7
Helpful
6
Replies
CreatePlease login to create content