Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Vlan Routing

How can I route these vlans so they can talk to each other. I'm doing this on a 6509 switch with a RSFC.

I've set up vlan interfaces with IPs on the layer 3 side of the switch but cannot ping from one vlan to the other.

Vlan 200 IP-10.2.253.253/24

Vlan 300 IP-10.2.254.254/24

4 REPLIES
New Member

Re: Vlan Routing

use 'ip help ' command to forward broadcast (first hosts of two subnet ought to ping successful each other )

New Member

Re: Vlan Routing

Hi,

Within the same R(M)SFC you should be able to ping each other. However please try by checking the inerface state. The common mistake is to forget to give to give "No shutdown" command for the interface Vlan.

!

interface Vlan200

ip address 10.2.253.253 255.255.255.0

no shutdown

!

!

interface Vlan300

ip address 10.2.254.254 255.255.255.0

no shutdown

!

And if you are restarting the MSFC , be sure that you saved the configuration.

-Thanks

-Mehboob

NEC-NY

New Member

Re: Vlan Routing

Hello,

Let me just go through the steps and check if you missed something.

1. Configure the MSFC card by issuing the following commands:

Hostname router

!

interface vlan 200

ip address 10.2.253.253 255.255.255.0

no shutdown

!

interface vlan 300

ip address 10.2.254.254 255.255.255.0

no shutdown

!

router eigrp 1

network 10.0.0.0

no auto-summary

!

end

2. Create vlans 200 and 300 on the 6509 switch.

switch(enable) set vlan 200 name VLAN200

switch(enable) set vlan 300 name VLAN300

2. Configure the some of the 6509 port to belong to vlan 200 and some to vlan 300.

switch (enable) set port vlan 200 2/1-12

switch (enable) set port vlan 300 2/13-24

3. Attach the workstations and configure their corresponding ip address and default gateway address (i.e. 10.2.253.x for vlan 200 and def. gateway of 10.2.253.253).

4. From a client ws in vlan 200, ping the default gateway ip address. If successful, ping vlan 300 default gateway ip address. If successful, ping the ip address of the client in vlan 300.

Regards,

Chris

Network Consultant

CCNP, CCDP

Getronics

New Member

Re: Vlan Routing

Cris,

great,you have put my ouststanding issue with this problem(similar to this).

your steps are spot on!

Thanks

Sam

123
Views
0
Helpful
4
Replies