Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VLAN's and DHCP

I'm unable to get dhcp addresses from my win2k server to pc's on different vlans. We are using cisco 3550-SMI switches. The dhcp server is on one vlan, and if I place the pc in the same vlan it is able to receive an ip address. All the other vlans are unable to get a address. I have the scopes defined on the server, and in the options I've defined the router's ip address as that vlan's ip address. Below is a config. Any ideas?

ip routing

!

ip dhcp-server 10.14.0.5

!

interface FastEthernet0/1

switchport access vlan 16

switchport mode access

no ip address

!

interface Vlan1

ip address 10.14.0.2 255.255.255.0

!

interface Vlan16

ip address 10.16.0.1 255.255.255.0

!

router rip

network 10.0.0.0

neighbor 10.14.0.1

!

ip default-gateway 10.14.0.2

ip classless

ip route 10.0.0.0 255.0.0.0 10.14.0.1

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: VLAN's and DHCP

You need to configure a ip-helper address on your vlan interfaces to tell this device to pass the DHCP discovery message on to your DHCP server.

Like this

interface Vlan1

ip-helper

ip address 10.14.0.2 255.255.255.0

You'll need to do this for each VLAN interface that is not on the same VLAn as your DHCP server.

Hope this helps you,

Don

1 REPLY
Silver

Re: VLAN's and DHCP

You need to configure a ip-helper address on your vlan interfaces to tell this device to pass the DHCP discovery message on to your DHCP server.

Like this

interface Vlan1

ip-helper

ip address 10.14.0.2 255.255.255.0

You'll need to do this for each VLAN interface that is not on the same VLAn as your DHCP server.

Hope this helps you,

Don

207
Views
0
Helpful
1
Replies
CreatePlease to create content