Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLan setup for a 2950 and 2611

Im trying to setup a real basic VLan setup for 1 2950 switch. I would like to have 3 Vlans on it including the default Vlan. So my understanding is that for all 3 of the VLans to talk to each other I will need a router to be the layer 3 device that routes the Vlans.

On my 2611 it looks like this:

!

interface Ethernet0/0

no ip address

full-duplex

!

interface Ethernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.10.1 255.255.255.0

no snmp trap link-status

!

interface Ethernet0/0.2

encapsulation dot1Q 2

ip address 172.16.20.1 255.255.255.0

no snmp trap link-status

!

interface Ethernet0/0.3

encapsulation dot1Q 3

ip address 172.16.30.1 255.255.255.0

no snmp trap link-status

!

Then my 2950 looks like this:

!

interface FastEthernet0/1

description Connection to router

switchport mode trunk

speed 10

duplex full

!

interface FastEthernet0/2

switchport access vlan 2

!

interface FastEthernet0/3

switchport access vlan 3

!

!

!

interface Vlan1

ip address 172.16.10.2 255.255.255.0

no ip route-cache

!

ip default-gateway 172.16.10.1

!

Ok so as it currently stands the switch and router will not talk to each other at all. From the switch I can not ping the router and vice a versa. If I plug a laptop into one of the ports using VLan1 I can ping the switch IP 172.16.10.2 but obviously can not ping the default gateway which is the router...

I didnt think this looked very hard but for some reason it does not want to work for me at all...

Any ideas?

LR

1 ACCEPTED SOLUTION

Accepted Solutions

Re: VLan setup for a 2950 and 2611

I have two things you might try. First set your trunking interface on your switch to auto.

interface fastethernet 0/1

speed auto

duplex auto

This will help to make sure that the ethernet on the 2611 will negotiate the duplex with the switch. I've had issues with 2611's trying to do full duplex on there ethernet ports.

Another Option turn on CDP on your router and switch and do a show cdp neighbor to make sure there plugged into the right ports.

Three you could move the vlan 1 ip address on the 2611 to the main interface. Example below. Then try pinging the switch. Your other tagged vlans should still work at that point. Also if you have multiple switches make sure to setup Vlan Trunk Protocol see NOTE A.

no interface Ethernet0/0.1

no encapsulation dot1Q 1 native

no ip address 172.16.10.1 255.255.255.0

no snmp trap link-status

interface Ethernet0/0

ip address 172.16.10.1 255.255.255.0

NOTE A

Add the following commands to each switch to setup your Vlan Trunk Protocol. These are pretty much the minimum amount of commands you can use to setup VTP.

vtp domain CISCO1

vtp version 2

2 REPLIES

Re: VLan setup for a 2950 and 2611

I have two things you might try. First set your trunking interface on your switch to auto.

interface fastethernet 0/1

speed auto

duplex auto

This will help to make sure that the ethernet on the 2611 will negotiate the duplex with the switch. I've had issues with 2611's trying to do full duplex on there ethernet ports.

Another Option turn on CDP on your router and switch and do a show cdp neighbor to make sure there plugged into the right ports.

Three you could move the vlan 1 ip address on the 2611 to the main interface. Example below. Then try pinging the switch. Your other tagged vlans should still work at that point. Also if you have multiple switches make sure to setup Vlan Trunk Protocol see NOTE A.

no interface Ethernet0/0.1

no encapsulation dot1Q 1 native

no ip address 172.16.10.1 255.255.255.0

no snmp trap link-status

interface Ethernet0/0

ip address 172.16.10.1 255.255.255.0

NOTE A

Add the following commands to each switch to setup your Vlan Trunk Protocol. These are pretty much the minimum amount of commands you can use to setup VTP.

vtp domain CISCO1

vtp version 2

New Member

Re: VLan setup for a 2950 and 2611

Well you fixed it, when I moved my vlan1 subinterface e0/0.1 to just ethernet0/0 everything started routing. I was able to ping across all 3 vlans just fine... Crazy stuff

Thanks for all the help from everyone.

LR

110
Views
5
Helpful
2
Replies
CreatePlease login to create content