Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN Support Question

Are VLANs supported on Ethernet (10Mbps) ports? If so, I can't get mine to work. I am connecting a Catalyst4006-S2 with a Cisco4500-M running CatOS 7.4.3 and 12.1.21 IP+ respectively. Both of the software versions supposedly support 802.1q trunking.

====================================

The switch looks like this:

set vlan 2 name V2

set vlan 21 name V21

set trunk 2/4 nonegotiate dot1q !TRUNK UNCONDITIONALLY

clear trunk 2/4 1 !CLEARS VLAN 1 FROM TRUNK PORT

====================================

The router looks like this:

ip routing

interface Ethernet1

no ip address ip address 10.10.0.1 255.255.255.0

no ip redirects

no ip mroute-cache

media-type 10BaseT

no shutdown

interface Ethernet1.2

encapsulation dot1q 2

ip address 10.10.0.1 255.255.255.0

no shutdown

interface Ethernet1.21

encapsulation dot1q 21

ip address 10.0.21.1 255.255.255.0

no shutdown

====================================

Any help would be greatly appreciated. Thanks, Tim

2 REPLIES
Cisco Employee

Re: VLAN Support Question

Trunking is not supported in 10Mbps Ethernet interfaces on the 4000 series routers. You need the NP-1FE interface to do trunking (ISL only). The Cat4000 sup2 system only supports dot1q, so you'll need either a different router or a different switch to trunk with. An alternative if you only have 2 vlans is to use two 10BaseT ports on the router (one for each vlan).

New Member

Re: VLAN Support Question

I was afraid someone was going to tell me this. I wish that we were only using 2 subnets, but I need 3. I was thinking about purchasing the old NP-6E if they won't purchase a new router. Thanks, Tim

85
Views
0
Helpful
2
Replies
CreatePlease login to create content