Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Vlan to Vlan multicasting on 4006s

We have vlan104 with users and vlan128 with servers. The actual ports for a user and server are on two different 4006 switches). The IP rp address is the FastEthernet subinterface for vlan128. Here is the config for the router to switch1:

Router:

interface Loopback0

ip address 192.168.200.72 255.255.255.255

ip pim sparse-dense-mode

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

!

interface FastEthernet0/0.76

encapsulation dot1Q 76

ip address 192.168.76.1 255.255.252.0

ip helper-address 192.168.36.30

ip helper-address 192.168.36.35

no ip redirects

ip pim sparse-dense-mode

ip cgmp

ipx encapsulation SAP

ipx network 3B14C00

!

interface FastEthernet0/0.104

encapsulation dot1Q 104

ip address 192.168.104.1 255.255.252.0

ip helper-address 192.168.36.30

ip helper-address 192.168.36.35

no ip redirects

ip pim sparse-dense-mode

ip cgmp

ipx encapsulation SAP

ipx network 3B16800

!

interface FastEthernet0/0.128

encapsulation dot1Q 128

ip address 192.168.128.1 255.255.252.0

ip helper-address 192.168.36.30

ip helper-address 192.168.36.35

no ip redirects

ip pim sparse-dense-mode

ip cgmp

ipx encapsulation SAP

ipx network 3B18000

!

interface FastEthernet0/0.137

description This interface is connected to the ERC owned LAN.

encapsulation dot1Q 137

ip address 192.168.137.1 255.255.255.0

ip helper-address 192.168.36.30

ip helper-address 192.168.36.35

ip pim sparse-dense-mode

ip cgmp

!

interface FastEthernet0/0.174

encapsulation dot1Q 174

ip address 192.168.174.1 255.255.255.0

!

Switch1: (firmware 5.4.1, software: 7.1(2))

#vtp

set vtp domain corporate1

set vtp pruning enable

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm

set vlan 76,104,128,137

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active mode srb aremaxhop 7 stemaxhop 7 backupcrf off

#frame distribution method

set port channel all distribution mac both

set vlan 76,104,128,137

#cgmp

set cgmp enable

set cgmp leave enable

set cgmp fastleave enable

#multicast filter

set igmp filter disable

!

set port channel 6/1-48 mode off ! (server is on port 6/5)

Switch2: (user is on port 3/41)(software/firmware same as switch1)

#frame distribution method

set port channel all distribution mac both

#vtp

set vtp domain corporate1

set vtp mode client

#cgmp

set cgmp enable

set cgmp leave enable

!

set vlan 104 3/1-48

The routers and the switches seem to see all the proper handshaking for multicasting but no packets from the multicast (webcast) are actually getting onto the vlan (show mac 6/5 on switch2).

Any clues or need more information?

  • Other Network Infrastructure Subjects
1 REPLY
New Member

Re: Vlan to Vlan multicasting on 4006s

Hi Philip,

please post the output of the following commands.

show ip mroute

show ip igmp groups

show ip igmp interface

regards Michel

103
Views
0
Helpful
1
Replies