Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN trunk to non Cisco

we have two 4503 switches configured with secondary interfaces and running RIP.

There are no vlans configured on the switch.

I have a 3com switch on a subnet not yet configured on the 4500 switches.

I want to create a trunk from the 3com to the 4500.

I have the vlan configured with the IP address I want, but I am not sure how to associate the trunk port to it.

I have the 3com connected to port g2/40 but the vlan interface does not come up unless I configure:

switchport mode access

interface GigabitEthernet2/40

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 6

switchport mode trunk

interface Vlan6

ip address 10.250.250.250 255.255.255.0

I can find anything specific on how this should be done.

9 REPLIES

Re: VLAN trunk to non Cisco

With 3Com (&HP as well) it works different from Cisco but dot1Q is an industry standard and you will be able to make the desired connection as follows:

On the 3Com, the native vlan is to be added to the trunk-port as "untagged". Then you may add multiple tagged vlans to the same port. There is a gui-tool for this that works rather well.

Then on the Cisco, set the native vlan to the same vlan-id as remote. Define the port as trunk with dot1Q encapsulation.

If all that is done you have the layer2 setup ready. Now, test if you also have ip connectivity on the same vlan from cisco to remote. Once that works you can try the same from different vlans to verify L3-switching operation.

Regards,

Leo

Re: VLAN trunk to non Cisco

Hi,

Do you have a vlan 6 created? Do a show vlan and check whether vlan 6 exists in your vlan database. If there's no vlan 6 then create one as shown below.

With the 'switchport trunk allowed vlan 6' you are only allowing vlan 6 across the trunk and the 3com has to be configured identical to this switchport for the trunk to become active. I recommend removing this command and configure 802.1q trunk on switchports on either end and check the status. If everything is OK then you can fine tune the config later.

SW1-3550#config t

Enter configuration commands, one per line. End with CNTL/Z.

SW1-3550(config)#vlan 6

SW1-3550(config-vlan)#name TEST

HTH

Sundar

New Member

Re: VLAN trunk to non Cisco

Thanks for the replys guys,

I do have the Vlan created and have looked and it is not in the Vlan database as you suggested, so that must be it.

Is that all that is needed for the trunk (what I have shown and adding it to the VLAN database)?

another question:

I want to have all the 3com switches trunk up to both of the Cisco 4500's

I am concerned about STP, is all I need to do is make sure it is enabled on the 3coms?

It is already set in the 4500 switches with switch 1 as the primary.

Cisco Employee

Re: VLAN trunk to non Cisco

Hi Rich,

Have you also configured trunk on 3com switch which I believe is not? Also if you have configured trunk on 3com switch is it showing you up and working. I believe your 3com switch por tconnected to cisco switch port is only configured for access vlan 6.

On cisco switch for any logical interface like vlan interface in your case to be up and up you need to have one physical interface attached to that vlan or you need ot have trunk interface allowing that vlan which is true in your case but if 3com switch port is not acting as trunk then trunk on cisco switch will be down and is the reason your logical interface will show you line protocol down.

because I believe your 3com switch is configured only for vlan 6 and is the reason when you configure switchport mode access on cisco switchport that physical interface get binded with that vlan and your logical interface comes up.

So cheked the port and trunk settings on 3com switch as config is fine on cisco switch end.

HTH

Ankur

New Member

Re: VLAN trunk to non Cisco

3com does have trunk configured on the link to the Cisco

New Member

Re: VLAN trunk to non Cisco

Are you saying I should have the trunk configured for native vlan 1 and vlan 6?

I need both on the trunk?

Re: VLAN trunk to non Cisco

Now, a trunk always transports more than one vlan. Remember: native vlan = untagged; all other vlans tagged. Make sure that the native or untagged vlan is the same, otherwise you will have traffic flowing from vlan 1 into vlan 6 and vice versa.

New Member

Re: VLAN trunk to non Cisco

Suppose there is only one subnet on the switch I want to uplink to the Cisco 4500?

I suupose it would not need a trunk then, just an uplink to the 4500?

How would I configure the Vlan interface to accept the uplink from the 3com if I am only concerned about the one subnet?

Re: VLAN trunk to non Cisco

You need a config like this.

4500:

int f0/14

description 'connects to 3com'

switchport mode access

switchport access vlan (#)

On the 3com switch, configure the port that connects to the 4500 as an access port on the same vlan # as the 4500 switchport. The uplink port would have to be on the same VLAN as the other 3com ports are. Ofcourse, you need to have the VLAN created in both switches.

HTH

Sundar

423
Views
20
Helpful
9
Replies
CreatePlease login to create content