Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Vlan Trunking / Mgmt Vlan Design

Hello,

I'm wondering if anyone can help me with some vlan design. I would like to know how to properly design the following system:

Location A: 3550 doing inter vlan routing

Location B: 2950 connected and trunking to the 3550

Location C: 2950 connected and trunking to the 3550

From what I have read, it is recommended to have a management vlan (not vlan1).

How would you setup the switches to be managable via the mgmt vlan and not vlan1?

Also, If location C is mostly connecting vlan50 how would you setup the switch to default to vlan50?

Thanks.

6 REPLIES
Purple

Re: Vlan Trunking / Mgmt Vlan Design

Just setup the layer 3 SVI on the 3550. Then have the trunk carry that vlan down to your other switches . Create the layer 2 vlan on the 2950 and then create the layer 3 SVI for that vlan so your management address is whatever you decide instead of vlan 1 , you will see the vlan 1 interface go down and the new one come up because you can only have 1 layer 3 SVI active at a time on the 2950's . For instance on the 2950's

conf t

vlan 20

exit

interface vlan 20

ip address xxx.xxx.xxx.xxx

no shut

Vlan 20 would have to be allowed across your trunks. Nothing on loc "C" would have to be changed as far as the users , you are just changing the address you manage the switch . The switch management address would be a vlan 20 address and vlan 50 gets carried across the trunk to the 3550 to be routed .

Re: Vlan Trunking / Mgmt Vlan Design

Hi Dan,

as you said that you have created vlans in 3550 which is doing inter-vlan routing. now what you do is, juz create a vlan eg. vlan 2 in both the 2950's in locaion B & C, & also create vlan 2 in 3550, which means all the switches falls under vlan 2, once if you enable vlan 2 in 2950's, vlan 1 will shutdowns automatically. This behavior is normal because 2950's are taking the vlan information from the layer 3(3550) logical interface which can have a active interface locally on the layer 2 switches.

configuration has to be setup like...

3550

ip routing

interface vlan 2

description ***Switch_VLANS***

ip address 10.1.1.1 255.255.255.0

interface vlan 50

description ****Server_VLAN***

ip address 192.168.1.1 255.255.255.0

interface vlan 51

description ***Client_VLAN***

ip address 172.16.1.1 255.255.255.0

interface giga 0/1

description ***Location B 2950***

switchport trunk encapsulation dot1q

swithport mode trunk

interface giga 0/2

description ***Location c 2950***

switchport trunk encapsulation dot1q

swithport mode trunk

Location B 2950

interface vlan 2

ip address 10.1.1.2 255.255.255.0

interface giga 0/1

decription ***connected to 3550***

switchport mode trunk

ip default-gateway 10.1.1.1

Location C 2950

interface vlan 2

ip address 10.1.1.3 255.255.255.0

interface giga 0/1

decription ***connected to 3550***

switchport mode trunk

ip default-gateway 10.1.1.1

here the management vlan is VLAN 2 for the switches, since you say that most of the ports are on vlan 50 in Location C, make rest of the ports as vlan 50.

hope this helps.

rate this post if cleared.

New Member

Re: Vlan Trunking / Mgmt Vlan Design

Hello,

It worked perfectly. Thanks.

I have one more question. Between location A and C, I have a third party wireless bridge connecting the buildings. Which vlan could I put those radios into in order to manage them?

Re: Vlan Trunking / Mgmt Vlan Design

Hi Dan,

juz put them in switch VLAN as it will easy for you understand.

eg. servers - vlan 3

clients - vlan 4

switches/bridge - vlan 2

printers - vlan 5 & so on

hope this helps.

please donot forget to rate the post

New Member

Re: Vlan Trunking / Mgmt Vlan Design

Hi,

Give seprate vlan Radio links

Eg: vlan 10 "RadioLink"

And then you can manage VLAN 10 traffic etc on switches

Thanks

Chetan

New Member

Re: Vlan Trunking / Mgmt Vlan Design

That worked. Thanks.

227
Views
15
Helpful
6
Replies