Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vlan will not come up

I have an 871 with two VLANS like this

VLAN 1 192.168.0.0 /24

VLAN 2 192.168.1.0 /24

I then have the following config for one of the switch ports:

interface fastethernet 0

switchport access vlan 1

switchport voice vlan 2

no keepalive

I plug an IP phone with a computer in the PC port to the above port. VLAN 1 comes up since there is a port in that VLAN. Problem is that VLAN 2 will not come up thus the phone will not get on the network.

Is there a way to force VLAN 2 to come up? Or is there a better way of doing this?

Thx.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: vlan will not come up

Set the port up like this:

interface FastEthernet0

switchport access vlan 1

switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport mode trunk

switchport voice vlan 2

The port needs to be trunked as it is transporting more then 1 vlan.

HTH & please rate if it does.

4 REPLIES
New Member

Re: vlan will not come up

Set the port up like this:

interface FastEthernet0

switchport access vlan 1

switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport mode trunk

switchport voice vlan 2

The port needs to be trunked as it is transporting more then 1 vlan.

HTH & please rate if it does.

New Member

Re: vlan will not come up

worked great thx! Question though, isn't that what switchport voice vlan in effect does? Doesn't it make it a trunk port behind the scenes anyway?

New Member

Re: vlan will not come up

It might make the trunk, but you still need the encap and set the native vlan.

Re: vlan will not come up

The trunk will be auto negotiated only if you have Cisco devices at both ends and the port is enabled for voice vlan.

Also When the IP Phone trunk is active, it is not shown in the trunking mode from any Cisco IOS Software show command. However, you can verify the VLANs being carried over the trunk link by looking at the Spanning Tree Protocol (STP) activity. STP runs with two instancesone for the voice VLAN and one for the data VLAN, which can be seen with the show spanning-tree interface command.

HTH

Narayan

351
Views
0
Helpful
4
Replies
CreatePlease to create content