Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

VLANs and NAT

I have a CISCO 1710 router and a Netgear FS526T Switch.

After a while I've been able to sort most of the configuration out but there´s something that does not quite work properly.

I use the switch to create port-based vlans All the ports but one are untagged. The last port in the switch uses 802.1q vlan tagging and belongs to all the vlans.

That port is connected to the fastethernet interface in the cisco.

Up to here, everything is fine. I can connect machines to different ports and they can all access the router, but when I try to access the internet there is a strange behaviour: The VLAN 1 works normally and at full speed. The other VLANs experience problems accessing some web sites.

I can trace a route, query a dns server, even download web pages from some sites (i.e. microsoft or cocacola), but not others (like google or altavista).

I'll paste a bit of configuration to see if anyone can find my mistake.

(I found a web page with the same problem but no solution:

http://www.groupstudy.com/archives/associate/200104/msg00325.html)

interface Ethernet0

ip address XX.XX.XX.XX 255.255.255.248

ip nat outside

half-duplex

!

interface FastEthernet0

no ip address

ip nat inside

speed 100

full-duplex

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

ip address 192.168.37.1 255.255.255.0

ip nat inside

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 172.16.22.1 255.255.255.0

ip nat inside

!

interface FastEthernet0.3

encapsulation dot1Q 3

ip address 172.16.24.1 255.255.255.0

ip nat inside

!

ip nat inside source list 110 interface Ethernet0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 XX.XX.XX.XX

no ip http server

no ip http secure-server

!

access-list 110 permit ip 192.168.37.0 0.0.0.255 any

access-list 110 permit ip 192.168.47.0 0.0.0.255 any

access-list 110 permit ip 172.16.0.0 0.0.255.255 any

access-list 110 permit ip 172.17.0.0 0.0.255.255 any

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: VLANs and NAT

Ruben,

First of all the translated traffic is going from a full duplex fast ethernet interface through a half duplex 10 MB ethernet interface, so performance issues can be expected.

You can try to disable fast switching on your FE interface to see if it makes any difference (Try this after hours).

no ip route-cache

Also look into CEF, Cisco Express forwarding, if it is avalaible for your IOS and router platform.

2 REPLIES
New Member

Re: VLANs and NAT

Ruben,

First of all the translated traffic is going from a full duplex fast ethernet interface through a half duplex 10 MB ethernet interface, so performance issues can be expected.

You can try to disable fast switching on your FE interface to see if it makes any difference (Try this after hours).

no ip route-cache

Also look into CEF, Cisco Express forwarding, if it is avalaible for your IOS and router platform.

New Member

Re: VLANs and NAT

no ip route-cache did the trick

thanks a lot.

performance is not an issue in my network. Anyway the internet connection will only be 2MB.

310
Views
0
Helpful
2
Replies
CreatePlease to create content