Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

Bronze

vlans not working on trunk

This should be simple. I've done it before. I just want to hang a 2950-48 off a 2950-24 via a trunk. The -24 is trunked to a 2612 on a fastethernet NM and works fine. This is the layout

2612(fa1/0)<>Sw1(fa0/1)-Sw1(fa0/24)<>Sw(fa0/48)

They are all dot1q trunks. The switches see each othe in cdp so it seems like at least one vlan is working. I tried bypassing sw1 and connecting sw2 to the rtr but it still did not work. I see encapsulation errors in sw2 trying to ping the router and in the router trying to ping the switch. What have I done wrong here? Excerpts from 3 configs below.

! Router

!

interface FastEthernet1/0

no ip address

no ip directed-broadcast

speed 100

full-duplex

!

interface FastEthernet1/0.1

encapsulation dot1Q 1

ip address 10.127.209.62 255.255.255.192

no ip directed-broadcast

!

interface FastEthernet1/0.2

encapsulation dot1Q 2

ip address 10.127.209.126 255.255.255.192

no ip directed-broadcast

!

interface FastEthernet1/0.3

encapsulation dot1Q 3

ip address 10.127.209.190 255.255.255.192

no ip directed-broadcast

!

interface FastEthernet1/0.4

encapsulation dot1Q 4

ip address 10.127.209.254 255.255.255.192

no ip directed-broadcast

!

interface FastEthernet1/0.5

encapsulation dot1Q 5

ip address 10.127.122.190 255.255.255.192

no ip directed-broadcast

!

******************************

! Switch1

!

no spanning-tree vlan 2

no spanning-tree vlan 3

no spanning-tree vlan 4

no spanning-tree vlan 5

ip subnet-zero

!

!

!

interface FastEthernet0/1

description uplink to router

duplex full

speed 100

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 5

!

!

interface FastEthernet0/24

description link to store systems switch

duplex full

speed 100

switchport mode trunk

!

interface VLAN5

ip address 10.127.122.188 255.255.255.192

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 10.127.122.190

******************************

! Switch2

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 2

no spanning-tree vlan 3

no spanning-tree vlan 4

no spanning-tree vlan 5

!

!

vlan 2-5

!

interface FastEthernet0/48

description uplink to sw1

switchport mode trunk

switchport nonegotiate

no ip address

duplex full

speed 100

!

interface Vlan1

ip address 10.127.209.60 255.255.255.192

no ip route-cache

!

ip default-gateway 10.127.209.62

4 REPLIES

Re: vlans not working on trunk

Hi,

I think you have missed native VLAN on your router trunk port.

It should be

interface FastEthernet1/0.1

encapsulation dot1Q 1 native

Now VLAN1 frames outgoing from the router are tagged but VLAN1 (default native VLAN on switch trunk) frames are outgoing untagged from your switch.

Regards,

Milan

Bronze

Re: vlans not working on trunk

Thanks,

I was wondering about that but couldn't find out how to specify it. Turns out my router does not accept the native keyword in the encapsulation statement. Its running 12.0(7) XK1. I'm going to upgrade and see what that does. Until then if anyone else sees anything wrong let me know

Thanks again.

Re: vlans not working on trunk

There is a little trick for IOS which does not accept the native keyword .

Just remove subinterface FastEthernet1/0.1 from your config

and configure

interface FastEthernet1/0

ip address 10.127.209.62 255.255.255.192

instead of it, with all other subinterfaces left as were before.

This should work without any upgrade.

Regards,

Milan

Bronze

Re: vlans not working on trunk

The uograde worked but only after I added the native keyword. I did not see the trick comment until after I fininshed the upgrade. Anyway, that means that the new switches replacing the 3500 series is not comptable with my 1000+ routers already installed. Sure would be nice if the Cisco sales people would point that out.

96
Views
0
Helpful
4
Replies
CreatePlease to create content