Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vlans on 1721 w/ WIC-4ESW

I'm tring to get a 1721 running 12.3(2)XC w/ a WIC-4ESW configured to work w/ vlans.

Fa2 of the wic will be in vlan 2 - everything else will be in vlan1. The on vlan2 the wic will have an ip of 192.168.17.254/24.

On fa2 I have the following..

interface FastEthernet2

switchport access vlan 2

no ip address

no cdp enable

I configured a interface VLAN2

interface Vlan2

ip address 192.168.17.254 255.255.255.0

I then plugged in a laptop to Fa2 - configured it for 192.168.17.1/24

Despite this config I can't ping 192.168.17.1.

Upon looking at a interface summary interface vlan2 was up and down and fa2 was up and up. A snippet.

FastEthernet2 unassigned YES unset up up

Vlan2 192.168.17.254 YES manual up down

vlan2 being up/down is my problem a

'show ip route 192.168.17.0'

Showed that subnet not in ther routing table - the interface was down.. So I return to my config and added the following:

interface FastEthernet2

switchport access vlan 2

no ip address

vlan-id dot1q 2

exit-vlan-config

!

no cdp enable

interface Vlan2

ip address 192.168.17.254 255.255.255.0

vlan-id dot1q 2

exit-vlan-config

Still vlan2 is up/down.

I remove the

switchport access vlan 2

from fa2 then administrativly up and down fa2. Still no dice.. I'm getting a little confused here at this point.

I then remove inter vlan2 and put in

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 192.168.17.254 255.255.255.0

no cdp enable

interface FastEthernet2

switchport access vlan 2

no ip address

no cdp enable

I can finally ping 192.168.17.254. I try 192.168.17.1 - still nothing. I clear the arp cache and reboot the router. Still can't ping 192.168.17.1.

Here is my show version output aswell as my interface brief output

Interface IP-Address OK? Method Status Protocol

FastEthernet0 x.x.x.x YES NVRAM up up

FastEthernet0.2 192.168.17.253 YES manual up up

FastEthernet1 unassigned YES unset up up

FastEthernet2 unassigned YES unset up up

FastEthernet3 unassigned YES unset administratively down down

FastEthernet4 unassigned YES unset administratively down down

Vlan1 x.x.x.x YES NVRAM up up

After double checking settings on the router and my laptop I'm at a loss as to why I can't set this up.. Keep in mind I can't configure a ip on fa1-4 as they're just layer 2 devices.

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.3(2)XC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Synched to technology version 12.3(1.6)T

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Thu 25-Sep-03 04:54 by ealyon

Image text-base: 0x80008120, data-base: 0x8122251C

ROM: System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)

ROM: C1700 Software (C1700-K9O3SY7-M), Version 12.3(2)XC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

kick-riverside uptime is 38 minutes

System returned to ROM by reload at 18:15:44 CST Fri Jan 30 2004

System restarted at 18:18:09 CST Fri Jan 30 2004

System image file is "flash:c1700-k9o3sy7-mz.123-2.XC.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco 1721 (MPC860P) processor (revision 0x100) with 43336K/5816K bytes of memory.

Processor board ID FOC0630088G (984524091), with hardware revision 0000

MPC860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

5 FastEthernet/IEEE 802.3 interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

3 REPLIES
Bronze

Re: vlans on 1721 w/ WIC-4ESW

Hi,

The first config you did was correct. That is

int vlan 2

ip address x.x.x.x

int fa 2

switchport mode access vlan 2

I think the only thing you have forgotten is to activate vlan 2 in the vlan database.

From the router prompt, go to

Router#vlan database

Router(vlan)# vlan 2

Once vlan 2 is active, the interface vlan 2( SVI ) will go up when you plug something into fa2

Bronze

Re: vlans on 1721 w/ WIC-4ESW

VIP Purple

Re: vlans on 1721 w/ WIC-4ESW

Hello,

in VLAN configuration mode, can you issue the ´show´ command to check if your VLAN 2 is operational ? It should look like this:

Router(vlan)#show

VLAN ISL Id: 1

Name: default

Media Type: Ethernet

VLAN 802.10 Id: 100001

State: Operational

MTU: 1500

Translational Bridged VLAN: 1002

Translational Bridged VLAN: 1003

VLAN ISL Id: 2

Name: VLAN0002

Media Type: Ethernet

VLAN 802.10 Id: 100002

State: Operational

MTU: 1500

Also, can you post your full configuration ?

Regards,

Georg

1132
Views
5
Helpful
3
Replies
CreatePlease login to create content