Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

vlans on router

I have seen on a router config that it has vlans, What routers are these and is that possible ?

3 REPLIES

Re: vlans on router

hi

I feel you are talking about Etherswitch modules,If you have installed EtherSwitch Network Module yes you can have VLANS configured.

I would suggest to check this link to check out the no of vlans supported on each interface models..

http://cisco.com/en/US/products/ps5853/products_qanda_item0900aecd802a9470.shtml

regds

Community Member

Re: vlans on router

Hello,

If you're looking at the config of an MSFC from either hybrid or native you will see VLAN interfaces configured as well. The MSFC (Multilayer Switch Feature Card) is a daughter card on the supervisor enginets that supports RP functionality.

If you have access to the device, you can check a show ver to verify the hardware type of box. You can check show diag to look for ether-switch modules that may be installed.

Hope this helps.

Regards,

James

Community Member

Re: vlans on router

Hello Carl,

a router can used to route between vlans. It is then called "router on a stick". This was common in former times when there where no routing capabilities in the switches.

interface FastEthernet0/0

no ip address

no ip mroute-cache

speed 100

full-duplex

!

interface FastEthernet0/0.1

description VLAN1

encapsulation dot1Q 1 native

ip address 10.30.255.1 255.255.0.0

no ip redirects

no ip mroute-cache

standby 1 priority 150 preempt

standby 1 ip 10.30.255.254

!

interface FastEthernet0/0.2

description VLAN2

encapsulation dot1Q 2

ip address 10.40.255.1 255.255.0.0

no ip redirects

no ip mroute-cache

standby 2 priority 120 preempt

standby 2 ip 10.40.255.254

!

If a router can do this depends on the feature set. In 12.1 you need PLUS feature set on the router to do this.

Bye

Jo

130
Views
0
Helpful
3
Replies
CreatePlease to create content