Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Voice and Data VLANs..Help!

Hello,

I am trying to configure three 3560 switches with seperate VLANs for voice and data. Computers will be plugged into the IP Phones and the phones into the switches. I have gotten this to work using a single VLAN but i am told that it is not a good practive to have voice and data on 1 VLAN. Two of the 3560s are 40 port PoE and one is a 24 port non-POE. I am attatching a config of a 48 port POE as it stands now. Can anyone help?

All replies will be rated!

Thaks in advance!

6 REPLIES
Cisco Employee

Re: Voice and Data VLANs..Help!

It involves more than just configuration on the switch. You will need to configure routing between Voice and data VLANs and configure DHCP scopes for the new VLANs as well.

Say vlan 10 is your data VLAN and vlan 20 is your voice VLAN, the config on the switch would look like.

interface FastEthernet0/x

switchport access vlan 10

switchport mode access

switchport voice vlan 20

spanning-tree portfast

New Member

Re: Voice and Data VLANs..Help!

Would it be just as effective configuring the ports as trunks instead of enabling two VLANs per port (provided you had no more than two VLANs on your network)?

New Member

Re: Voice and Data VLANs..Help!

And to add to the previous post, don't forget to enable qos.

in global configuration mode "mls qos"

int f0/x

mls qos trust cos

The PC traffic will be tagged by the phone with cos - 0 and tag voip traffic cos-5. The above command will instruct the switch to trust cos values coming from the phone port to the switch port, i.e data-0, voice-5. That is assuming you want all pc traffic to be marked with cos-0.

More details:

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12225see/scg/swvoip.htm#wp1030794

HTH

E.

Re: Voice and Data VLANs..Help!

To summarize all the above posts, your configs shud look like..

interface FastEthernet1/0/9

description Connection to IP Phone/PC

switchport access vlan 10 <-- access vlan

switchport mode access

switchport voice vlan 11 <--- voice vlan

mls qos trust cos

spanning-tree portfast

HTH

New Member

Re: Voice and Data VLANs..Help!

Thanks. Now another simple question. How do I create each VLAN and does each VLAN have to have its own ip address? and to allow the VLANs to talk to each other I have to do VLAN trunking on a router but nothing more than create the VLANS on the switches correct?

Thanks so much for the help everyone!

New Member

Re: Voice and Data VLANs..Help!

To create vlans on the 3560:

# vlan 10

name DATA

# vlan 20

name VOICE

Then you must create a trunk connection to your router or use two seperate ethernet ports connected to each vlan. You must configure the IP address on each of your VLANS within the router so that you route between them.

If you are wishing to use a 802.1q trunk from the router on say interface fa0/0 then the commands would be similar to:

int fa0/0.10

encap dot1q 10

ip add [data vlan ip ddress and mask]

int fa0/0.20

encap dot1q 20

ip add [voice vlan ip address and mask]

136
Views
0
Helpful
6
Replies
CreatePlease to create content