Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Voice Vlan question

I was curious what the difference between the following 2 configs are? Both seem to work, but I wasn't sure what the fundamental difference of making the port a trunk or not would do?

config 1:

fa0/1

description CISCO PHONE

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 3

no ip address

spanning-tree portfast

config 2:

int fa0/2

description CISCO PHONE

switchport access vlan 2

switchport voice vlan 3

no ip address

spanning-tree portfast

  • Other Network Infrastructure Subjects
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Voice Vlan question

config 1 is the old school way of connecting IP phones(Xls running 12.0 IOS). config 2 is the recommended way since it has less overhead and fewer STP instances.

4 REPLIES
Cisco Employee

Re: Voice Vlan question

config 1 is the old school way of connecting IP phones(Xls running 12.0 IOS). config 2 is the recommended way since it has less overhead and fewer STP instances.

Re: Voice Vlan question

In this case, I guess it doesn't make too much difference as long as you have configured a voice-vlan. The Cisco IP phone always checks (cisco-only) if a voice-vlan is active and will then start to communicate over this voice-vlan. When the voice-vlan is not the native vlan, this will require dot1p/q tagging which also comes in handy for QoS;-)

What I am missing in your config is something like:

int fa0/..

description CISCO PHONE

mls qos trust device cisco-phone

This line will instruct the switch to "trust" the QoS classifucation from the phone.

Regards,

Leo

New Member

Re: Voice Vlan question

this is something I need if I use the second config? We are planning on putting it in, but not till we have all of our vlan structures built...

Cisco Employee

Re: Voice Vlan question

Most platforms support Auto-QoS and you can use it. You will need to enable QOS globally and enable "auto qos" under the interfaces.

Switch(config-if)#auto qos voip ?

cisco-phone Trust the QoS marking of Cisco IP Phone

cisco-softphone Trust the QoS marking of Cisco IP SoftPhone

trust Trust the DSCP/CoS marking

153
Views
0
Helpful
4
Replies