Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

voice vlan questions

I want to configure f0/10 on catalyst 3550 to carry coice traffic in 802.1Q frames, data vlan is vlan 2(data), voice vlan is vlan 3(voice), are the following configurations correct?

vlan database

vlan 2 name data

vlan 3 name voice

configure terminal

mls qos

int f0/10

switchport mode access

switchport access vlan 2

switchport vocie vlan 3

mls qos trust cos

spanning-tree portfast

The voice vlan should be configured in vlan database, is it?

The interface mode must be access or trunk?

are there need any other configurations?

Thanks.

5 REPLIES
Silver

Re: voice vlan questions

interface FastEthernet0/10

switchport trunk encapsulation dot1q

switchport voice vlan 3

switchport trunk native vlan 2

no ip address

mls qos trust cos

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

New Member

Re: voice vlan questions

Thanks.

If use dot1p, how should I configure?

Silver

Re: voice vlan questions

You cannot use dot1p trunking, we only have dot1q and isl trunking. dot1p is the user priority bits used to classify traffic.

New Member

Re: voice vlan questions

I have a quesion for you:

I agree with your config. The problem is that in the doc (design guide qos for avvid) Cisco tells to use

no trunk

voice vlan for voice

ACCESS vlan for data behind the PC!!

It seems strange to me but it's on the cco!

Any idea regard it?

thanks

Fabio

Cisco Employee

Re: voice vlan questions

since IOS 12.1(9)EA1 there is a new approach to connecting Cisco IP phones implemented in Catalyst2950/3550 switches. This is closely resembling the Auxiliary VLAN on CatOS switches, it's called Voice Vlan and it does not require the port to be trunking.

However, if you wish to configure the port to be a trunk like in a 3500XL switch, you should be able to do that as well.

Example

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport trunk native vlan 128 <<<

switchport mode trunk

switchport voice vlan 210 <<<

spanning-tree portfast

96
Views
0
Helpful
5
Replies