Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VoIP over MLPPP over Frame (Interleaving + fragment delay problems....)

I am having problems with VoIP over MLPPP over FrameRelay, and hopefully someone can explain any bugs? or things I've misunderstood as I explain, or major problems in the config... The end aim is to use this with ATM+Serial routers.

Two Cisco 2600's back to back, with Frame-Relay (Two DSU's crossed) running on Serial WIC's

Smartbits to inject simulated voice (64 byte UDP packets) and simulated data (1514 TCP packets).

On one occassions smartbits reported that the voice packets were transmitted with a 10ms window. The next day (and a week later), I can't acheive that result again... That's where the problem is (I need the simulated voice to go end-to-end in 10ms).

- Using the command sh policy-map interface virtual-access2, I can see that the class-map correctly matches the simulated data and simulated voice into the correct class (they are fed in via different interfaces).

- Using IOS 12.2(5) on the routers, however I read somewhere that with MLPPP that percentage rather than absolute values must be used in the policy-map. That doesn't seem to work with 12.2(5) - anyone else find this? tried also 12.2(8)T1 which allows the percentage command to be configured.

- I'm guessing that hte ppp multilink interleave/ppp multilink fragment-delay commands give priority to the PRIORITY queue... or do those command look for voice (in which case my simulated voice might be to blame)?

- config below

A week of going around in circles and havn't worked it out, so hoping someone else has the answer!

Regards,

Lee

class-map match-all ONE

matched by input interface (e0/0 from VOICE simulator)

class-map match-all TWO

matched by input interface (e0/1 from DATA simulator)

policy-map QoS-Policy

class TWO

bandwidth 8 ' also tried bandwidth percent 12

class ONE

priority 30 ' also tried priority percent 50

class class-default

fair-queue

interface Serial0/0.6 point-to-point

frame-relay interface-dlci 111 ppp Virtual-Template7

class VoIP

interface Virtual-Template7

bandwidth 64

ip address 172.20.7.2 255.255.255.0

service-policy output QoS-Policy

ppp authentication chap

ppp chap hostname host1

ppp chap password 7 00141215174C04140B

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

!

map-class frame-relay VoIP

no frame-relay adaptive-shaping

frame-relay cir 64000

frame-relay bc 12000

frame-relay be 12000

frame-relay mincir 64000

1 REPLY

Re: VoIP over MLPPP over Frame (Interleaving + fragment delay pr

Since there has been no response to your post, it appears to be either too complex or too rare an issue for other forum members to assist you. If you don't get a suitable response to your post, you may wish to review our resources at the online Technical Assistance Center (http://www.cisco.com/tac) or speak with a TAC engineer. You can open a TAC case online at http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

295
Views
0
Helpful
1
Replies