Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VPDN Callback and AS5350

Hi,

From my previous post I finally got VPDN Dialback to work, now there is another problem. If I dial in using ISDN the AS5350 dials me back using ISDN, when I dial in using analogue, it still dials me back ISDN. I then reset the dialer interface, dial in analogue and it dials me back analogue, then I use ISDN again and guess what....it dials back analogue....

Any ideas?

This is my config...

------------------ show version ------------------

Cisco Internetwork Operating System Software

IOS (tm) 5350 Software (C5350-JS-M), Version 12.2(11)T1, RELEASE SOFTWARE (fc2)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Mon 30-Sep-02 15:33 by ccai

Image text-base: 0x60008948, data-base: 0x61700000

ROM: System Bootstrap, Version 12.1(2r)XD1, RELEASE SOFTWARE (fc1)

BOOTLDR: 5350 Software (C5350-BOOT-M), Experimental Version 12.1(20000922:142008) [nag-flo_t_0110 101]

RBA_AS5350-1 uptime is 1 week, 21 hours, 17 minutes

System returned to ROM by reload at 13:05:06 SA Wed Nov 20 2002

System restarted at 13:06:37 SA Wed Nov 20 2002

System image file is "flash:c5350-js-mz.122-11.T1.bin"

cisco AS5350 (R7K) processor (revision T) with 131072K/65536K bytes of memory.

Processor board ID JAE052600ES

R7000 CPU at 250Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache

Last reset from IOS reload

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

Primary Rate ISDN software, Version 1.1.

Manufacture Cookie Info:

EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x32,

Board Hardware Version 3.27, Item Number 800-5171-01,

Board Revision B0, Serial Number JAE052600ES,

PLD/ISP Version 2.2, Manufacture Date 28-Jun-2001.

Processor 0x14, MAC Address 0x044DC5482C

Backplane HW Revision 1.0, Flash Type 5V

2 FastEthernet/IEEE 802.3 interface(s)

130 Serial network interface(s)

60 terminal line(s)

4 Channelized E1/PRI port(s)

512K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

8192K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

------------------ show running-config ------------------

Building configuration...

Current configuration : 7519 bytes

!

! Last configuration change at 22:31:04 SA Tue Nov 26 2002 by satnet

! NVRAM config last updated at 22:22:49 SA Tue Nov 26 2002 by satnet

!

version 12.2

service timestamps debug uptime

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname RBA_AS5350-1

!

boot system flash c5350-js-mz.122-11.T1.bin

no boot startup-test

aaa new-model

!

!

aaa group server radius AUTH

server 10.1.92.7 auth-port 1645 acct-port 1646

server 10.1.92.5 auth-port 1645 acct-port 1646

server 10.1.91.4 auth-port 1645 acct-port 1646

server 10.1.92.2 auth-port 1645 acct-port 1646

!

aaa group server radius ACC

server 10.1.92.7 auth-port 1645 acct-port 1646

server 10.1.92.5 auth-port 1645 acct-port 1646

!

aaa authentication ppp dialup group AUTH local

aaa authorization network default group AUTH

aaa authorization network no-author none

aaa authorization network dialup group AUTH local

aaa accounting update newinfo periodic 30

aaa accounting network dialup start-stop group ACC

aaa nas port extended

aaa session-id common

enable secret 5 <removed>

enable password 7 <removed>

!

username satnet password 7 <removed>

username RBA_AS5350-1 password 7 <removed>

username l2tp-mpls-dialback-lac password 7 <removed>

username l2tp-mpls-dialback-lns password 7 <removed>

!

!

resource-pool disable

clock timezone SA 2

tdm clock priority 1 3/0

tdm clock priority 2 3/1

spe country south-africa

!

spe default-firmware spe-firmware-1

!

!

!

!

ip subnet-zero

no ip source-route

ip domain name uis.co.za

ip name-server 10.1.90.2

ip name-server 10.1.93.2

!

ip cef

!

sgbp group SBSHWH

sgbp member RBA_AS5350-2 10.1.66.3

vpdn enable

vpdn logging

vpdn logging remote

vpdn search-order domain

!

vpdn-group sbs.siemens.co.za

accept-dialout

protocol l2tp

dialer 0

terminate-from hostname l2tp-mpls-dialback-lns

local name l2tp-mpls-dialback-lac

source-ip 10.1.66.2

!

async-bootp gateway 10.1.66.2

async-bootp dns-server 10.1.90.2 10.1.93.2

isdn switch-type primary-net5

isdn voice-call-failure 0

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

!

controller E1 3/0

pri-group timeslots 1-31

!

controller E1 3/1

pri-group timeslots 1-31

!

controller E1 3/2

pri-group timeslots 1-31

!

controller E1 3/3

pri-group timeslots 1-31

!

!

!

interface FastEthernet0/0

ip address 192.168.60.2 255.255.255.0 secondary

ip address 10.1.66.2 255.255.255.0

no ip mroute-cache

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

no ip mroute-cache

shutdown

duplex full

speed 100

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

no cdp enable

!

interface Serial0/1

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

no cdp enable

!

interface Serial3/0:15

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn timer t321 40000

isdn incoming-voice modem 64

isdn T310 4000

no fair-queue

no cdp enable

!

interface Serial3/1:15

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn timer t321 40000

isdn incoming-voice modem 64

isdn T310 4000

no fair-queue

no cdp enable

!

interface Serial3/2:15

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn timer t321 40000

isdn incoming-voice modem 64

isdn T310 4000

no fair-queue

no cdp enable

!

interface Serial3/3:15

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn timer t321 40000

isdn incoming-voice modem 64

isdn T310 4000

no fair-queue

no cdp enable

!

interface Group-Async0

ip unnumbered FastEthernet0/0

no ip mroute-cache

dialer in-band

dialer rotary-group 0

dialer-group 1

async default routing

async mode dedicated

peer default ip address pool pool

no fair-queue

ppp callback accept

ppp authentication chap pap dialup

ppp authorization dialup

ppp accounting dialup

group-range 1/00 1/59

!

interface Dialer0

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

dialer in-band

dialer aaa

dialer idle-timeout 3600

dialer wait-for-carrier-time 60

dialer-group 1

peer default ip address pool pool

no fair-queue

no cdp enable

ppp callback accept

ppp authentication chap pap callin dialup

ppp authorization dialup

ppp accounting dialup

ppp multilink

!

ip local pool pool 10.1.66.4 10.1.66.124

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.66.1

no ip http server

!

!

logging 10.1.90.4

logging 10.1.89.2

access-list 4 permit 192.168.200.1

access-list 4 permit 10.1.90.4

access-list 4 permit 10.1.93.3

access-list 4 permit 10.1.91.10

access-list 4 permit 10.1.92.8

access-list 4 permit 10.1.89.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

tacacs-server host 10.1.91.10

tacacs-server key <removed>

snmp-server view configView system included

snmp-server community <removed> RO 4

snmp-server community <removed> view configView RW

snmp-server community <removed> view configView RW

snmp-server community <removed> RW 4

snmp-server contact services@uis.co.za

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps calltracker

snmp-server enable traps tty

snmp-server enable traps modem-health

snmp-server enable traps ds0-busyout

snmp-server enable traps ds1-loopback

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps isdn chan-not-avail

snmp-server enable traps fru-ctrl

snmp-server enable traps hsrp

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps envmon

snmp-server enable traps bgp

snmp-server enable traps ipmulticast

snmp-server enable traps msdp

snmp-server enable traps rsvp

snmp-server enable traps frame-relay

snmp-server enable traps syslog

snmp-server enable traps rtr

snmp-server enable traps dlsw

snmp-server enable traps dial

snmp-server enable traps dsp card-status

snmp-server enable traps voice poor-qov

snmp-server host 10.1.90.4 <removed>

!

radius-server configure-nas

radius-server host 10.1.91.4 auth-port 1645 acct-port 1646 non-standard key 7 <removed>

radius-server host 10.1.92.2 auth-port 1645 acct-port 1646 non-standard key 7 <removed>

radius-server host 10.1.92.5 auth-port 1645 acct-port 1646 non-standard key 7 <removed>

radius-server host 10.1.92.7 auth-port 1645 acct-port 1646 non-standard key 7 <removed>

radius-server retransmit 3

radius-server timeout 1

radius-server deadtime 1

radius-server key 7 <removed>

radius-server authorization permit missing Service-Type

radius-server vsa send accounting

radius-server vsa send authentication

call rsvp-sync

!

voice-port 3/0:D

!

voice-port 3/1:D

!

voice-port 3/2:D

!

voice-port 3/3:D

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

logging synchronous

line aux 0

logging synchronous

line vty 0 4

password 7 <removed>

line 1/00 1/59

no flush-at-activation

logging synchronous

modem InOut

international

transport input all

autoselect during-login

autoselect ppp

!

scheduler allocate 10000 400

end

3 REPLIES
Cisco Employee

Re: VPDN Callback and AS5350

I would say instead of using the same dialer interface for both the analog and isdn connection, use the different one for both..So pl. create the interface dialer 1 for analog termination and have same config as dialer 0 interface.

So point interface group-async 1 for interface dialer 1 using "dialer rotary-group 1".

OR

You can just use "intereface group-async 1" without pointing it to dialer

New Member

Re: VPDN Callback and AS5350

The problem is this;

vpdn-group sbs.siemens.co.za

accept-dialout

protocol l2tp

dialer 0

terminate-from hostname l2tp-mpls-dialback-lns

local name l2tp-mpls-dialback-lac

source-ip 10.1.66.2

The group profile only supports one interface to use for the dialout, in this case dialer 0, so this the only dialer it can use.

Bronze

Re: VPDN Callback and AS5350

The problem is likely that no one has really wanted to do this in the past, so the implementation may not be that robust. There was a bug CSCdp01232 which attempted to fix this to some extent, but it sounds like it's not complete. You can open a case with the TAC to have this pursued further, but in the meantime you may want to see about having different VPDN groups for your async and sync users.

174
Views
0
Helpful
3
Replies
CreatePlease login to create content