Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VPDN Callback

I've got VPDN callback to work up to the point where my pc's( xp, 98 or NT4 OS) needs to be called back. My pc answers the callback and just gets stuck on verifying username and password and then the conection times out.

I've been using the site http://www.cisco.com/warp/public/793/access_dial/vpdn_6367.html to configure VPDN Callback. I have tried this with Async and ISDN with the same problem. I've used a 7200 and 2600 as LNS instead of the 3660. I've tried no aaa on all three devices as well.

My ACS v2.4 configures the 5350 with all the atributes to create the l2tp tunnel to the 3660.

I've edited the debug towards the end to show where my pc's start with verifying username and password after the callback.

What am I missing???

LNS Config;

------------------ show version ------------------

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3660-JS-M), Version 12.2(8)T4, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sat 04-May-02 06:32 by ccai

Image text-base: 0x60008940, data-base: 0x61880000

ROM: System Bootstrap, Version 12.0(6r)T, RELEASE SOFTWARE (fc1)

MPLS_Core uptime is 2 days, 18 hours, 35 minutes

System returned to ROM by reload at 15:14:45 UTC Tue Sep 3 2002

System image file is "flash:c3660-js-mz.122-8.T4.bin"

cisco 3660 (R527x) processor (revision 1.0) with 59392K/6144K bytes of memory.

Processor board ID JAC0532A2LR

R527x CPU at 225Mhz, Implementation 40, Rev 10.0, 2048KB L2 Cache

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

Primary Rate ISDN software, Version 1.1.

Basic Rate ISDN software, Version 1.1.

3660 Chassis type: ENTERPRISE

2 FastEthernet/IEEE 802.3 interface(s)

4 Serial network interface(s)

4 ISDN Basic Rate interface(s)

1 Channelized E1/PRI port(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

16384K bytes of processor board PCMCIA Slot0 flash (Read/Write)

Configuration register is 0x2102

------------------ show running-config ------------------

Building configuration...

Current configuration : 8266 bytes

!

version 12.2

service nagle

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname MPLS_Core

!

boot system flash c3660-js-mz.122-8.T4.bin

logging buffered 4096 debugging

aaa new-model

!

!

aaa group server radius AUTH

server 172.16.92.5 auth-port 1645 acct-port 1646

!

aaa group server radius ACC

server 172.16.92.5 auth-port 1645 acct-port 1646

!

aaa authentication login default group tacacs+ group AUTH local

aaa authentication enable default group tacacs+ enable

aaa authentication ppp default if-needed group AUTH local

aaa authentication ppp none none

aaa authorization config-commands

aaa authorization exec default group tacacs+ local

aaa authorization network default group AUTH local

aaa authorization network vpdn if-authenticated none

aaa authorization configuration default group AUTH group radius

aaa accounting nested

aaa accounting update newinfo

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting network default start-stop group ACC

aaa session-id common

enable secret 5 <removed>

!

username l2tp-mpls-dialback-lac password 7 <removed>

username l2tp-mpls-dialback-lns password 7 <removed>

username mark@dialback.co.za callback-dialstring 0116523075 password 7 <removed>

memory-size iomem 10

voice-card 4

!

ip subnet-zero

!

!

ip name-server 172.16.90.2

!

!

ip vrf SBSUBS

description SBS RAS

rd 2002:1

route-target export 2002:1

route-target import 2002:1

!

!

ip vrf inet

description Internet VRF

rd 65535:0

route-target export 65535:0

route-target export 3000:1

route-target import 65535:0

route-target import 3000:1

!

ip vrf test

rd 3000:1

route-target export 3000:1

route-target export 65535:0

route-target import 3000:1

route-target import 65535:0

ip cef

virtual-profile aaa

vpdn enable

vpdn logging

vpdn logging remote

vpdn search-order domain

!

vpdn-group dialback

accept-dialin

protocol l2tp

virtual-template 2

request-dialout

protocol l2tp

pool-member 10

terminate-from hostname l2tp-mpls-dialback-lac

initiate-to ip 172.16.66.2

local name l2tp-mpls-dialback-lns

source-ip 172.16.74.250

!

tag-switching ip default-route

!

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller E1 4/0

!

!

!

!

interface Loopback0

ip address 172.16.74.250 255.255.255.255

!

interface Loopback10

ip vrf forwarding inet

ip address 10.200.200.1 255.255.255.255

!

interface Loopback11

ip vrf forwarding test

ip address 10.200.200.2 255.255.255.255

!

interface Loopback15

ip vrf forwarding SBSUBS

ip address 10.254.1.1 255.255.255.0

!

interface Loopback16

description Foschini ISDN Backup

ip vrf forwarding SMCNFOSC

ip address 10.254.254.1 255.255.255.252

!

interface Tunnel1

description To_Internet_Gateway

ip vrf forwarding inet

ip address 10.200.201.1 255.255.255.252

tunnel source 172.16.77.126

tunnel destination 172.16.77.125

tunnel mode ipip

!

interface FastEthernet0/0

ip address 172.16.77.126 255.255.255.252

speed 100

full-duplex

no mop enabled

!

interface FastEthernet0/1

ip address 172.16.67.82 255.255.255.252

speed 100

full-duplex

tag-switching mtu 1508

tag-switching ip

!

interface Serial1/0

no ip address

shutdown

no fair-queue

serial restart_delay 0

!

interface Virtual-Template2

ip unnumbered Loopback0

peer default ip address pool MPLS

ppp max-failure 10

ppp max-bad-auth 10

ppp timeout idle 3600

!

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

dialer pool 10

dialer remote-name mark@dialback.co.za

dialer idle-timeout 3600

dialer wait-for-carrier-time 60

dialer string 0116523075 class dialback

dialer hold-queue 20

dialer vpdn

dialer-group 1

peer default ip address pool MPLS

ppp max-failure 10

ppp max-bad-auth 10

ppp callback accept

ppp authentication chap callin

ppp timeout idle 3600

!

routing info omited...

!

ip local pool MPLS 10.252.1.1 10.252.1.20

ip classless

no ip http server

ip pim bidir-enable

!

ip radius source-interface Loopback0

!

!

map-class dialer dialback

dialer callback-server username

logging 172.16.89.2

dialer-list 1 protocol ip permit

!

!

radius-server host 172.16.92.5 auth-port 1645 acct-port 1646 key 7 <removed>

radius-server retransmit 3

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 7 <removed>

!

!

end

LAC Config;

------------------ show version ------------------

Cisco Internetwork Operating System Software

IOS (tm) 5350 Software (C5350-JS-M), Version 12.2(2)XB6, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Mon 17-Jun-02 19:39 by hwcheng

Image text-base: 0x600089C8, data-base: 0x61500000

ROM: System Bootstrap, Version 12.1(2r)XD1, RELEASE SOFTWARE (fc1)

BOOTLDR: 5350 Software (C5350-BOOT-M), Experimental Version 12.1(20000922:142008) [nag-flo_t_0110 101]

RBA_AS5350-1 uptime is 7 weeks, 1 day, 17 hours, 47 minutes

System returned to ROM by reload at 18:45:54 UTC Thu Jan 27 2000

System restarted at 16:26:21 UTC Wed Jul 17 2002

System image file is "flash:c5350-js-mz.122-2.XB6.bin"

cisco AS5350 (R7K) processor (revision T) with 131072K/65536K bytes of memory.

Processor board ID JAE052600ES

R7000 CPU at 250Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache

Last reset from IOS reload

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

Primary Rate ISDN software, Version 1.1.

Manufacture Cookie Info:

EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x32,

Board Hardware Version 3.27, Item Number 800-5171-01,

Board Revision B0, Serial Number JAE052600ES,

PLD/ISP Version 2.2, Manufacture Date 28-Jun-2001.

Processor 0x14, MAC Address 0x044DC5482C

Backplane HW Revision 1.0, Flash Type 5V

2 FastEthernet/IEEE 802.3 interface(s)

64 Serial network interface(s)

60 terminal line(s)

2 Channelized E1/PRI port(s)

512K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

8192K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

------------------ show running-config ------------------

Building configuration...

Current configuration : 6814 bytes

!

! Last configuration change at 23:51:20 UTC Thu Sep 5 2002

! NVRAM config last updated at 12:08:40 UTC Tue Sep 3 2002

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec localtime

service password-encryption

!

hostname RBA_AS5350-1

!

boot system flash c5350-js-mz.122-2.XB6.bin

no boot startup-test

aaa new-model

!

!

aaa group server radius AUTH

server 172.16.92.5 auth-port 1645 acct-port 1646

server 172.16.91.4 auth-port 1645 acct-port 1646

server 172.16.92.2 auth-port 1645 acct-port 1646

!

aaa group server radius ACC

server 172.16.91.4 auth-port 1645 acct-port 1646

!

aaa authentication ppp dialup group AUTH local

aaa authorization network default group AUTH

aaa authorization network no-author none

aaa authorization network dialup group AUTH local

aaa accounting update newinfo periodic 30

aaa accounting network dialup start-stop group ACC

aaa nas port extended

aaa session-id common

enable secret 5 <removed>

enable password 7 <removed>

!

username RBA_AS5350-1 password 7 <removed>

username l2tp-mpls-dialback-lac password 7 <removed>

username l2tp-mpls-dialback-lns password 7 <removed>

username lac password 7 <removed>

username lns password 7 <removed>

!

!

resource-pool disable

dial-tdm-clock priority 1 3/0

dial-tdm-clock priority 2 3/1

spe country south-africa

!

!

!

!

!

ip subnet-zero

no ip source-route

ip domain-name uis.co.za

ip name-server 172.16.90.2

ip name-server 172.16.93.2

!

ip cef

vpdn enable

vpdn logging

vpdn logging remote

vpdn search-order domain

!

vpdn-group dialback

request-dialin

protocol l2tp

domain dialback.co.za

accept-dialout

protocol l2tp

dialer 0

terminate-from hostname l2tp-mpls-dialback-lns

initiate-to ip 172.16.74.250

local name l2tp-mpls-dialback-lac

source-ip 172.16.66.2

!

async-bootp gateway 172.16.66.2

async-bootp dns-server 172.16.90.2 172.16.93.2

isdn switch-type primary-net5

isdn voice-call-failure 0

chat-script dialback ABORT ERROR ABORT BUSY ABORT "NO ANSWER" "" "ATZ" OK "ATDT\T" TIMEOUT 90 CONNECT \c

!

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller E1 3/0

pri-group timeslots 1-31

!

controller E1 3/1

pri-group timeslots 1-31

!

!

!

interface FastEthernet0/0

ip address 192.168.60.2 255.255.255.0 secondary

ip address 172.16.66.2 255.255.255.0

no ip mroute-cache

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

no ip mroute-cache

shutdown

duplex full

speed 100

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

no cdp enable

!

interface Serial0/1

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

no cdp enable

!

interface Serial3/0:15

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem 64

no fair-queue

no cdp enable

!

interface Serial3/1:15

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem 64

no fair-queue

no cdp enable

!

interface Group-Async0

ip unnumbered FastEthernet0/0

ip tcp header-compression

no ip mroute-cache

dialer in-band

dialer wait-for-carrier-time 60

dialer rotary-group 0

dialer-group 1

async default routing

async mode dedicated

peer default ip address pool pool

no fair-queue

ppp callback accept

ppp authentication chap pap dialup

ppp authorization dialup

ppp accounting dialup

group-range 1/00 1/59

!

interface Dialer0

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

dialer in-band

dialer aaa

dialer idle-timeout 3600

dialer wait-for-carrier-time 60

dialer-group 1

peer default ip address pool pool

no fair-queue

no cdp enable

ppp callback accept

ppp authentication chap pap callin dialup

ppp authorization dialup

ppp accounting dialup

ppp multilink

!

ip local pool pool 172.16.66.4 172.16.66.64

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.66.1

no ip http server

!

logging 172.16.90.4

logging 172.16.89.2

access-list 4 permit 172.16.90.4

access-list 4 permit 172.16.93.3

access-list 4 permit 172.16.91.10

access-list 4 permit 172.16.89.0 0.0.0.255

access-list 4 deny any log

dialer-list 1 protocol ip permit

!

radius-server configure-nas

radius-server host 172.16.91.4 auth-port 1645 acct-port 1646 non-standard key 7 <removed>

radius-server host 172.16.92.2 auth-port 1645 acct-port 1646 non-standard key 7 <removed>

radius-server host 172.16.92.5 auth-port 1645 acct-port 1646 non-standard key 7 <removed>

radius-server retransmit 3

radius-server timeout 1

radius-server deadtime 1

radius-server key 7 <removed>

radius-server vsa send accounting

radius-server vsa send authentication

call rsvp-sync

!

voice-port 3/0:D

compand-type a-law

!

voice-port 3/1:D

compand-type a-law

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

logging synchronous

line aux 0

logging synchronous

line vty 0 4

password 7 <removed>

line 1/00 1/59

no flush-at-activation

script callback dialback

logging synchronous

modem InOut

international

transport input all

autoselect during-login

autoselect ppp

!

scheduler allocate 10000 400

end

MPLS_Core#sh debugging

Dial on demand:

Dial on demand events debugging is on

PPP:

PPP authentication debugging is on

PPP protocol negotiation debugging is on

PPP Callback Control Protocol debugging is on

VPN:

L2X protocol events debugging is on

L2X protocol errors debugging is on

VPDN events debugging is on

VPDN errors debugging is on

VTEMPLATE:

Virtual Template debugging is on

Callback:

Callback activity debugging is on

MPLS_Core#

Sep 6 11:53:52: L2TP: I SCCRQ from l2tp-mpls-dialback-lac tnl 23693

Sep 6 11:53:52: Tnl32685 L2TP: Got a challenge in SCCRQ, l2tp-mpls-dialback-lac

Sep 6 11:53:52: Tnl32685 L2TP: New tunnel created for remote l2tp-mpls-dialback-lac, address 196.44.66.2

Sep 6 11:53:52: Tnl32685 L2TP: O SCCRP to l2tp-mpls-dialback-lac tnlid 23693

Sep 6 11:53:52: Tnl32685 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:53:52: Tnl32685 L2TP: Tunnel state change from idle to wait-ctl-reply

Sep 6 11:53:52: Tnl32685 L2TP: I SCCCN from l2tp-mpls-dialback-lac tnl 23693

Sep 6 11:53:52: Tnl32685 L2TP: Got a Challenge Response in SCCCN from l2tp-mpls-dialback-lac

Sep 6 11:53:52: Tnl32685 L2TP: Tunnel Authentication success

Sep 6 11:53:52: Tnl32685 L2TP: Tunnel state change from wait-ctl-reply to established

Sep 6 11:53:52: Tnl32685 L2TP: SM State established

Sep 6 11:53:52: Tnl32685 L2TP: I ICRQ from l2tp-mpls-dialback-lac tnl 23693

Sep 6 11:53:52: Tnl/Sn32685/62 L2TP: Session FS enabled

Sep 6 11:53:52: Tnl/Sn32685/62 L2TP: Session state change from idle to wait-for-vaccess

Sep 6 11:53:52: Tnl/Sn32685/62 L2TP: New session created

Sep 6 11:53:52: VTEMPLATE: Sending vaccess request, id 0x7FAD003E

Sep 6 11:53:52: VTEMPLATE: Processing vaccess requests, 1 outstanding

Sep 6 11:53:52: Vt2 VTEMPLATE: (Pre)cloning vaccess from recycle queue

Sep 6 11:53:52: Vi18 MCB: Initialize

Sep 6 11:53:52: Vi18 PPP: Phase is DOWN, Setup

Sep 6 11:53:52: Vi18 VTEMPLATE: Has a new cloneblk vtemplate, now it has vtemplate

Sep 6 11:53:52: Vi18 VTEMPLATE: ************* CLONE VACCESS18 *****************

Sep 6 11:53:52: Vi18 VTEMPLATE: Clone from Virtual-Template2

default ip address

encap ppp

ip unnumbered Loopback0

ip unnumbered Loopback0

serial restart_delay 0

end

Sep 6 11:53:52: Vi18 VTEMPLATE: Messages from (un)cloning ...

Can't set restart-delay for this interface

Sep 6 11:53:52: VTEMPLATE: Receiving vaccess request, id 0x7FAD003E, result 1

Sep 6 11:53:52: Tnl/Sn32685/62 L2TP: O ICRP to l2tp-mpls-dialback-lac 23693/429

Sep 6 11:53:52: Tnl32685 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:53:52: Tnl/Sn32685/62 L2TP: Session state change from wait-for-vaccess to wait-connect

Sep 6 11:53:52: Tnl/Sn32685/62 L2TP: I ICCN from l2tp-mpls-dialback-lac tnl 23693, cl 429

Sep 6 11:53:52: VPDN: Callback negotiated

Sep 6 11:53:52: mark@dialback.co.za Tnl/Sn32685/62 L2TP: Session state change from wait-connect to wait-for-new-vaccess

Sep 6 11:53:52: Vi18 VTEMPLATE: Free vaccess

Sep 6 11:53:52: VTEMPLATE: Sending vaccess request, id 0x7FAD003E

Sep 6 11:53:52: VTEMPLATE: Clean up dirty vaccess queue, size 1

Sep 6 11:53:52: Vi18 VTEMPLATE: Found a dirty vaccess clone with vtemplate

Sep 6 11:53:52: Vi18 VTEMPLATE: ************ UNCLONE VACCESS18 **************

Sep 6 11:53:52: Vi18 VTEMPLATE: Unclone to-be-freed command#4

default serial restart_delay 0

default ip unnumbered Loopback0

default ip unnumbered Loopback0

default encap ppp

end

Sep 6 11:53:52: Vi18 VTEMPLATE: Messages from (un)cloning ...

Can't set restart-delay for this interface

Sep 6 11:53:52: Vi18 VTEMPLATE: Remove cloneblk vtemplate with vtemplate

Sep 6 11:53:52: Vi18 VTEMPLATE: Set default settings with no ip address

Sep 6 11:53:52: Vi18 VTEMPLATE: Add vaccess to recycle queue, queue size 1

Sep 6 11:53:52: VTEMPLATE: Processing vaccess requests, 1 outstanding

Sep 6 11:53:52: Vi18 VTEMPLATE: Reuse Vi18, recycle queue size 0

Sep 6 11:53:52: Vi18 VTEMPLATE: Hardware address 0006.d763.9d60

Sep 6 11:53:52: Vi18 VTEMPLATE: Has a new cloneblk dialer, now it has dialer

Sep 6 11:53:52: VTEMPLATE: Receiving vaccess request, id 0x7FAD003E, result 1

Sep 6 11:53:52: Vi18 VPDN: Set to Async interface

Sep 6 11:53:52: Vi18 VPDN: Virtual interface created for mark@dialback.co.za bandwidth 52 Kbps

Sep 6 11:53:52: Vi18 VPDN: Bind interface direction=2

Sep 6 11:53:52: Vi18 PPP: Authorization required

Sep 6 11:53:52: Vi18 PPP: Phase is ESTABLISHING

Sep 6 11:53:52: Vi18 Tnl/Sn32685/62 L2TP: Session state change from wait-for-new-vaccess to established

Sep 6 11:53:52: Vi18 LCP: I FORCED rcvd CONFACK len 21

Sep 6 11:53:52: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:53:52: Vi18 LCP: AuthProto CHAP (0x0305C22305)

Sep 6 11:53:52: Vi18 LCP: MagicNumber 0x0A021579 (0x05060A021579)

Sep 6 11:53:52: Vi18 LCP: PFC (0x0702)

Sep 6 11:53:52: Vi18 LCP: ACFC (0x0802)

Sep 6 11:53:52: Vi18 LCP: I FORCED sent CONFACK len 19

Sep 6 11:53:52: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:53:52: Vi18 LCP: MagicNumber 0x11E73E00 (0x050611E73E00)

Sep 6 11:53:52: Vi18 LCP: PFC (0x0702)

Sep 6 11:53:52: Vi18 LCP: ACFC (0x0802)

Sep 6 11:53:52: Vi18 LCP: Callback 6 (0x0D0306)

Sep 6 11:53:52: Vi18 PPP: Phase is FORWARDING, Attempting Forward

Sep 6 11:53:52: Vi18 PPP: Phase is AUTHENTICATING, Unauthenticated User

Sep 6 11:53:52: Vi18 MCB: Initialize

Sep 6 11:53:52: Vi18 MCB: Flush

Sep 6 11:53:52: Vi18 Tnl/Sn32685/62 L2TP: O SLI to l2tp-mpls-dialback-lac 23693/429

Sep 6 11:53:52: Vi18 Tnl/Sn32685/62 L2TP: Sending send ACCM 0x00000000 and receive ACCM 0x000A0000

Sep 6 11:53:52: Tnl32685 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:53:52: Vi18 PPP: Sent CHAP LOGIN Request to AAA

Sep 6 11:53:52: %LINK-3-UPDOWN: Interface Virtual-Access18, changed state to up

Sep 6 11:53:52: Vi18 DDR: Dialer statechange to up

Sep 6 11:53:52: %DIALER-6-BIND: Interface Vi18 bound to profile Di1

Sep 6 11:53:52: Vi18 PPP: Received LOGIN Response from AAA = PASS

Sep 6 11:53:52: Vi18 PPP: Phase is FORWARDING, Attempting Forward

Sep 6 11:53:52: Vi18 PPP: Phase is AUTHENTICATING, Authenticated User

Sep 6 11:53:52: Vi18 DDR: Remote name for mark@dialback.co.za

Sep 6 11:53:52: Vi18 CHAP: O SUCCESS id 132 len 4

Sep 6 11:53:52: Vi18 MCB: Start

Sep 6 11:53:52: Vi18 MCB: User mark@dialback.co.za Callback Number - Server 0116523075

Sep 6 11:53:52: Vi18 MCB: Newstate 0-INIT -> 2-WAIT_RESPONSE

Sep 6 11:53:52: Virtual-Access18 PPP: O MCB Request(1) id 5 len 7

Sep 6 11:53:52: Virtual-Access18 MCB: O 1 5 0 7 3 3 0

Sep 6 11:53:52: Vi18 MCB: O Request Id 5 Callback Type Server-Num delay 0

Sep 6 11:53:52: Vi18 PPP: Phase is CBCP

Sep 6 11:53:52: Virtual-Access18 PPP: I MCB Response(2) id 5 len 7

Sep 6 11:53:52: Virtual-Access18 MCB: I 2 5 0 7 3 3 C

Sep 6 11:53:52: Vi18 MCB: Received response

Sep 6 11:53:52: Vi18 MCB: Response CBK-Server-Num 3 3 12

Sep 6 11:53:52: Virtual-Access18 PPP: O MCB Ack(3) id 6 len 7

Sep 6 11:53:52: Virtual-Access18 MCB: O 3 6 0 7 3 3 C

Sep 6 11:53:52: Vi18 MCB: O Ack Id 6 Callback Type Server-Num delay 12

Sep 6 11:53:52: Vi18 MCB: Negotiated MCB with peer

Sep 6 11:53:52: Vi18 MCB: Newstate 2-WAIT_RESPONSE -> 3-WAIT_TERMINATE

Sep 6 11:53:52: Vi18 LCP: I TERMREQ [Open] id 3 len 16 (0x11E73E00003CCD7400000000)

Sep 6 11:53:52: Vi18 LCP: O TERMACK [Open] id 3 len 4

Sep 6 11:53:52: Vi18 MCB: Peer terminating the link

Sep 6 11:53:52: Vi18 MCB: Newstate 3-WAIT_TERMINATE -> 5-WAIT_LINKDOWN

Sep 6 11:53:52: Vi18 PPP: Phase is TERMINATING

Sep 6 11:53:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access18, changed state to up

Sep 6 11:53:54: Vi18 LCP: TIMEout: State TERMsent

Sep 6 11:53:54: Vi18 LCP: State is Closed

Sep 6 11:53:54: Vi18 MCB: Link terminated by peer, Callback Needed

Sep 6 11:53:54: Vi18 MCB: Newstate 5-WAIT_LINKDOWN -> 6-CALLING

Sep 6 11:53:54: Vi18 MCB: Initiate Callback for mark@dialback.co.za at 0116523075 using ISDN DDR

Sep 6 11:53:54: Vi18 DDR: PPP callback Callback server starting to mark@dialback.co.za 0116523075

Sep 6 11:53:54: Vi18 VPDN: Reset

Sep 6 11:53:54: Vi18 Tnl/Sn32685/62 L2TP: O CDN to l2tp-mpls-dialback-lac 23693/429

Sep 6 11:53:54: Tnl32685 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:53:54: Vi18 Tnl/Sn32685/62 L2TP: Destroying session

Sep 6 11:53:54: Vi18 Tnl/Sn32685/62 L2TP: Session state change from established to idle

Sep 6 11:53:54: Vi18 Tnl/Sn32685/62 L2TP: Releasing idb for LAC/LNS tunnel 32685/23693 session 62 state idle

Sep 6 11:53:54: Vi18 VPDN: Unbind interface

Sep 6 11:53:54: %DIALER-6-UNBIND: Interface Vi18 unbound from profile Di1

Sep 6 11:53:54: Vi18 VTEMPLATE: Free vaccess

Sep 6 11:53:54: Tnl32685 L2TP: Tunnel state change from established to no-sessions-left

Sep 6 11:53:54: Tnl32685 L2TP: No more sessions in tunnel, shutdown (likely) in 10 seconds

Sep 6 11:53:54: Vi18 MCB: Dialer callback started

Sep 6 11:53:54: Vi18 PPP: Phase is DOWN

Sep 6 11:53:54: Vi18 PPP: Phase is ESTABLISHING, Passive Open

Sep 6 11:53:54: Vi18 LCP: State is Listen

Sep 6 11:53:54: %LINK-3-UPDOWN: Interface Virtual-Access18, changed state to down

Sep 6 11:53:54: VTEMPLATE: Clean up dirty vaccess queue, size 1

Sep 6 11:53:54: Vi18 VTEMPLATE: Found a dirty vaccess clone with dialer

Sep 6 11:53:54: Vi18 VTEMPLATE: Remove cloneblk dialer with dialer

Sep 6 11:53:54: Vi18 VTEMPLATE: Set default settings with no ip address

Sep 6 11:53:54: Vi18 VTEMPLATE: Add vaccess to recycle queue, queue size 1

Sep 6 11:53:54: Vi18 LCP: State is Closed

Sep 6 11:53:54: Vi18 PPP: Phase is DOWN

Sep 6 11:53:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access18, changed state to down

Sep 6 11:54:04: Tnl32685 L2TP: O StopCCN to l2tp-mpls-dialback-lac tnlid 23693

Sep 6 11:54:04: Tnl32685 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:54:04: Tnl32685 L2TP: Tunnel state change from no-sessions-left to shutting-down

Sep 6 11:54:04: Tnl32685 L2TP: Shutdown tunnel

Sep 6 11:54:04: Tnl32685 L2TP: Tunnel state change from shutting-down to idle

Sep 6 11:54:09: DDR: Callback timer expired

Sep 6 11:54:09: Di1 DDR: beginning callback to mark@dialback.co.za 0116523075

Sep 6 11:54:09: Vi18 VTEMPLATE: Reuse Vi18, recycle queue size 0

Sep 6 11:54:09: Vi18 VTEMPLATE: Hardware address 0006.d763.9d60

Sep 6 11:54:09: Vi18 MCB: Initialize

Sep 6 11:54:09: Vi18 PPP: Phase is DOWN, Setup

Sep 6 11:54:09: Vi18 VTEMPLATE: Has a new cloneblk dialer, now it has dialer

Sep 6 11:54:09: Vi18 DDR: Dialing cause Callback return call

Sep 6 11:54:09: Vi18 DDR: Attempting to dial 0116523075

Sep 6 11:54:09: DDR: Freeing callback to mark@dialback.co.za 0116523075

Sep 6 11:54:09: Tnl/Sn50420/63 L2TP: Session FS enabled

Sep 6 11:54:09: Tnl/Sn50420/63 L2TP: Session state change from idle to wait-for-tunnel

Sep 6 11:54:09: Vi18 Tnl/Sn50420/63 L2TP: Create session

Sep 6 11:54:09: Tnl50420 L2TP: SM State idle

Sep 6 11:54:09: Tnl50420 L2TP: O SCCRQ to l2tp-mpls-dialback-lac tnlid 0

Sep 6 11:54:09: Tnl50420 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:54:09: Tnl50420 L2TP: Tunnel state change from idle to wait-ctl-reply

Sep 6 11:54:09: Tnl50420 L2TP: SM State wait-ctl-reply

Sep 6 11:54:09: Tnl50420 L2TP: I SCCRP from l2tp-mpls-dialback-lac

Sep 6 11:54:09: Tnl50420 L2TP: Got a challenge from remote peer, l2tp-mpls-dialback-lac

Sep 6 11:54:09: Tnl50420 L2TP: Got a response from remote peer, l2tp-mpls-dialback-lac

Sep 6 11:54:09: Tnl50420 L2TP: Tunnel Authentication success

Sep 6 11:54:09: Tnl50420 L2TP: Tunnel state change from wait-ctl-reply to established

Sep 6 11:54:09: Tnl50420 L2TP: O SCCCN to l2tp-mpls-dialback-lac tnlid 52514

Sep 6 11:54:09: Tnl50420 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:54:09: Tnl50420 L2TP: SM State established

Sep 6 11:54:09: L2TP: O OCRQ

Sep 6 11:54:09: Vi18 Tnl/Sn50420/63 L2TP: Session state change from wait-for-tunnel to wait-reply

Sep 6 11:54:09: Vi18 Tnl/Sn50420/63 L2TP: I OCRP from l2tp-mpls-dialback-lac tnl 52514, cl 0

Sep 6 11:54:09: Vi18 Tnl/Sn50420/63 L2TP: Session state change from wait-reply to wait-connect

Sep 6 11:54:40: Vi18 Tnl/Sn50420/63 L2TP: I OCCN from l2tp-mpls-dialback-lac tnl 52514, cl 430

Sep 6 11:54:40: Vi18 Tnl/Sn50420/63 L2TP: Session state change from wait-connect to established

Sep 6 11:54:40: Vi18 VPDN: Bind interface direction=2

Sep 6 11:54:40: %LINK-3-UPDOWN: Interface Virtual-Access18, changed state to up

Sep 6 11:54:40: Vi18 DDR: Dialer statechange to up

Sep 6 11:54:40: %DIALER-6-BIND: Interface Vi18 bound to profile Di1

Sep 6 11:54:40: Vi18 DDR: Dialer call has been placed

Sep 6 11:54:40: Vi18 PPP: Treating connection as a callout

Sep 6 11:54:40: Vi18 PPP: Phase is ESTABLISHING, Active Open

Sep 6 11:54:40: Vi18 PPP: Authorization required

Sep 6 11:54:40: Vi18 PPP: No remote authentication for callback

This is where the problem is, my XP workstation just gets stuck on verifying user name and password while the

following output is produced on the 3660 LNS

Sep 6 11:54:40: Vi18 LCP: O CONFREQ [Closed] id 1 len 20

Sep 6 11:54:40: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:40: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:40: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:40: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:40: Vi18 LCP: I CONFREQ [REQsent] id 0 len 20

Sep 6 11:54:40: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:40: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:40: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:40: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:40: Vi18 LCP: O CONFACK [REQsent] id 0 len 20

Sep 6 11:54:40: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:40: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:40: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:40: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:42: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:42: Vi18 LCP: O CONFREQ [ACKsent] id 2 len 20

Sep 6 11:54:42: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:42: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:42: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:42: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:42: Vi18 LCP: I CONFREQ [ACKsent] id 1 len 20

Sep 6 11:54:42: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:42: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:42: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:42: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:42: Vi18 LCP: O CONFACK [ACKsent] id 1 len 20

Sep 6 11:54:42: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:42: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:42: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:42: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:45: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:45: Vi18 LCP: O CONFREQ [ACKsent] id 3 len 20

Sep 6 11:54:45: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:45: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:45: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:45: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:45: Vi18 LCP: I CONFREQ [ACKsent] id 2 len 20

Sep 6 11:54:45: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:45: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:45: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:45: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:45: Vi18 LCP: O CONFACK [ACKsent] id 2 len 20

Sep 6 11:54:45: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:45: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:45: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:45: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:47: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:47: Vi18 LCP: O CONFREQ [ACKsent] id 4 len 20

Sep 6 11:54:47: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:47: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:47: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:47: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:49: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:49: Vi18 LCP: O CONFREQ [ACKsent] id 5 len 20

Sep 6 11:54:49: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:49: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:49: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:49: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:49: Vi18 LCP: I CONFREQ [ACKsent] id 3 len 20

Sep 6 11:54:49: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:49: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:49: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:49: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:49: Vi18 LCP: O CONFACK [ACKsent] id 3 len 20

Sep 6 11:54:49: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:49: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:49: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:49: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:51: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:51: Vi18 LCP: O CONFREQ [ACKsent] id 6 len 20

Sep 6 11:54:51: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:51: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:51: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:51: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:53: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:53: Vi18 LCP: O CONFREQ [ACKsent] id 7 len 20

Sep 6 11:54:53: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:53: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:53: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:53: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:53: Vi18 LCP: I CONFREQ [ACKsent] id 4 len 20

Sep 6 11:54:53: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:53: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:53: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:53: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:53: Vi18 LCP: O CONFACK [ACKsent] id 4 len 20

Sep 6 11:54:53: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:53: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:53: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:53: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:55: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:55: Vi18 LCP: O CONFREQ [ACKsent] id 8 len 20

Sep 6 11:54:55: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:55: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:55: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:55: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:57: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:57: Vi18 LCP: O CONFREQ [ACKsent] id 9 len 20

Sep 6 11:54:57: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:57: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:57: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:57: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:57: Vi18 LCP: I CONFREQ [ACKsent] id 5 len 20

Sep 6 11:54:57: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:57: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:57: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:57: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:57: Vi18 LCP: O CONFACK [ACKsent] id 5 len 20

Sep 6 11:54:57: Vi18 LCP: ACCM 0x00000000 (0x020600000000)

Sep 6 11:54:57: Vi18 LCP: MagicNumber 0x7EBF7ECB (0x05067EBF7ECB)

Sep 6 11:54:57: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:57: Vi18 LCP: ACFC (0x0802)

Sep 6 11:54:59: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:54:59: Vi18 LCP: O CONFREQ [ACKsent] id 10 len 20

Sep 6 11:54:59: Vi18 LCP: ACCM 0x000A0000 (0x0206000A0000)

Sep 6 11:54:59: Vi18 LCP: MagicNumber 0x15929BD0 (0x050615929BD0)

Sep 6 11:54:59: Vi18 LCP: PFC (0x0702)

Sep 6 11:54:59: Vi18 LCP: ACFC (0x0802)

Sep 6 11:55:01: Vi18 LCP: TIMEout: State ACKsent

Sep 6 11:55:01: Vi18 VPDN: Reset

Sep 6 11:55:01: Vi18 Tnl/Sn50420/63 L2TP: O CDN to l2tp-mpls-dialback-lac 52514/430

Sep 6 11:55:01: Tnl50420 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:55:01: Vi18 Tnl/Sn50420/63 L2TP: Destroying session

Sep 6 11:55:01: Vi18 Tnl/Sn50420/63 L2TP: Session state change from established to idle

Sep 6 11:55:01: Vi18 Tnl/Sn50420/63 L2TP: Releasing idb for LAC/LNS tunnel 50420/52514 session 63 state idle

Sep 6 11:55:01: Tnl50420 L2TP: Tunnel state change from established to no-sessions-left

Sep 6 11:55:01: Tnl50420 L2TP: No more sessions in tunnel, shutdown (likely) in 10 seconds

Sep 6 11:55:01: Vi18 LCP: State is Listen

Sep 6 11:55:01: Vi18 VPDN: Unbind interface

Sep 6 11:55:01: %DIALER-6-UNBIND: Interface Vi18 unbound from profile Di1

Sep 6 11:55:01: Vi18 VTEMPLATE: Free vaccess

Sep 6 11:55:01: %LINK-3-UPDOWN: Interface Virtual-Access18, changed state to down

Sep 6 11:55:01: VTEMPLATE: Clean up dirty vaccess queue, size 1

Sep 6 11:55:01: Vi18 VTEMPLATE: Found a dirty vaccess clone with dialer

Sep 6 11:55:01: Vi18 VTEMPLATE: Remove cloneblk dialer with dialer

Sep 6 11:55:01: Vi18 VTEMPLATE: Set default settings with no ip address

Sep 6 11:55:01: Vi18 VTEMPLATE: Add vaccess to recycle queue, queue size 1

Sep 6 11:55:01: Vi18 LCP: State is Closed

Sep 6 11:55:01: Vi18 PPP: Phase is DOWN

Sep 6 11:55:11: Tnl50420 L2TP: O StopCCN to l2tp-mpls-dialback-lac tnlid 52514

Sep 6 11:55:11: Tnl50420 L2TP: Control channel retransmit delay set to 1 seconds

Sep 6 11:55:11: Tnl50420 L2TP: Tunnel state change from no-sessions-left to shutting-down

Sep 6 11:55:11: Tnl50420 L2TP: Shutdown tunnel

Sep 6 11:55:11: Tnl50420 L2TP: Tunnel state change from shutting-down to idle

4 REPLIES
Community Member

Re: VPDN Callback

Looking over the configuration it seems to be configured correctly. The following link has some more in depth configurations that might solve your issue. http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/dialns_c/dnsprt3/dcdvpn.htm

Community Member

Re: VPDN Callback

Thanks for your reply. I have searched every bit of this document but I still have the same problem. Do you have this running? If so what IOS and router platforms are you using?

Bronze

Re: VPDN Callback

I would be inclinded to open a case with the TAC; it could very well be that this is an issue with the LAC rather than the LNS. As you see, the callback completes and the LNS sees the CONFREQ's from the remote. However, it appears that the remote is not receiving anything from the LNS; this could be due to the LNS not actually sending the packets out, or that the LAC is not forwarding the packets correctly. I would be inclinded to suspect the LAC as much as the LNS. To verify, there will likely be a need for some show and debug output from both the LAC and LNS, which is why I think a case with the TAC would be best.

Community Member

Re: VPDN Callback

It was the IOS of the LAC if anyone was interested....I upgraded to 12.2(11)T1 and it worked first time.

278
Views
0
Helpful
4
Replies
CreatePlease to create content