Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

vpn connection

Hi all, when setting up a vpn connection using a client and server setup, Do I just get the server to issue dhcp addresses out, and if so do I just add a route to that network from my server location, how would I do this on my router ?

  • Other Network Infrastructure Subjects
5 REPLIES

Re: vpn connection

Hi

I would recommend DHCP.

Pls tell us what is your setup and what is the configuration on both the routers.

Regards

JD

New Member

Re: vpn connection

I have not yet configured the setup, I want my cisco 1700 router to have the config on, then I connect with a vpn client to that network. i want to give out dhcp addresses to my clients, All authentication will be done on the 1700 router, can someone show me an example config ?

Re: vpn connection

Hi

I am attaching one of my running config.It is using l2tp.

Router#sh run

Building configuration...

Current configuration : 1597 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

username jaideep@cisco.com password 0 jaideep

username jaideep password 0 jaideep

username brij password 0 brij

no network-clock-participate slot 1

no network-clock-participate wic 0

aaa new-model

!

!

aaa authentication login default local

aaa authentication login NO_AUTHEN none

aaa authentication ppp default local

aaa session-id common

ip subnet-zero

ip cef

!

!

!

vpdn enable

!

vpdn-group 1

! Default L2TP VPDN group

! Default PPTP VPDN group

accept-dialin

protocol any

virtual-template 1

l2tp tunnel password 0 cisco

interface FastEthernet0/0

ip address 10.0.0.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

ip address 192.168.1.211 255.255.255.0

ip nat outside

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

interface Serial1/0

no ip address

shutdown

clockrate 2000000

!

interface Serial1/1

no ip address

shutdown

clockrate 2000000

!

interface Virtual-Template1

ip unnumbered FastEthernet0/1

peer default ip address pool CISCO

ppp authentication pap chap callin

ppp multilink

!

ip local pool CISCO 10.0.0.10 10.0.0.20

ip nat inside source list 1 interface FastEthernet0/1 overload

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

!

!

access-list 1 permit 10.0.0.0 0.0.0.255

!

!

line con 0

line aux 0

line vty 0 4

!

!

end

Hope this helps.

Pls rate helpful posts.

Regards

JD

Router#

Router#

Router#

New Member

Re: vpn connection

thats quite a big config, can you possibly tell me what things mean on it ? also what id layer 2 tunneling ?

Re: vpn connection

Hi

Man the bigger the configuration...the better networking expert you are :D)

If you will look at the config, there are 3 major parts:

(1)AAA server auth. on router.

(2)Layer 2 VPN config.

(3)Bit change on the Virtual-interface.......

Thats it.

Regards

JD

114
Views
0
Helpful
5
Replies
This widget could not be displayed.