Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VRF-Lite CE configuration

Hello. I was wondering if it's possible to have a CE router send routes between customer routers in the same VLAN? I have a situation where I have a customer with two routers that hookup to my CE switch. I'm receiving routes from both customer routers in the VRF i've setup. But the customer routers aren't seeing routes learned from the CE switch.

Any help would be greatly appreciated.

3 REPLIES
Purple

Re: VRF-Lite CE configuration

Hi Mike,

Could you provide a bit of your config ?

Paresh

New Member

Re: VRF-Lite CE configuration

Hi Paresh.

Here's the config from the CE router...

ip vrf vrf_168

rd 192.168.53.2:1

interface Vlan167

ip vrf forwarding vrf_168

ip address 192.168.53.35 255.255.255.224

no ip redirects

no ip unreachables

ip ospf authentication

ip ospf authentication-key xxxx

ip ospf priority 230

!

interface Vlan168

ip vrf forwarding vrf_168

ip address 192.168.53.2 255.255.255.224

ip access-group acl_premiumdsl_filter in

no ip redirects

no ip unreachables

ip ospf authentication

ip ospf authentication-key 7 095C5C0C1401041E5A

ip ospf network point-to-multipoint

ip ospf priority 250

!

router ospf 3 vrf vrf_168

router-id 192.168.53.2

log-adjacency-changes

capability vrf-lite

area 0 authentication

network 192.168.53.0 0.0.0.255 area 0

I have one router connected off interface vlan 168 and one router off vlan 167. If I do a show ip route vrf vrf_168 I see the routes from both routers.

But if I go to either of these spoke routers and do a show ip ospf database 192.168.53.2 I don't see any of the external routes that I should be seeing...I only see the connected routes in the vrf.

Mike

Purple

Re: VRF-Lite CE configuration

Mike,

Could you post the output of 'sh ip ospf neighbors' and 'sh ip ospf database' from the three routers that you have ?

Thanks,

Paresh

120
Views
0
Helpful
3
Replies
CreatePlease to create content