Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
Bronze

VTP Between 3750 and 2811

Hey All,

I'm attempting to create a trunk between a 3750 and a Cisco 2811 router (with a 16 port switching module NM-16-ESW). I'm using an etherchannel trunk between the two. I'm trying to configure VTP on the 3750 (server) and make the 2811 a client. Below is a copy of the configs and output from relevant commands. Any clue why I'm not seeing vlans on the 2811?

2811 Router Config:

!

interface Port-channel1

switchport mode trunk

!

nterface FastEthernet1/14

switchport mode trunk

channel-group 1 mode on

!

interface FastEthernet1/15

switchport mode trunk

channel-group 1 mode on

MPLS-TEST#sh vlans

No Virtual LANs configured.

MPLS-TEST#sh vtp status

VTP Version : 2

Configuration Revision : 1

Maximum VLANs supported locally : 256

Number of existing VLANs : 6

VTP Operating Mode : Client

VTP Domain Name : VTP

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xE7 0x0F 0xE8 0x89 0x47 0xAE 0x7E 0x7B

Configuration last modified by <IP of 3750> at 3-1-93 00:06:05

3750 Config and Shows:

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet1/0/47

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface FastEthernet1/0/48

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

sw-upstairs#sh vtp status

VTP Version : 2

Configuration Revision : 1

Maximum VLANs supported locally : 1005

Number of existing VLANs : 6

VTP Operating Mode : Server

VTP Domain Name : VTP

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xE7 0x0F 0xE8 0x89 0x47 0xAE 0x7E 0x7B

Configuration last modified by <IP of VLAN 1> at 3-1-93 00:06:05

Local updater ID is 134.178.220.224 on interface Vl1 (lowest numbered VLAN interface found)

sw-upstairs#sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa1/0/1, Fa1/0/2, Fa1/0/3

Fa1/0/4, Fa1/0/5, Fa1/0/6

Fa1/0/7, Fa1/0/8, Fa1/0/9

Fa1/0/10, Fa1/0/11, Fa1/0/12

Fa1/0/13, Fa1/0/14, Fa1/0/15

Fa1/0/16, Fa1/0/17, Fa1/0/18

Fa1/0/19, Fa1/0/20, Fa1/0/21

Fa1/0/22, Fa1/0/23, Fa1/0/24

Fa1/0/25, Fa1/0/26, Fa1/0/27

Fa1/0/28, Fa1/0/29, Fa1/0/30

Fa1/0/31, Fa1/0/32, Fa1/0/33

Fa1/0/34, Fa1/0/35, Fa1/0/36

Fa1/0/37, Fa1/0/38, Fa1/0/39

Fa1/0/40, Fa1/0/41, Fa1/0/42

Fa1/0/43, Fa1/0/44, Fa1/0/45

Fa1/0/46, Gi1/0/1, Gi1/0/2

Gi1/0/3, Gi1/0/4

5 INTERNET active

I'm baffled why these vlans aren't showing on my 2811. Any ideas?

Thanks,

Mike

6 REPLIES

Re: VTP Between 3750 and 2811

Can you post the show vlan on 2811? The show vtp stat shows that the VTP is updated by the 3750 and they both have the same number of vlans - 6.

Only the vlan information will be on VTP, VTP will not assign the vlans to the ports, if that's what you are asking. Show vtp stat on 2811 looks like vtp are being exchaged between 3750 and 2811.

Please rate helpful posts.

Bronze

Re: VTP Between 3750 and 2811

I posted the sh vlans for the 2811 above but here it is again:

MPLS#sh vlans

No Virtual LANs configured.

For kicks I even tried assigning the INTERNET vlan to one of the ports on the 2811 (fa1/1), and it took the change but when I attempt to do a sh vlans on the 2811 I still get "No Virtual LANs configured." I know I need to assign the vlans to the ports, but we use VTP between our 6509s and 3750s and all the VLANs show on all the switches... even if they are not assigned to a port on that switch. Here's some more output if it provides any help:

MPLS#sh vtp counters

VTP statistics:

Summary advertisements received : 16

Subset advertisements received : 1

Request advertisements received : 0

Summary advertisements transmitted : 14

Subset advertisements transmitted : 1

Request advertisements transmitted : 50

Number of config revision errors : 0

Number of config digest errors : 0

Number of V1 summary errors : 0

VTP pruning statistics:

Trunk Join Transmitted Join Received Summary advts received from

non-pruning-capable device

---------------- ---------------- ---------------- ---------------------------

Po1 0 0 0

Thanks for the input,

Mike

New Member

Re: VTP Between 3750 and 2811

Hi!

What about the encapsulation in under the interface port-channel?ISL Or Dot1.Q?I'm not seen this!

New Member

Re: VTP Between 3750 and 2811

Hi Mike

Try to disable the password, by using

"no vtp password" on both.

HTH

Re: VTP Between 3750 and 2811

Hello,

I hope I do not add to the confusion, but have you defined the VLAN interfaces on your 2811 ? Can you post the full config of your 2811 ?

Regards,

GNT

Bronze

Re: VTP Between 3750 and 2811

Hey All,

Thanks for the input! I was actually able to solve the issue. It appears that "sh vlans" is different on an IOS router than an IOS switch. On the router it shows sub-interface ISL/dot1q trunks to a switch. This is obviously different for me as I have a switching card. In order to see VTP in action on the router and verify it was working I actually needed to view it through the VLAN database. See below:

MPLS-TEST#vlan database

MPLS-TEST(vlan)#show

VLAN ISL Id: 1

Name: default

Media Type: Ethernet

VLAN 802.10 Id: 100001

State: Operational

MTU: 1500

VLAN ISL Id: 5

Name: INTERNET

Media Type: Ethernet

VLAN 802.10 Id: 100005

State: Operational

MTU: 1500

VLAN ISL Id: 10

Name: INTERNET-DMZ

Media Type: Ethernet

VLAN 802.10 Id: 100010

State: Operational

MTU: 1500

VLAN ISL Id: 20

Name: PRODUCTION

Media Type: Ethernet

VLAN 802.10 Id: 100020

State: Operational

MTU: 1500

VLAN ISL Id: 25

Name: LAPTOPS

Media Type: Ethernet

VLAN 802.10 Id: 100025

State: Operational

MTU: 1500

VLAN ISL Id: 30

Name: NETWORK-DISTRIBUTION

Media Type: Ethernet

VLAN 802.10 Id: 100030

State: Operational

MTU: 1500

VLAN ISL Id: 250

Name: BGP-ROUTING

Media Type: Ethernet

VLAN 802.10 Id: 100250

Certainly is confusing and left me scratching my head. Thanks for the help though! I through this up on my blog too so someone in the future isn't chasing his/her tail

-Mike

http://cs-mars.blogspot.com

1022
Views
0
Helpful
6
Replies
CreatePlease to create content