Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VTP Domain Name and Transparent Mode

Can two switches connect via a trunk, one as a server and one as transparent and be in two different VTP domains respectively?

20 REPLIES

Re: VTP Domain Name and Transparent Mode

HI

U want just physical connection or u want the vlan info to sync with the other switch.

First if a switch is in VTP transparent mode it doesnt sync with vtp messages but it can forward u r vtp messages to other switches if u r using vtp version 2.

And if they are in two diff vtp domains they cannot exchange any vlan info.

Thanks

Mahmood

New Member

Re: VTP Domain Name and Transparent Mode

Unfortunatly I need them to pass vlan information. I just have to give up and accept this implementation isn't going to work. I'll have to eliminate the two transparent switches. Thanks.

New Member

Re: VTP Domain Name and Transparent Mode

Another suggestion... not sure what the overall goal is, but I think 802.1Q/Layer 2 protocol tunneling would work in this case:

Configuring 802.1Q and Layer 2 Protocol Tunneling

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a008062cf6c.html

Re: VTP Domain Name and Transparent Mode

hi,,,

ya two switches can connect using trunk link...u can configure one switch as server and one as transparent but they must be in one vtp domain in order to make consistent switching network topology...

regards

Devang

New Member

Re: VTP Domain Name and Transparent Mode

I figured that was the issue. I have 4 switches in all. 1) Server, 2) Transparent_1, 3)Transparent_2 and 4)Client. I need the Server(1) to communicate with the Client(4) through the two transparent switches(2&3). The two transparent switches are in a different VTP Domain than the Server and Client switch. According to your answer, this will not work unless all switches are in the same VTP Domain?

Re: VTP Domain Name and Transparent Mode

Hi Friend,

AFAIK in VTP version 1, a VTP transparent switch inspects VTP messages for the domain name and version and forwards a message only if the version and domain name match. Because VTP version 2 supports only one domain, it forwards VTP messages in transparent mode without inspecting the version and domain name.

Can you confim if you are running vtp version 1 or version 2?

Regards,

Ankur

New Member

Re: VTP Domain Name and Transparent Mode

The switches are all configured for Version 2. I'm thinking it may not inspect the vlan information but it does inspect the domain name????

Re: VTP Domain Name and Transparent Mode

hi...

u mean to say your vtp mesg are not forwarded...right

r u sure all switches runing version 2

regards

Devang

New Member

Re: VTP Domain Name and Transparent Mode

All switches are running version 2, however the switch that is furthest away(client) has not receive an update from the VTP Server because the transparent switches are not sending the vlan information or vtp updates.

New Member

Re: VTP Domain Name and Transparent Mode

I found the following on Cisco web:

Error Message DTP-5-DOMAINMISMATCH: Unable to perform trunk negotiation on port

[chars] because of VTP domain mismatch.

Explanation This message means that the two ports involved in trunk negotiation belong to different VTP domains. Trunking is possible only when the ports involved belong to the same VTP domain. [chars] is the name of the interface.

Re: VTP Domain Name and Transparent Mode

it means there is no trunk link formation between server and 1st transperent switch as well as there is no trunk between 2nd transperent switch and client switch...right due to domain miss match...

only trunk will form between two transperent switch...because of same domain ...right

regards

Devang

New Member

Re: VTP Domain Name and Transparent Mode

Try the following suggestions:

1. As a best practice, use nonegotiate everywhere.

2. On the specific ports we are discussing in this thread, also try the following commands:

switchport mode trunk

switchport trunk allowed vlan ###

switchport trunk pruning vlan none

Re: VTP Domain Name and Transparent Mode

can u send me the configuration of all switches...

regards

Devang

New Member

Re: VTP Domain Name and Transparent Mode

You are correct. I've attached a word doc with all the information I have. Thanks for your help.

Re: VTP Domain Name and Transparent Mode

thanks you to u also...

hey its nice sharing of knowledge with u...i have to check it out this on my lab...hey can i have your yahoo email id ...

thanks again

regards

Devang

Re: VTP Domain Name and Transparent Mode

Hi Guys,

For the error messgae below:

Error Message DTP-5-DOMAINMISMATCH: Unable to perform trunk negotiation on port

[chars] because of VTP domain mismatch.

This you will got only when you have an automatic trunk negotiation using the DTP (dynamic trunking protocol) between the switches. The switches with different VTP domain name will not negotiate a trunk and a trunk will not form. But if you configure a trunk manually (not using DTP) then the trunk will work.

HTH, Please rate if this helps

-amit singh.

New Member

Re: VTP Domain Name and Transparent Mode

Do all switches in the path have to be configured as nonegotiate? I also need to allow certain vlans to transverse the trunk.

Re: VTP Domain Name and Transparent Mode

Nope all switches in the path dont have to be configured to negotitate. I would prefer hardcoding the trunk as oppose to leaving the interfaces to negotiate on DTP.

If you want certain vlans to travel on the link, then u can filter unwanted Vlans using the " switchport allowed " command.

HTH, Please rate if it does.

-amit singh

New Member

Re: VTP Domain Name and Transparent Mode

All trunk ports are configured as follows:

interface FastEthernet0/48

description *****Connect to Idea Stream Data Center*****

switchport trunk encapsulation dot1q

switchport trunk native vlan 12

switchport trunk allowed vlan 12,50

switchport mode trunk

switchport nonegotiate

This still does not allow communitcations from the server switch through the transparent switches to the client switch. I don't think it will work because of the two different vtp domains. ?????

Re: VTP Domain Name and Transparent Mode

hi,,,

you can check it out this link...

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12225see/scg/index.htm

when this link open then download PDF version of whole book...and got to page number 324 and read the VTP version 2...it will help u ...

rate this post if it helps

regards

Devang

885
Views
0
Helpful
20
Replies
CreatePlease to create content