Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VTP over WAN

Is it possible to pass VTP over point-to-point T1 between two 2811 routers? I would like to establish VoIP at a branch office and bring all voice trafic via T1 and into my voice VLAN at my main site where it would be routed to the call manager. Or is QoS my main answer for the WAN?

7 REPLIES
VIP Purple

Re: VTP over WAN

Hello,

in general, extending layer 2 (VTP traffic in your case) across a (slow) WAN connection is not recommended, since it would likely saturate the link and unnecessarily use bandwidth.

I would suggest to configure, as you mentioned, a QoS policy prioritizing your voice traffic, and implement that policy at both sides of your link.

The policy could look like this:

class-map match-all VOICE

match access-group ACCESS_LIST_FOR_VOICE_TRAFFIC

!

policy-map VOICE_TRAFFIC

class VOICE

set dscp cs5

!

ip access-list extended ACCESS_LIST_FOR_VOICE_TRAFFIC

permit tcp any any eq 1720

permit udp any any range 16384 32767

Then, apply the service policy to the LAN interfaces where your Voice hosts are connected to, on both sides of the link, e.g.:

interface FastEthernet0/0

service-policy input VOICE_TRAFFIC

Can you try and see if that works for you ?

Regards,

GP

New Member

Re: VTP over WAN

GP, thanks for your reply. I am still waiting for my routers to arrive, but trying to plan ahead. I will try you example. Thanks a lot.

Re: VTP over WAN

In addition to marking, you definitely want to prioritize voice traffic over data.

class-map match-all VOICE

match access-group ACCESS_LIST_FOR_VOICE_TRAFFC

class-map match-all VOICE_CONTROL

match access-group ACCESS_LIST_FOR_VOICE_CONTROL

!

policy-map VOICE_TRAFFIC

class VOICE

set dscp cs5

priority 512

(Kilobits/sec, 50 % bw allocated to voice)

class VOICE_CONTROL

set dscp cs3

bandwidth 64

class class-default

fair-queue

ip access-list extended ACCESS_LIST_FOR_VOICE_TRAFFC

permit udp any any range 16384 32767

ip access-list extended ACCESS_LIST_FOR_VOICE_CONTROL

permit tcp any any eq 1720

(Additionally TCP port 2427,2428 or skinny 2000 could be included in control traffic if those protocols - SCCP and MGCP traverse the T1)

New Member

Re: VTP over WAN

I will be working with Avaya IP phones and Difinity as the call manager. Will have to check the port structure on that system.

Bronze

Re: VTP over WAN

Avaya uses the following:

1719 UDP for Registration

1720 TCP for Signaling.

RTP-UDP system default is 2048-65535, but you can chnage this to whatever udp range you want via (change ip-network-region X)

New Member

Re: VTP over WAN

Thanks kleo. This helps a lot.

Bronze

Re: VTP over WAN

Vlad, I forgot to mention one other thing all avaya endpoints and gateways can be configured with customized cos and Diffserv tagging parameters. default i think is COS 7 Diffserv 46, but can be changed to whatever value via network region command i showed prior.

271
Views
15
Helpful
7
Replies