Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WAN Routing

Here is the problem...I have three 1721 routers connected together...lets just call them R1,R2 and R3. R1 is the gateway router running frame relay ecap and is connected to R2 via FastE...R2 is then connected to R3 at a remote site via WAN0dsu/csu interface running Point-to-Point. All routers can see each other and can pass traffic...However I cannot get from R3 out past the Frame-Relay serial intereface on R1...and thus out to the frame cloud.

Again all of the 1721's can see each other...but I cannot passs traffic from R3 via the PPP to R2 and then to R1 out to the cloud...all traffic dies at the serial interface at R1 from R3...R2 can pass traffic out just fine.

There are no acl's set on any of the routers.

Does anybody have an idea why this is happening??

Any help would be much apprecaited...Thanks

4 REPLIES

Re: WAN Routing

Hello

Can you send Scheme to view your architec ans config

Best regards

Kheireddine

New Member

Re: WAN Routing

Sure take a look...

Here is the config for all three routers.

Thanks

Hostname R1

ip subnet-zero

ip name-server 206.13.31.12

ip name-server 206.13.28.12

!

!

!

!

!

interface FastEthernet0

description TO LOCAL LAN

ip address 63.196.107.33 255.255.255.240 secondary

ip address 63.205.221.97 255.255.255.248

speed auto

no cdp enable

!

interface Serial0

description PB CKT 22.HCGM.007267/PBI 1-800-463-8724

no ip address

encapsulation frame-relay IETF

fair-queue

service-module t1 timeslots 1-24

frame-relay lmi-type cisco

!

interface Serial0.1 point-to-point

ip address 67.122.236.158 255.255.255.252

no cdp enable

frame-relay interface-dlci 16

!

router rip

version 2

network 63.0.0.0

network 172.16.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 67.122.236.157

ip route 0.0.0.0 0.0.0.0 172.16.1.1

ip route 172.16.1.0 255.255.255.0 Serial0

no ip http server

!

!

no cdp run

r1 and r2 are physiacally connected via faste

hostname R2

!

logging buffered 4096 debugging

logging rate-limit console 10 except errors

enable password xxxx

!

memory-size iomem 25

clock timezone pst -8

clock summer-time pdt recurring

ip subnet-zero

no ip finger

no ip domain-lookup

!

!

!

!

interface FastEthernet0

description connected to FastHub412

ip address 63.205.221.98 255.255.255.248

speed auto

!

interface Serial0

description connected to BC2

ip address 172.16.1.1 255.255.255.252

encapsulation ppp

no service-module t1 remote-loopback full

service-module t1 remote-alarm-enable

!

router rip

version 2

network 63.0.0.0

network 172.16.0.0

no auto-summary

!

ip default-gateway 63.205.221.97

ip classless

ip route 0.0.0.0 0.0.0.0 63.205.221.97

ip route 172.16.1.0 255.255.255.0 Serial0

r2 and r3 are connected via ppp

hostname R3

!

ip subnet-zero

!

!

no ip domain lookup

!

!

!

!

!

interface FastEthernet0

no ip address

speed auto

!

interface Serial0

description connected to BC1

ip address 172.16.1.2 255.255.255.252

encapsulation ppp

service-module t1 remote-alarm-enable

!

router rip

version 2

network 63.0.0.0

network 172.16.0.0

no auto-summary

!

ip default-gateway 67.122.236.158

ip classless

ip default-network 63.0.0.0

ip route 0.0.0.0 0.0.0.0 172.16.1.1 permanent

ip route 0.0.0.0 0.0.0.0 63.205.221.97

ip route 0.0.0.0 0.0.0.0 67.122.236.158

no ip http server

!

snmp-server community public RO

snmp-server enable traps tty

no ip http server

New Member

Re: WAN Routing

Hi,

One question. Why do you have multiple default routes on each router? for example, on R3 you have:

ip default-gateway 67.122.236.158

ip default-network 63.0.0.0

ip route 0.0.0.0 0.0.0.0 172.16.1.1 permanent

ip route 0.0.0.0 0.0.0.0 63.205.221.97

ip route 0.0.0.0 0.0.0.0 67.122.236.158

What is the purpose of this?

What i would recommend is that you have one default route on each router. So;

R3 - 0.0.0.0 0.0.0.0 172.16.1.1

R2 - 0.0.0.0 0.0.0.0 63.205.221.97

R1 - 0.0.0.0 0.0.0.0 67.122.236.157

There should be no need for further static routes as you are running RIP.

Now your biggest problem is that R3 cannot communicate beyond R1. Is R1 advertising the 172.16.0.0 network into the F/R cloud? what I'm getting at is there must be a route back to R3 and its connected networks from the WAN. If R1's peer (gateway) is not running RIP then you will need some other mechanism to route traffic destined for the 172.16.0.0 network via R1. e.g. a static route.

Good luck

Teggs

New Member

Re: WAN Routing

Teggs-

Thanks for the input...as for the multiple default routes I just forgot to take them out before I cut and pasted...ooops...as it turned out it was a NAT issue on R2 that was holding us up...the command line went something like this...

router rip

version 2

network 63.0.0.0

network 172.16.0.0

no auto-summary

ip nat inside source list 25 interface FastEthernet0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 63.205.221.97

ip route 172.16.1.0 255.255.255.0 Serial0

no ip http server

!

access-list 25 permit 172.16.1.0 0.0.0.255

access-list 25 permit 192.168.1.0 0.0.0.255

then we added the 192 to RIP on R3, set the default network to 63 and the static route to the 172 and it all came up...looked like this

R3

router rip

version 2

network 63.0.0.0

network 172.16.0.0

network 192.168.1.0

no auto-summary

!

ip classless

ip default-network 63.0.0.0

ip route 0.0.0.0 0.0.0.0 172.16.1.1

no ip http server

Of course we added 172 to RIP on R1 as well...

100
Views
0
Helpful
4
Replies