Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WCCP on 1841 router

Having a problem with a configuration of our guest network and our content filter (S170 IronPort). The 1841 has 3 interfaces. 0/0 is on the LAN side, 0/1/0 is connected to the Ironport, 0/1 is connected to the ISP. So we would like to redirect all traffic from the LAn interface to the Ironport and then out to the internet. For some reason with the configuration below it does not redirect the traffic. When I apply WCCP to the LAN interface it redirects but the cleints stop gettin g internet traffic. Does anyone have any expereince or ideas on how to make this work in the environment?

The ironport is 10.x.5.30 and conneted to fa0/1/0

ip wccp web-cache redirect-list https-cache
ip wccp 80 redirect-list https-cache

interface FastEthernet0/1/0
description WCCP port
ip address 10.x.5.10 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip wccp web-cache redirect in
ip wccp 80 redirect in
no ip nat inside
ip virtual-reassembly
ip route-cache flow
exit

interface FastEthernet0/0
description $ES_LAN$$FW_INSIDE$
ip address 10.x.4.20 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto

interface FastEthernet0/1
description outside$ETH-WAN$
ip address 50.x.89.145 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled


ip access-list extended https-cache
permit ip 10.245.4.0 0.0.0.255 any

ip route 0.0.0.0 0.0.0.0 50.x.89.150

ip route 10.0.0.0 255.0.0.0 10.x.4.1

ip route 172.16.0.0 255.248.0.0 10.x.4.1

1049
Views
0
Helpful
0
Replies