Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Weird Problem with LS1010 ATM switch and 2 routers on each side

I have a TAC case open with this, but I wanted to see if I could get some ideas from anyone here. All documented configuration is v. simple and straightforward, but something is amiss. Any pointers, advice would be great:

Here's a diagram of what we have set up. Very simple setup we have:

maingw7500 LS1010 Loaner3600

atm5/1/0.40 -------atm0/0/0 | atm0/0/1 -------atm1/0.50

pvc3/40 ------------ pvc 3/40 pvc3/50 ----------pvc3/50

Now for the interface configs on the routers and the entire config of the LS1010:

VGW7500 (IOS Version 12.0(9)S)

interface ATM5/1/0

no ip address

no ip directed-broadcast

ip route-cache flow

no ip route-cache cef

no ip route-cache distributed

atm uni-version 3.1

no atm auto-configuration

atm ilmi-keepalive

no atm address-registration

atm ilmi-pvc-discovery

!

interface ATM5/1/0.40 point-to-point

ip address 150.240.45.1 255.255.255.252

no ip directed-broadcast

pvc 3/40

protocol ip 150.240.45.2

no ilmi manage

oam-pvc 0 ****NOTE**** here oam-pvc manage brings down the interface!

encapsulation aal5snap

-----------------------------------------------

Loaner3600 (IOS Version 12.1(5)T5)

interface ATM1/0

no ip address

ip route-cache flow

atm uni-version 3.1

no atm auto-configuration

atm ilmi-keepalive

no atm address-registration

atm ilmi-pvc-discovery

!

interface ATM1/0.50 point-to-point

ip address 150.240.45.2 255.255.255.252

pvc 3/50

protocol ip 150.240.45.1

oam-pvc manage

encapsulation aal5snap

-------------------------------------------------

SW1010_Lightstream(IOS Version 12.1(7a)EY3)

Current configuration : 1589 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname sw1010

!

enable secret 5 xxx

!

network-clock-select 1 System clock

sdm ipqos zero

sdm policy 0

ip subnet-zero

no ip finger

!

!

atm address 47.0091.8100.0000.0009.b71c.3e01.0009.b71c.3e01.00

atm router pnni

no aesa embedded-number left-justified

node 1 level 56 lowest

redistribute atm-static

!

!

!

!

interface ATM0/0/0

no ip address

no atm auto-configuration

no atm address-registration

!

interface ATM0/0/1

no ip address

no atm auto-configuration

no atm address-registration

atm pvc 3 50 interface ATM0/0/0 3 40

!

interface ATM0/0/2

no ip address

no ip route-cache cef

shutdown

no atm auto-configuration

no atm address-registration

atm uni version 3.1

!

interface ATM0/0/3

no ip address

shutdown

!

interface ATM0

no ip address

atm oam interface ATM0/0/0 0 16 seg-loopback rdi

atm oam interface ATM0/0/1 0 16 seg-loopback rdi

atm oam interface ATM0/0/2 0 16 seg-loopback rdi

atm oam interface ATM0/0/3 0 16 seg-loopback rdi

atm oam interface ATM0/0/0 0 5 seg-loopback rdi

atm oam interface ATM0/0/1 0 5 seg-loopback rdi

atm oam interface ATM0/0/2 0 5 seg-loopback rdi

atm oam interface ATM0/0/3 0 5 seg-loopback rdi

!

interface Ethernet0

ip address 150.240.150.154 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0

no ip http server

!

!

!

line con 0

transport input none

line aux 0

line vty 0 4

exec-timeout 120 0

password 7 xxx

login

!

end

--------------------------------

NOTES:

- When the routers are terminated with a physical loopback they ping their own ATM ints just fine.

- All interfaces on the routers have been in production in recent past.

- 3600 interface stopped flapping when we extended its cable.

- Routers can ping their own ATM ints also when they are plugged into LS1010 AND the other LS1010 interface it is mapped to is plugged into itself with at physical loopback.

- 3600 can ping its own ATM int even when it is plugged into LS1010 AND 7500 is plugged into other LS1010 interface to which its mapped

- Also, on the LS1010, when we do a "ping atm interface atm0/0/1 3 50 end-loopback" command it works fine (this is with a normal setup like i just mentioned above), but the same "ping atm" command mapping to the 7500's interface and pvc does not work because we can't run OAM-PVC MANAGE on the 7500 sub-int without it bringing down the interface??

- Throughout this process we have occasionally been able to get pings through from the 3600 atm int to the 7500 atm int.

- We've tried many debugs, and one common debug message on pings is "encapsulation failed", but we have aal5snap defined on both ends of the PVC

- I know we don't need ILMI on a PVC, but it helps for debugging

- Both atm interfaces on the routers are set to CLOCKING=LINE, and the LS1010 is set to "Current clock source:System clock, priority:1"

Any advice or help would be appreciated!

Jason

3 REPLIES
New Member

Re: Weird Problem with LS1010 ATM switch and 2 routers on each s

Jeson,

this is a little bit difficult to understand and I guess the only chance to find

out what's up is to use an ATM protocol analyser. The analyser can prove

which device causes the problem. You mentioned that it is not possible

to send "atm oam end-loopback pings" from the LS1010 in the direction

of the 7500 router because you need to set the interface to oam-managed.

This is not true. The interface has to reply on such pings even it is not set to

oam-managed.

Setting an pvc to oam-managed means that the router sends oam pings itself

on a regular basis over that pvc but has nothing to do with the reply on such

atm pings.

Are there any hints of errors in the "show controller atm ..." outputs? You

should check this. Config seems to be o.k. I believe the problem is with the

7500 cisco. Maybe you can do an IOS upgrade on that router.

regards Ulrich Marzoli

www.netaid.de

New Member

Re: Weird Problem with LS1010 ATM switch and 2 routers on each s

Thanks for the OAM-manage tip Ulrich. You are 100% correct. Actually we solved the problem by putting "atm scrambling cell-payload" on both LS1010 interfaces and both router interfaces, and circuit came up. However,

I still have one note and question though. Even though we can ping ip across the pvc in both directions now, on the LS1010, the "PING atm int atm 0/0/0 3 40 end-loopback" command does not work, however the same command for the 3600 does work, and they now have identical PVC 3/x configs. Any thoughts on that?

thanks,

Jason Evans

New Member

Re: Weird Problem with LS1010 ATM switch and 2 routers on each s

Hi Jeason,

I think that it is a problem with the IOS for the Cisco 7500 because this one is

in regard to the atm IOS development very old.

I don't know if the command "show atm pvc 3/40" is working on that router IOS.

This command shows the amount of received and transmitted atm oam looopback cells. The output is like this:

router#sh atm pvc 1/321

ATM2/0.321: VCD: 1, VPI: 1, VCI: 321

VBR-NRT, PeakRate: 14936, Average Rate: 14936, Burst Cells: 200

AAL5-LLC/SNAP, etype:0x0, Flags: 0x20, VCmode: 0x0

OAM frequency: 10 second(s), OAM retry frequency: 1 second(s), OAM retry frequency: 1 second(s)

OAM up retry count: 3, OAM down retry count: 5

OAM Loopback status: OAM Received

OAM VC state: Verified

ILMI VC state: Not Managed

VC is managed by OAM.

InARP frequency: 15 minutes(s)

Transmit priority 2

InPkts: 2249329431, OutPkts: 2331157430, InBytes: 2783771421, OutBytes: 2383249112

InPRoc: 20635871, OutPRoc: 28830950

InFast: 2228692502, OutFast: 2302309385, InAS: 0, OutAS: 0

InPktDrops: 0, OutPktDrops: 0

CrcErrors: 260149, SarTimeOuts: 0, OverSizedSDUs: 0

OAM cells received: 4124434

F5 InEndloop: 4123136, F5 InSegloop: 0, F5 InAIS: 1281, F5 InRDI: 17

F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0

OAM cells sent: 4134409

F5 OutEndloop: 4133128, F5 OutSegloop: 0, F5 OutRDI: 1281

F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0

OAM cell drops: 0

Status: UP

This command is most helpfull becaus it shows also the SAR CRC errors

per PVC. So you can find out where the CRC errors on the interface come from if the problem is not related to the access line. But this is more related to WAN links with several PVCs.

regards Ulrich Marzoli

www.netaid.de

176
Views
0
Helpful
3
Replies
CreatePlease to create content