Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

What IOS do I need to upgrade to for Vulnerability

I have a 3640 router running 12.0(7)XK2

I am having difficulty obtaining information as to what IOS I can go to in order to patch Cisco latest vulnerability. Any assistance with this would be great.

Thank you in advance.

4 REPLIES

Re: What IOS do I need to upgrade to for Vulnerability

Hi rich,

You must be a bit more specific about what should be fixed (in your opinion).

But this is not all: It is more than likely that an upgrade to a more recent IOS will require a substantial upgrade of your flash and RAM memories costing substantial $$$. To determine if this is indeed required and to know what we are talking about, the output of the "sh ver" command would make things a lot clearer.

The bottom line of this story might very well be that you are simply cheaper off when you buy yourself a new router.

Regards,

Leo

New Member

Re: What IOS do I need to upgrade to for Vulnerability

Thank you for your response. Flash and memory are my primary concern in updating the IOS. Just cant seem to find any documentation on what I need. I have attached a txt file with show version stats. Thanks again in advance for your assistance! Here is the info to the fix I was referring to:

The networking giant on Wednesday released an update to fix a serious so-called heap-overflow vulnerability in its Internetwork Operating System, or IOS. This type of security flaw is commonly found in software and often allows a remote attacker to gain control of the affected system.

New Member

Re: What IOS do I need to upgrade to for Vulnerability

Sorry, here is the attachment, forgot it in last post.

Purple

Re: What IOS do I need to upgrade to for Vulnerability

100
Views
0
Helpful
4
Replies
CreatePlease to create content