Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Why are iBGP routes not being redist into RIP ?

Hello,

Can someone please help and explain why this configuration is not working correctly. I am trying to get my 3 iBGP subnets redistributed into RIP in order to send them via RIP to the PIX connected via eth0. iBGP works fine and does what it needs to do. However, I cannot see the iBGP routes being redist when I sho the RIP database. thanks !

OPS_CORE#wr t

Building configuration...

Current configuration : 2151 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname OPS_CORE

!

no logging buffered

logging rate-limit console 10 except errors

enable secret <del>

enable password <del>

!

memory-size iomem 20

ip subnet-zero

!

!

no ip finger

!

ip audit notify log

ip audit po max-events 100

no ip dhcp-client network-discovery

!

!

!

!

!

interface Ethernet0

ip address 172.16.2.2 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

half-duplex

!

interface FastEthernet0

ip address 192.168.5.249 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

speed auto

!

router rip

version 2

no validate-update-source

redistribute bgp 65000

passive-interface Ethernet0

network 172.16.0.0

neighbor 172.16.2.1

default-metric 1

no auto-summary

!

router bgp 65000

no synchronization

bgp log-neighbor-changes

timers bgp 5 16

neighbor 192.168.1.252 remote-as 65000

neighbor 192.168.1.252 update-source FastEthernet0

neighbor 192.168.1.252 default-originate

neighbor 192.168.1.252 route-map NEXTHOP_OVERRIDE_AIR in

neighbor 192.168.4.253 remote-as 65000

neighbor 192.168.4.253 update-source FastEthernet0

neighbor 192.168.4.253 default-originate

neighbor 192.168.4.253 route-map NEXTHOP_OVERRIDE_HAM in

neighbor 192.168.7.254 remote-as 65000

neighbor 192.168.7.254 update-source FastEthernet0

neighbor 192.168.7.254 default-originate

neighbor 192.168.7.254 route-map NEXTHOP_OVERRIDE_WAX in

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.2.1

ip route 192.168.1.252 255.255.255.255 192.168.5.243

ip route 192.168.4.253 255.255.255.255 192.168.5.244

ip route 192.168.7.254 255.255.255.255 192.168.5.244

no ip http server

!

!

!

route-map NEXTHOP_OVERRIDE_HAM permit 10

set ip next-hop 192.168.5.244

!

route-map NEXTHOP_OVERRIDE_WAX permit 10

set ip next-hop 192.168.5.244

!

route-map NEXTHOP_OVERRIDE_AIR permit 10

set ip next-hop 192.168.5.243

!

banner motd ^C FOR AUTHORIZED USERS ONLY!!! ^C

!

line con 0

transport input none

line aux 0

line vty 0 4

password <del>

login

!

end

OPS_CORE#sho ip bgp

BGP table version is 4, local router ID is 192.168.5.249

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*>i192.168.1.0 192.168.5.243 0 100 0 i

*>i192.168.4.0 192.168.5.244 0 100 0 i

*>i192.168.7.0 192.168.5.244 0 100 0 i

OPS_CORE#sho ip rip data

0.0.0.0/0 auto-summary

0.0.0.0/0 redistributed

[0] via 0.0.0.0,

172.16.0.0/16 auto-summary

172.16.2.0/24 directly connected, Ethernet0

OPS_CORE#

2 REPLIES

Re: Why are iBGP routes not being redist into RIP ?

I tested this on lab, and was perplexed to find the same results. The ibgp routes were not being redistributed into rip. Not just RIP, it didnt get redistributed via EIGRP, OSPF...Spent almost an hour behind this, thinking why its happening. Finally came to conclustion that, the reason has to be the design of BGP. IBGP routes shouldnt really be redistributed to IGP, because it can cause routing loops.

While browsing through the cisco website, i came across a command, called "bgp redistribute-internal". This command can be used to enable redistribution between iBGP routes and IGPs. By default a cisco router doesnt redistribute between iBGP and any IGP, to prevent possible routing loops.

The cisco document says that this is used to redistributes routes into IGPs such as OSPF and IS-IS. But I have tested this with RIP and it works with RIP too.

Use this command with extreme care, because this can be a potential source of routing loops in your network. The CLI command description itself describes it as "dangerous".

1600(config-router)#bgp ?

always-compare-med Allow comparing MED from different neighbors

bestpath Change the default bestpath selection

client-to-client Configure client to client route reflection

cluster-id Configure Route-Reflector Cluster-id

confederation AS confederation parameters

dampening Enable route-flap dampening

default Configure BGP defaults

deterministic-med Pick the best-MED path among paths advertised from

the neighboring AS

fast-external-fallover Immediately reset session if a link to a directly

connected external peer goes down

log-neighbor-changes Log neighbor up/down and reset reason

redistribute-internal Allow redistribution of iBGP into IGPs (dangerous)

router-id Override configured router identifier

scan-time Configure background scanner interval

Also a min of 12.1 IOS is required to use this command.

HTH.

New Member

Re: Why are iBGP routes not being redist into RIP ?

Thank you, I appreciate very much the time you spent looking into this. I will add that to my BGP process and see what happens..

166
Views
15
Helpful
2
Replies
CreatePlease login to create content