Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

Why did the queueing default change from WFQ to FIFO in IOS 11.2?

Hi,

I'm looking for an explanation of why the IOS starting using fifo queueing instead of weighted fair around version 11.2. Seems like that was when traffic shaping started so I guess there might be a connection there but I dont know what it is. What happens if I turn WFQ back on? Does traffic shaping work under WFQ?

Is there a reference out there that explains the change?

2 REPLIES
Bronze

Re: Why did the queueing default change from WFQ to FIFO in IOS

It is the other way round. WFQing is the default in all current levels of IOS and I believe that was introduced in 11.2.

The change was in an effort to improve throughput.

Bronze

Re: Why did the queueing default change from WFQ to FIFO in IOS

Thats what everyone seems to think but when I paste this config into a 2610 running 12.0

hostname Michaels-2712

.

!

service timestamps debug datetime

service timestamps log datetime

service password-encryption

no ip domain-lookup

.

.

.

!

interface Serial0/0

no ip address

encapsulation frame-relay

no shutdown

!

interface Serial0/0.1 point-to-point

ip address 10.120.24.170 255.255.255.248

frame-relay interface-dlci 950

no shutdown

I get this. These "no fair queue" statements are in over 700 routers and we didn't put them there.

Michaels-2712#sh conf

Using 1926 out of 29688 bytes

!

version 12.0

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname Michaels-2712

!

logging buffered 4096 debugging

enable secret 5 $1$nx.X$6rXDieeDpEJ5Gp5Rpz2Jd/

!

username RAS1 password 7 04480E051A3349

ip subnet-zero

no ip domain-lookup

chat-script rset-usr "" AT&F1 OK AT&B1 OK AT&U10 OK AT&N14

!

!

!

interface Ethernet0/0

ip address 10.127.148.62 255.255.255.192

no ip directed-broadcast

!

interface Serial0/0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

no fair-queue

!

interface Serial0/0.1 point-to-point

ip address 10.120.24.170 255.255.255.248

no ip directed-broadcast

It changed at 11.2 but I cannot find out why.

94
Views
0
Helpful
2
Replies