Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

why ebgp peer group members should belong to the same ip subnet?

why ebgp peer group members should belong to the same ip subnet?

If this is true,that means the ebgp border router should only have one interface to interconnect different ebgp peer group members,and the network must be multiaccess network,and can not be point to point network.Is that true? because different interface in router must have different ip subnet

3 REPLIES

Re: why ebgp peer group members should belong to the same ip sub

EBGP peers should be on same subnet as the default TTL is set to 1(IBGP TTL is 255). If you want to make them on different subnets, use the command ebgp-multihop x (where x is the hops/ttl). A use for this is if you have 2+ links to a neighbor, so for redundancy, peer with the loopbacks and use the commands ebgp-multihop and update-source. So with these commands the EBGP peer can be on the same or different subnet, and they can be directly connected or on a multiaccess network or a few hops away.

eg.

interface loopback 0

ip address 1.1.1.1 255.255.255.0

!

interface serial 0

description connects to peer AS 11

ip address 10.10.10.10 255.255.255.0

!

interface serial 1

description connects to peer AS 11

ip address 11.11.11.11 255.255.255.0

!

router bgp 10

neighbor 2.2.2.2 remote-as 11 (where 2.2.2.2 is the peer AS 11's loopback)

neighbor 2.2.2.2 update-source loopback 0

neighbor 2.2.2.2 ebgp-multihop

Hope it helps.

Steve

New Member

Re: why ebgp peer group members should belong to the same ip sub

My questions is about ebgp peer group,not about ebgp peer. There are two restrictions when using ebgp peer group:

one is ebgp peer members should belong to the same subnets,and the other is that peer groups should not be set on ebgp neighbors if the router is acting as a transit between these neithbors.

And i don't know why these two restrictions exitst.

Any help?

Bronze

Re: why ebgp peer group members should belong to the same ip sub

Um, I have never heard of those restrictions. I have used ebgp peer groups on diff. subnets and for transit. As far as I know, the only peer-group restriction is that all members must have the same policy. If you have seen different requirements, please post a link...

--Warren.

161
Views
0
Helpful
3
Replies
CreatePlease to create content