Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

why it's work? ( OSPF )

I have 3 routers -2610,1601,1603.

2610(s0/0.2, 192.168.100.1) and 1601(s1.1,192.168.100.2) connected by Frame Relay,

2610(e0/0,A.B.C.1) and 1603(e0,A.B.C.111) connected by Ethernet.

Because i have FR => NBMA environment -than (from O'Reilly book) - "In an NBMA environment, broadcasts or multicasts do not propogate over the FR."

And i should use

#neighbor A.B.C.D

to enable static OSPF neighbor relationship. But i did not do it. And it's work!Why?

( Addresses 141.108.*.* , 131.108.*.* i took from O'Reilly book).

All routers have information about networks:

2610#sh ip route ospf

141.108.0.0/32 is subnetted, 3 subnets

O 141.108.9.129 [110/782] via 192.168.100.2, 00:43:05, Serial0/0.2

O 141.108.9.1 [110/782] via 192.168.100.2, 00:43:05, Serial0/0.2

O 141.108.12.1 [110/782] via 192.168.100.2, 00:43:05, Serial0/0.2

131.108.0.0/16 is variably subnetted, 6 subnets, 3 masks

O 131.108.5.32/27 [110/1010] via A.B.C.111, 00:48:42, Ethernet0/0

O 131.108.6.1/32 [110/11] via A.B.C.111, 00:48:42, Ethernet0/0

O 131.108.6.2/32 [110/11] via A.B.C.111, 00:48:42, Ethernet0/0

192.168.17.0/32 is subnetted, 1 subnets

O 192.168.17.1 [110/782] via 192.168.100.2, 00:43:05, Serial0/0.2

192.168.16.0/32 is subnetted, 1 subnets

O 192.168.16.1 [110/11] via A.B.C.111, 00:48:42, Ethernet0/0

------------------------------

c1603#sh ip route ospf

141.108.0.0/32 is subnetted, 3 subnets

O IA 141.108.9.129 [110/792] via A.B.C.1, 00:50:15, Ethernet0

O IA 141.108.9.1 [110/792] via A.B.C.1, 00:50:15, Ethernet0

O IA 141.108.12.1 [110/792] via A.B.C.1, 00:50:15, Ethernet0

131.108.0.0/16 is variably subnetted, 6 subnets, 2 masks

O 131.108.4.129/32 [110/11] via A.B.C.1, 00:50:15, Ethernet0

O 131.108.4.1/32 [110/11] via A.B.C.1, 00:50:15, Ethernet0

O 131.108.5.1/32 [110/11] via A.B.C.1, 00:50:15, Ethernet0

192.168.17.0/32 is subnetted, 1 subnets

O IA 192.168.17.1 [110/792] via A.B.C.1, 00:44:35, Ethernet0

O IA 192.168.100.0/24 [110/791] via A.B.C.1, 00:50:15, Ethernet0

----------------------------------------

Cisco1601#sh ip route ospf

131.108.0.0/16 is variably subnetted, 6 subnets, 2 masks

O IA 131.108.4.129/32 [110/1563] via 192.168.100.1, 00:46:21, Serial1.1

O IA 131.108.5.32/27 [110/2572] via 192.168.100.1, 00:46:21, Serial1.1

O IA 131.108.6.1/32 [110/1573] via 192.168.100.1, 00:46:21, Serial1.1

O IA 131.108.4.1/32 [110/1563] via 192.168.100.1, 00:46:21, Serial1.1

O IA 131.108.6.2/32 [110/1573] via 192.168.100.1, 00:46:21, Serial1.1

O IA 131.108.5.1/32 [110/1563] via 192.168.100.1, 00:46:21, Serial1.1

192.168.16.0/32 is subnetted, 1 subnets

O IA 192.168.16.1 [110/1573] via 192.168.100.1, 00:46:21, Serial1.1

___________________________________________

Here configs:

---------------------------------2610-----------------------

!

interface Loopback0

ip address 131.108.4.1 255.255.255.128

!

interface Loopback1

ip address 131.108.4.129 255.255.255.128

!

interface Loopback2

ip address 131.108.5.1 255.255.255.224

!

interface Ethernet0/0

ip address A.B.C.1 255.255.255.0

!

interface Serial0/0

bandwidth 512

no ip address

encapsulation frame-relay

!

....

!

interface Serial0/0.2 point-to-point

bandwidth xxx

ip address 192.168.100.1 255.255.255.0

frame-relay interface-dlci xxx

!

..........

!

router ospf 1

log-adjacency-changes

area 2 virtual-link 141.108.12.1

network 131.108.4.0 0.0.0.127 area 1

network 131.108.4.128 0.0.0.127 area 1

network 131.108.5.0 0.0.0.31 area 1

network 192.168.100.0 0.0.0.255 area 2

network A.B.C.0 0.0.0.255 area 1

!

----------------------------------1603--------------------------------------

!

interface Loopback0

ip address 131.108.5.33 255.255.255.224

no ip directed-broadcast

ip ospf network point-to-point

ip ospf cost 1000

!

interface Loopback1

ip address 131.108.6.1 255.255.255.255

no ip directed-broadcast

!

interface Loopback2

ip address 131.108.6.2 255.255.255.255

no ip directed-broadcast

!

interface Loopback3

ip address 192.168.16.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0

ip address A.B.C.111 255.255.255.0

.................

!

router ospf 2

network 131.108.5.32 0.0.0.31 area 1

network 131.108.6.1 0.0.0.0 area 1

network 131.108.6.2 0.0.0.0 area 1

network 192.168.16.0 0.0.0.255 area 1

network A.B.C.0 0.0.0.255 area 1

!

------------------------------------1601-------------------------------------

!

interface Loopback0

ip address 141.108.9.1 255.255.255.128

!

interface Loopback1

ip address 141.108.9.129 255.255.255.128

!

interface Loopback2

ip address 141.108.12.1 255.255.255.0

!

interface Loopback3

ip address 192.168.17.1 255.255.255.0

!

interface Ethernet0

ip address 192.168.10.1 255.255.255.0

!

.....

!

interface Serial1

bandwidth xxx

no ip address

encapsulation frame-relay

frame-relay lmi-type cisco

!

interface Serial1.1 point-to-point

bandwidth

ip address 192.168.100.2 255.255.255.0

frame-relay interface-dlci xxx

!

router ospf 3

log-adjacency-changes

area 2 virtual-link 131.108.5.1

network 141.108.9.0 0.0.0.127 area 0

network 141.108.9.128 0.0.0.127 area 0

network 141.108.12.0 0.0.0.255 area 0

network 192.168.17.0 0.0.0.255 area 0

network 192.168.100.0 0.0.0.255 area 2

!

----------------------------------------------------------------------------------

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: why it's work? ( OSPF )

You are using frame relay point-to-point subinterfaces; ospf will form adjacencies over these without any specail work, since ospf sees these as simple point-to-points, rather than as a non broadcast multi access link.

If you want to see the impact of not putting the broadcast statement on the frame map command, you need to use the main interface, or a point-to-multipoint subinterface, rather than a point-to-point subinterface.

Russ.W

4 REPLIES
Gold

Re: why it's work? ( OSPF )

You are using frame relay point-to-point subinterfaces; ospf will form adjacencies over these without any specail work, since ospf sees these as simple point-to-points, rather than as a non broadcast multi access link.

If you want to see the impact of not putting the broadcast statement on the frame map command, you need to use the main interface, or a point-to-multipoint subinterface, rather than a point-to-point subinterface.

Russ.W

New Member

Re: why it's work? ( OSPF )

What's use for form adjacencies - multicast address 224.0.0.5 or adress of DR?

Silver

Re: why it's work? ( OSPF )

OSPF uses the AllSPFRouters address 224.0.0.5 on Point-To-Point interfaces

(see scetion 8 - Protocol Packet Processing on page 58 of RFC 2328:

ftp://ftp.rfc-editor.org/in-notes/std/std54.txt)

Bronze

Re: why it's work? ( OSPF )

There is only a DR Election on Multiacces Networks (OSPF Broadcast + NBMA).

For a p-2-p network it will be 224.0.0.5.

Regards

Roger

266
Views
6
Helpful
4
Replies