Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Why OSPF have to redistribute the connected network?

when I redistribute OSPF and RIP or OSPF and EIGRP or OSPF and ISIS, I have to redistribute the Connected network under "router OSPF ", if I don't redistribute the connected network, the routes can be seen, but can not ping. why?

7 REPLIES
Gold

Re: Why OSPF have to redistribute the connected network?

Do you mean if you redistribute some protocol into OSPF, and you don't redistribute the network you're learning the routes from, you can't ping them? In reality, it shoudl the other way--you might have to run OSPF on the interface you're learning the routes from.

In an OSPF type 5 external route, there's a field for the next hop address. If the next hop address is not reachable as an OSPF itnernal route, the external will not be installed in the table. You can tell this is happening by looking at the ospf database entry for the type 5 external route (show ip ospf data extern), and looking for the entry that says: "routing bit not set," or "routing bit set." If it says the routing bit isn't set, either the router redistributing the route isn't being seen as an ASBR, or the next hop isn't reachable as an OSPF internal route.

If this isn't the problem, could you please post the output of show ip ospf data and show ip route for what you are seeing?

Hope that helps.

:-)

Russ.W

New Member

Re: Why OSPF have to redistribute the connected network?

every time I met this question when I redistribute OSPF and others. for example

R1 s0-----ISIS-----S0 R2 S1-----OSPF----- S1 R3

simply, I redistribute ISIS/OSPF on R2

now

R3 can see the route from R1, but can not ping, then

I have to "redistribute connect subnet (for S0)" on R2, and everything is ok.

but for eigrp, RIP, ISIS redistribution, no this problem. only OSPF has to redistribute the connected network.

I don't know why.

Gold

Re: Why OSPF have to redistribute the connected network?

Are you redistributing level 1 and level 2 routes?

redistribute isis level-1-2 metric 10 subnets

Are you redistributing ospf back into is-is? Remember we need a path back, as well as a path there.

We really need the configuration of the redistributing router to see what's going on. A show ip ospf data extern from that router would be good, too, as well as a show ip route. I just set this up in the lab, and as long as I'm running the right redistribution, and redistributing ospf back into is-is works fine.

:-)

Russ.W

New Member

Re: Why OSPF have to redistribute the connected network?

Thanks for your time.

My friend(ccie) told me, that is a bug of OSPF, and I changed some IOS, the problem is still there. my IOS file is c2500-js-l.122-23.bin

for the ISIS, the IS-type is level-2-only. because I shutdown my routers, so I can not post the configuration now, but later.

the topology like this

R1---FR(ospf)----R2

R1---FR(ospf)----R3----ISIS----R4----ISIS----R5

R1 use sub-interface, same subnet with R2 and R3.

level-2-only between R4 and R5

I redistribute ISIS/OSPF on R3 without redistributed connected network. and on R1, only see the routes from R5, but can not ping.

after I redistribute connected netowrk on R3, everything is ok.

later, I will set the topology up and get the configuration and I would post.

Thanks again.

Gold

Re: Why OSPF have to redistribute the connected network?

You're using the same subnet between R1 and R3, and R2 and R3? When you get this set up, post the configurations.

:-)

Russ.W

New Member

Re: Why OSPF have to redistribute the connected network?

Topology

R1 s0.1--area0----s0 R2

R1 s0.1--area0----s0 R3 same subnet, 192.168.0.0/26

R3 s1---isis---s3 R4 192.168.1.0/24

R4 s1---ISIS---s1 R5 192.168.4.0/24

simply, redistribute ospf and isis on R3, and R1 can ping 192.168.4.0/24, but 192.168.1.0/24. On R3, after redistribute connected network under ospf, R1 can ping 192.168.1.0/24

configurations

R1

interface Loopback0

ip address 192.168.11.11 255.255.255.255

ip ospf network point-to-point

!

interface Serial0

no ip address

encapsulation frame-relay

!

interface Serial0.1 multipoint

ip address 192.168.0.1 255.255.255.192

frame-relay map ip 192.168.0.2 204 broadcast

frame-relay map ip 192.168.0.3 205 broadcast

router ospf 10

log-adjacency-changes

network 192.168.0.1 0.0.0.0 area 0

network 192.168.11.11 0.0.0.0 area 0

neighbor 192.168.0.3

neighbor 192.168.0.2

r1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

192.168.1.3 0 FULL/DROTHER 00:01:58 192.168.0.3 Serial0.1

192.168.0.2 0 FULL/DROTHER 00:01:46 192.168.0.2 Serial0.1

r1#sh ip route os

O E2 192.168.4.0/24 [110/20] via 192.168.0.3, 00:07:49, Serial0.1

R2

interface Serial0

ip address 192.168.0.2 255.255.255.192

encapsulation frame-relay

ip ospf priority 0

frame-relay map ip 192.168.0.1 402 broadcast

frame-relay map ip 192.168.0.3 402 broadcast

!

router ospf 10

log-adjacency-changes

network 192.168.0.2 0.0.0.0 area 0

!

r2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

192.168.0.1 1 FULL/DR 00:01:33 192.168.0.1 Serial0

r2#sh ip route os

192.168.11.0/32 is subnetted, 1 subnets

O 192.168.11.11 [110/65] via 192.168.0.1, 00:08:58, Serial0

O E2 192.168.4.0/24 [110/20] via 192.168.0.3, 00:08:58, Serial0

Cont.

R3#sh ip ospf database external

OSPF Router with ID (192.168.1.3) (Process ID 10)

Type-5 AS External Link States

LS age: 1378

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 192.168.4.0 (External Network Number )

Advertising Router: 192.168.1.3

LS Seq Number: 80000001

Checksum: 0xE4E0

Length: 36

Network Mask: /24

Metric Type: 2 (Larger than any link state path)

TOS: 0

Metric: 20

Forward Address: 0.0.0.0

External Route Tag: 0

New Member

Re: Why OSPF have to redistribute the connected network?

R3

interface Serial0

ip address 192.168.0.3 255.255.255.192

encapsulation frame-relay

ip ospf priority 0

frame-relay map ip 192.168.0.1 502 broadcast

frame-relay map ip 192.168.0.2 502 broadcast

interface Serial1

ip address 192.168.1.3 255.255.255.0

ip router isis

!

router ospf 10

log-adjacency-changes

redistribute isis level-2 subnets

network 192.168.0.3 0.0.0.0 area 0

!

router isis

net 49.0001.3333.3333.3333.00

redistribute ospf 10 metric 20

is-type level-2-only

R3#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

192.168.0.1 1 FULL/DR 00:01:58 192.168.0.1 Serial0

R3#sh ip route isis

i L2 192.168.4.0/24 [115/20] via 192.168.1.4, Serial1

R3#sh ip route osp

192.168.11.0/32 is subnetted, 1 subnets

O 192.168.11.11 [110/65] via 192.168.0.1, 00:10:16, Serial0

R3#

R3#sh isis topology

IS-IS paths to level-2 routers

System Id Metric Next-Hop Interface SNPA

R3 --

r4 10 r4 Se1 *HDLC*

r5 20 r4 Se1 *HDLC*

R4

interface Serial1

ip address 192.168.4.4 255.255.255.0

ip router isis

!

!

interface Serial3

ip address 192.168.1.4 255.255.255.0

ip router isis

clockrate 64000

router isis

net 49.0001.4444.4444.4444.00

is-type level-2-only

r4#sh ip route isis

192.168.11.0/32 is subnetted, 1 subnets

i L2 192.168.11.11 [115/30] via 192.168.1.3, Serial3

192.168.0.0/26 is subnetted, 1 subnets

i L2 192.168.0.0 [115/30] via 192.168.1.3, Serial3

r4#

r4#p 192.168.11.11

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.11.11, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R5

interface Serial1

bandwidth 148000

ip address 192.168.4.5 255.255.255.0

ip router isis

clockrate 148000

no cdp enable

router isis

net 49.0001.5555.5555.5555.00

is-type level-2-only

r5#sh ip route isis

192.168.11.0/32 is subnetted, 1 subnets

i L2 192.168.11.11 [115/40] via 192.168.4.4, Serial1

192.168.0.0/26 is subnetted, 1 subnets

i L2 192.168.0.0 [115/40] via 192.168.4.4, Serial1

i L2 192.168.1.0/24 [115/20] via 192.168.4.4, Serial1

r5#

r5#p 192.168.11.11

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.11.11, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 100/102/108 ms

r5#

Finish.

r1#sh ip ospf dat ex

OSPF Router with ID (192.168.0.1) (Process ID 10)

Type-5 AS External Link States

Routing Bit Set on this LSA

LS age: 1276

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 192.168.4.0 (External Network Number )

Advertising Router: 192.168.1.3

LS Seq Number: 80000001

Checksum: 0xE4E0

Length: 36

Network Mask: /24

Metric Type: 2 (Larger than any link state path)

TOS: 0

Metric: 20

Forward Address: 0.0.0.0

External Route Tag: 0

See, why R5 can ping loopback of R1, and R4 not

I always met some strange question. See the route 192.168.11.11/32, why the mask is /32, not /24, because I added "ip ospf net point-to-point" under loopback0

c2500-js-l.122-23.bin"

All five routers have same IOS

Thanks

148
Views
0
Helpful
7
Replies