Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

WS-C6503-E OS up date from compact flash via Linux - Got it working sort of!

--Update--

I formatted the flash card on the C6503 in disk1:

Tried reading the disk in my Linux PC it would not mount said unknown file system.

Formatted the disk again in the C6503 and then copied the old code from disk0: to disk1:

Tried reading the disk in my Linux PC and it shows the file.

I deleted the file on the flash disk from my Linux PC and copied the new code to the flash.

Tried reading the disk in the C6503 it saw the new file.

Put the flash disk back into the Linux PC and copied the startup-config to the disk.

Back in the C6503 it would see the code up date but not the startup-config.

Copied the startup-config to disk1: and did a "dir disk1:" I could see both the code update and the startup-config.

Back to the Linux PC I could see both the code update and the startup-config.

Edited the startup-config and saved it back to the flash disk.

Reading the disk again in the C6503 it saw the updated code and two config files "startup-config" and "startup-config~" with startup-config being the modified one.

So the C6509 or the Linux PC does not want to play with the file system correctly.

 

--Original post--

I know this is possible, because I did it before, and it was a pain, just don't remember what I did, so...

I need to format a CISCO 256MB compact flash so I will be accessible by both the C6503 and a Linux computer.

If I format the card on the switch (format disk1:) it is readable by the switch but will not mount in Linux.

If I format the card in Linux one of three things happen depending on the partition and format options...

1. The C6503 will not see it.

2. The C6503 will see it but sees some off files not the ones I copied and it takes a long time for it to read.

3. Both Linux and the C6509 will see the card and write files to it, bit they only see the file they wrote not each others.

I need to copy the startup-config to the flash-disk from the C6503 and then copy the updated code to the flash drive from my Linux PC.

3 REPLIES
Silver

Hi,Always format the flash

Hi,

Always format the flash card in the switch. To copy files to and from the switch, you can use scp: copy startup-config scp://username@x.x.x.x/ The file is copied to the home directory of username.

You can also install tftp or ftp on the linux box and copy files using these.

 

Thanks

John

New Member

Thanks, this solves half the

Thanks, this solves half the issue, I can use SCP to copy files off the switch to the Linux box, but trying it the other way the console connection seems to hang after entering the password then eventually times out. I will use TFTP as last resort, but it would be faster to take the switch down and use the other flash card that is formatted to work in  both the switch and Linux. last time I used TFTP it took over three days to transfer a 128MB file to the C6503.

Silver

Hi,Shouldn't take that long

Hi,

Shouldn't take that long to transfer a file. Have you tried this over a telnet or ssh connection rather than via the console. You can still use scp to copy file to the switch.You just need to revers the source and destination e.g. copy scp://username@x.x.x.x/filename disk1/filename

 

Thanks

John

68
Views
0
Helpful
3
Replies
CreatePlease to create content