Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

X.25 connection to Alcatel HLR 1422

Hi all,

I have a problem whereby PAD to a Alcatel HLR 1422 results in this error debug message. Keypoint here is Diag 235.

00:05:16: Serial0/1: X.25 O R1 Call (13) 8 lci 1

00:05:16: From (4): 2001 To (4): 1001

00:05:16: Facilities: (0)

00:05:16: Call User Data (4): 0x01000000 (pad)

00:05:16: Serial0/1: LAPB O CONNECT (15) IFRAME 6 4

00:05:16: Serial0/1: LAPB I CONNECT (2) RR (R) 7

00:05:16: Serial0/1: LAPB I CONNECT (7) IFRAME 4 7

00:05:16: Serial0/1: X.25 I R1 Clear (5) 8 lci 1

00:05:16: Cause 0, Diag 235 (DTE originated/Unknown diagnostic)

00:05:16: PAD: VC Cleared Cause: 0 Diag: 235

00:05:16: Serial0/1: X.25 O R1 Clear Confirm (3) 8 lci 1

00:05:16: Serial0/1: LAPB O CONNECT (5) IFRAME 7 5

00:05:16: PAD: VC Out of service/deleted

00:05:16: PAD0: Closing connection to . In 0/0, out 0/0

00:05:16: Serial0/1: LAPB I CONNECT (2) RR (R) 0

I have tried several combinations of configurations which have matched the Alcatel HLR switch configuration and usually results with this debug message.

Please help

6 REPLIES
New Member

Re: X.25 connection to Alcatel HLR 1422

According to the debug we are getting INPUT clear from device connected to serial 0/1 ,once the router get input clear it would send out clear confirm. we are getting proprietory diagnostic code which is vendor specific , you need to find out from other end why they are sending us clear and what that diagnostic code means .

Can you send running configuration of your router and show interface serial 0/1

New Member

Re: X.25 connection to Alcatel HLR 1422

Thank you for replying

Here is the interface

Serial0/1 is up, line protocol is up

Hardware is PowerQUICC Serial

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation X25, loopback not set

X.25 DCE, address 2002, state R1, modulo 8, timer 0

Defaults: idle VC timeout 0

cisco encapsulation, nvc 8

input/output window sizes 2/2, packet sizes 256/256

Timers: T10 60, T11 180, T12 60, T13 60

Channels: Incoming-only none, Two-way 1-16, Outgoing-only none

RESTARTs 6/0 CALLs 0+9/0+0/0+0 DIAGs 1/0

LAPB DCE, state CONNECT, modulo 8, k 7, N1 12056, N2 20

T1 1000, T2 0, interface outage (partial T3) 0, T4 0

VS 3, VR 2, tx NR 2, Remote VR 3, Retransmissions 0

Queues: U/S frames 0, I frames 0, unack. 0, reTx 0

IFRAMEs 28/17 RNRs 0/0 REJs 0/0 SABM/Es 0/2 FRMRs 0/0 DISCs 0/0

Last input never, output 00:00:34, output hang never

Last clearing of "show interface" counters 01:04:38

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

103 packets input, 283 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

93 packets output, 381 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Here is the configuration

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

ip subnet-zero

mpls ldp logging neighbor-changes

no ftp-server write-enable

x25 routing

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation x25 dce

x25 address 2002

x25 htc 16

x25 ips 256

x25 ops 256

x25 nvc 8

clockrate 9600

lapb T1 1000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

encapsulation x25 dce

x25 address2001

x25 htc 16

x25 ips 256

x25 ops 256

x25 nvc 8

no keepalive

clockrate 9600

!

no ip http server

ip classless

!

!

!

x25 route 1002 interface Serial0/0

x25 route 1001 interface Serial0/1

!

line con 0

line aux 0

line vty 0 4

login

transport output none

!

!

end

I have looked through with the engineers on the Alcatel side and the configuration looks similar except for T20+ (timer) values which cannot be configured on the current IOS I am running.

New Member

Re: X.25 connection to Alcatel HLR 1422

X25 T20 timer is use to send Restart request in X25 DTE side , the s0/1 is x25 dce in X25 DCE the similar counter you have is x25 T11 which is set in DCE for restart indication, you would not see option of t20 in DCE side.

I am wondering if you turn on keepalive and then see your interface is stay up/up longer w/o turning on keepalive the interface is always stays up/up.

I notice we have couple of interface reset so i want to make sure with keepalive we still see interface stays up/up .

Turn on debug labp and debug x25 all after enabling keepalive and shut/no shut the interface .

Again the clear indication is coming form Alcatel , they need to tell us why are they clearing the call . According to your configuration they are expecting lci within 1-16 , may be they are expecting different channels then we need to change x25 htc paramter accordingly, it is just a guess .

New Member

Re: X.25 connection to Alcatel HLR 1422

Thanks for your input.

I have talked to the Alcatel Engineers and they will refer their configuration as well as mine to their respective parties.

There is this field which is interchangable on the Alcatel switch configuration

Definition: CCITT or ISO

Is this a good clue?

New Member

Re: X.25 connection to Alcatel HLR 1422

CCIT protocol is define the call user data in call set up field , that shows 0 in 8 bit and 0 also in 7 bit in call user data .

In the debug it was showing the CUD field shows 0x01 which is Local PTT protocol also say PAD ..

The question here is how you are making a call to other device of x25 connected to s0/1 .Are you making pad call from router to connect to that x25 device connected in alcatel side or just switching x25 callfrom one side to other using x25 route. It seems to me a pad call coming into the router .

Again you need to involve Alcatel to narrow down the problem , as those are clearing the call with vendor specific reason.

New Member

Re: X.25 connection to Alcatel HLR 1422

Problem solved,

Alcatel switch terminal configuration is set to GENEWAN and LineRemote (not workstation remote). Hope this helps other people.

176
Views
0
Helpful
6
Replies