Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

x.25 over TCP

Does anybody know what minimal Cisco router platform could be used for X.25 connections?

This router must be integrated on OSPF network.

Could this router has VPN facilities ?

Thanks

  • Other Network Infrastructure Subjects
2 REPLIES
New Member

Re: x.25 over TCP

New Member

Re: x.25 over TCP

I have a working config for you.

This is two routers back to back over serial wan cables on s0/0 .Connected to two unix servers running x25 protocol on s0/1.

This is running x25 over IP.

outer1#sh run

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router1

!

enable password cisco

!

memory-size iomem 10

ip subnet-zero

!

x25 routing

!

interface Ethernet0/0

ip address 51.1.1.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0/0

ip address 145.1.1.2 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

clockrate 2000000

!

interface Serial0/1

no ip address

no ip directed-broadcast

encapsulation x25 dce

no ip mroute-cache

x25 version 1980

x25 lic 512

x25 hic 515

x25 ltc 1024

x25 htc 1051

x25 win 7

x25 wout 7

x25 ips 512

x25 ops 512

clockrate 19200

no cdp enable

!

router ospf 123

network 0.0.0.0 255.255.255.255 area 0

!

ip classless

no ip http server

!

x25 route 237830050052 xot 145.1.1.1

x25 route 237819420132 interface Serial0/1

!

Hostname router2

!

logging rate-limit console 10 except errors

enable password cisco

!

memory-size iomem 10

ip subnet-zero

!

no ip finger

!

ip audit notify log

ip audit po max-events 100

no ip dhcp-client network-discovery

!

x25 routing

call rsvp-sync

!

!

interface FastEthernet0/0

ip address 10.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 145.1.1.1 255.255.255.0

!

interface Serial0/1

no ip address

shutdown

!

interface Serial0/2

no ip address

encapsulation x25 dce

x25 version 1980

x25 lic 512

x25 hic 515

x25 ltc 1024

x25 htc 1051

x25 win 7

x25 wout 7

x25 ips 512

x25 ops 512

clockrate 19200

no cdp enable

!

router ospf 123

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip classless

ip http server

!

x25 route 237819420132 xot 145.1.1.2

x25 route 237830050052 interface Serial0/2

175
Views
0
Helpful
2
Replies
This widget could not be displayed.