Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

x25 over ip

Hi, all

I have 2 hosts run x25 PVC, one acts x25 DTE, the other DCE. They can work well connected by 2 modems. Now I add them into IP network, run as X25 over IP by 2 routers. I try 2 methods to configure router to connect them, STUN and X25 PVC. But neither can work. The configurations are as below. Anybody can give me some suggestions is very appreciated.

A. Stun:

hostname RouterA

!

enable secret 5 $1$wwWF$PRaaQiMV2aR.vvh6li.381

!

no ip domain-lookup

x25 routing tcp-use-if-defs

!

stun peer-name 11.1.1.1

stun protocol-group 1 basic

stun remote-peer-keepalive

!

interface Loopback0

ip address 11.1.1.1 255.255.255.255

!

interface Ethernet0

ip address 10.1.1.254 255.255.255.0

no keepalive

!

interface Serial0

ip address 1.1.1.5 255.255.255.252

no fair-queue

!

interface Serial1

no ip address

encapsulation stun

clockrate 9600

stun group 1

stun route all tcp 11.1.1.2

!

router eigrp 20

network 10.0.0.0

network 11.0.0.0

network 1.0.0.0

no auto-summary

!

B . X25 PVC

hostname RouterA

!

enable secret 5 $1$wwWF$PRaaQiMV2aR.vvh6li.381

!

no ip domain-lookup

x25 routing tcp-use-if-defs

!

!

interface Loopback0

ip address 11.1.1.1 255.255.255.255

!

interface Ethernet0

ip address 10.1.1.254 255.255.255.0

no keepalive

!

interface Serial0

ip address 1.1.1.5 255.255.255.252

no fair-queue

!

interface Serial1

no ip address

encapsulation x25 dce ietf

no ip mroute-cache

x25 modulo 128

x25 ltc 2

x25 pvc 1 tunnel 11.1.1.2 interface Serial 1 pvc 1

clockrate 9600

!

router eigrp 20

network 10.0.0.0

network 11.0.0.0

network 1.0.0.0

no auto-summary

!

  • Other Network Infrastructure Subjects
1 REPLY
New Member

Re: x25 over ip

Hi, check whether the two X.25 hosts are running PVC or SVC. If they are using SVC, the PVC setup will not work and you may want to switch to a SVC XOT setup.

129
Views
0
Helpful
1
Replies