Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1841 Router as EZVPNServer with Cisco VPN Client - No traffic

Network consists of:

InternalNetwork->Cisco1841->ADSL->Internet<-ADSL<-GenericADSLRouter<-VPN Client

I am able to connect sucessfully over the VPN and authenticate via RADIUS. I get assigned an address from the VPN pool.

I am unable to ping any devices on the office internal network nor am I able to connect to any resources (e.g. \\servername.domain.com\sharename). If I try to ping servername.domain.com, it successfully resolves the IP address, although there is no reply.

I have tried the config with and without the firewall/ACL and it still does not work. I also see no packets being discarded that match my home IP/External range, so I assume it is not the firewall/ACL that is causing it not to work.

I have also tried it with and without nat-transparency.

The IP addresses are all in different subnets as well. Internal = 10.0.0.0, VPN Pool = 192.168.10.0, Home PC = 192.168.1.0

I have attached my config and show ver below, and would appreciate any assistance anyone can give me.

1 REPLY
New Member

Re: 1841 Router as EZVPNServer with Cisco VPN Client - No traffi

Ok I solved it... Was just missing the obvious! Changed the relevant parts of the config to:

ip nat inside source route-map nonat interface Dialer0 overload

!

access-list 144 remark VPN Traffic

access-list 144 deny ip 10.0.0.0 0.0.0.255 192.168.10.0 0.0.0.255

access-list 144 permit ip 10.0.0.0 0.0.0.255 any

!

route-map nonat permit 10

match ip address 144

!

It all works fine now...

88
Views
0
Helpful
1
Replies
CreatePlease login to create content