Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

New Member

501 VPN Site-2-Site Help

Hi All,

Hopefully somebody will be able to help me out. I have two Cisco PIX 501s and I am attempting to create a site to site VPN between them. The problem is that I appear to be unable to contact the server on the "other side" of the VPN. I have created a simple network diagram below.

From the 192.84.7.90 PC I attempt to contact the 192.168.254.10 server. The VPN light on the PIX appears but I get an error message saying that the network path cannot be found.

Hopefully somebody will be able to point me in the right direction, regarding where I am going wrong, or will be able to give me trouble shooting advice. Many Thanks.

PC 192.84.7.90

|

BangorPIX Inside 192.84.7.99

|

BangorPIX Outside ***.*.198.138

|

Internet

|

WelshPIX Outside ***.**.102.209

|

WelshPIX Inside 192.168.254.1

|

Server 192.168.254.199

I have attached the configs from both PIXs below.

BangorPIX

nameif ethernet0 outside security0

nameif ethernet1 inside security100

hostname tmaxbangor

domain-name ciscopix.com

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list inside_outbound_nat0_acl permit ip 192.84.7.0 255.255.255.0 192.168.254.0 255.255.255.0

access-list outside_cryptomap_20 permit ip 192.84.7.0 255.255.255.0 192.168.254.0 255.255.255.0

pager lines 24

logging on

logging buffered debugging

interface ethernet0 10baset

interface ethernet1 10full

mtu outside 1500

mtu inside 1500

ip address outside ***.*.198.138 255.255.255.248

ip address inside 192.84.7.99 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm drop reset

ip audit attack action alarm drop reset

pdm location 192.84.7.111 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 ***.*.198.137 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 192.84.7.111 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

no sysopt route dnat

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto map outside_map 20 ipsec-isakmp

crypto map outside_map 20 match address outside_cryptomap_20

crypto map outside_map 20 set peer ***.**.102.209

crypto map outside_map 20 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

isakmp enable outside

isakmp key **************** address ***.***.102.209 netmask 255.255.255.255 no-xauth no-config-mode

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash sha

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet 192.84.1.0 255.255.255.0 inside

telnet timeout 50

ssh timeout 5

terminal width 80

Welsh PIX

nameif ethernet0 outside security0

nameif ethernet1 inside security100

hostname TMAXWALES

domain-name ciscopix.com

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list inside_outbound_nat0_acl permit ip 192.168.254.0 255.255.255.0 192.84.7.0 255.255.255.0

access-list outside_cryptomap_20 permit ip 192.168.254.0 255.255.255.0 192.84.7.0 255.255.255.0

pager lines 24

logging trap debugging

logging host inside 192.168.254.10

interface ethernet0 10baset

interface ethernet1 10full

mtu outside 1500

mtu inside 1500

ip address outside ***.**.102.209 255.255.255.248

ip address inside 192.168.254.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 192.168.254.10 255.255.255.255 inside

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 ***.**.102.208

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 192.168.254.10 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

no sysopt route dnat

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto map outside_map 20 ipsec-isakmp

crypto map outside_map 20 match address outside_cryptomap_20

crypto map outside_map 20 set peer ***.*.198.138

crypto map outside_map 20 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

isakmp enable outside

isakmp key ***************************** address ***.**.198.138 netmask 255.255.255.255 no-xauth no-config-mode

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash sha

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet timeout 5

ssh timeout 5

terminal width 80

1 REPLY
Bronze

Re: 501 VPN Site-2-Site Help

Have you checked your router to see if you have a route to the remote subnet?

Check this out

http://www.cisco.com/en/US/partner/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094761.shtml

99
Views
0
Helpful
1
Replies
CreatePlease to create content