Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

A question in regards to PPTP using virtual-templates and routing problems

Hi.

A little information before I ask a question. My config is below...

vpdn-group 1

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

interface Virtual-Template1

ip unnumbered Loopback0

peer default ip address pool vpdn

compress mppc ignore-pfc

ppp encrypt mppe 40 passive

ppp authentication ms-chap

The PPTP Tunnel works like a champ. The issue I have is that the routes get messed up when the PPTP tunnel is up. Whenever I have the tunnel up internally, the PPTP connection wants everything passed through it. This means that even though I have a default route for my internal network, the PPTP tunnel causes it not to work. I have tried various fixes, one is below. Which didn't work....

ip route 0.0.0.0 0.0.0.0 Fa0/1

ip route ip.ip.ip.ip 255.255.255.0 virtual-template 1

All traffic still wants to go through only the virtual-template 1 interface. I have tried messing around with using various route statements. None of

them have worked.

Maybe I am incorrect in assuming that the VT interface should not be treated the same as a tunnel interface. (or any other interface for that matter)

Another footnote would be that I went through about 5 IOS versions to get PPTP to work properly.

I am currently running 12.1(5)T6

Any input will be appreciated.

1 REPLY
New Member

Re: A question in regards to PPTP using virtual-templates and ro

Ok.

I am guilty of not browsing the board before asking a previously answered question.

I also had a brain freeze since the tunnel is established between the client and the remote router, so this means the local router could care less due to the fact that the client already has a route it wants to use...

Sorry. :)

BTW: The answer is to not use the default gateway of the remote system. This is check box under tcp/ip settings under the network settings of the Windows PPTP client.

This is depressing since I chose an inappropriate logic with changing the light switch, before checking the bulb. *cough*

207
Views
0
Helpful
1
Replies
CreatePlease to create content