Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

ACS 3.0 Replication failed

I have problems in replicating the database from the primary Server to the backup server. If i manually start the replication it fails with the following log entry on the primary server:

-outbound replication cycle starting...

-acs ´servername´has denied replication request

-outbound replication cycle completed

Log entry on the backup server:

-Inbound database replication from ACS ´servername´ denied

In the Network Configuration both servers are configured.

In the Database Replication Configuration, the primary server is configured only to send any database information. The backup server is selected in the Replication Partner table. Replication is accepted from any known CSACS.

Thanks for any tips !!

The AUTH.log file:

AUTH 05/02/2002 13:36:37 A 5041 0776 DBReplicate thread kicked..starting sync.

AUTH 05/02/2002 13:36:38 E 0962 0776 Comms lib:Transport connect failed

AUTH 05/02/2002 13:36:38 I 0312 0776 Varsdb:All ODBC workers closed OK

AUTH 05/02/2002 13:36:38 I 0312 0776 Varsdb:DLL shutdown complete

AUTH 05/02/2002 13:36:41 I 0312 0776 Varsdb:Kicking off 1 ODBC workers

AUTH 05/02/2002 13:36:41 I 0156 0776 DBReplicate(OUT) attempting to sync with host ace-ciscosecur2

AUTH 05/02/2002 13:36:42 I 0178 0776 DBReplicate(OUT) attempting to exchange sync info with host ace-ciscosecur2

AUTH 05/02/2002 13:36:42 E 0366 0776 DBReplicate(OUT) 'ace-ciscosecur2' has denied replication request

AUTH 05/02/2002 13:36:42 A 5041 0776 DBReplicate(OUT) cycle completed

AUTH 05/02/2002 13:36:43 E 0962 0776 Comms lib:Transport connect failed

Community Member

Re: ACS 3.0 Replication failed

Hi Armin,

This a Cisco Bug, I had the same , and Cisco told me to ignore it , But NO Fix for it yet.

What ACS version do u hv.?

I have 2.6.4(4) for Win2000.

Hope this helps

Sarkis Karagozian

Community Member

Re: ACS 3.0 Replication failed

I have on Win2000.

But I can´t ignore that problem, because I have to replicate the database to the backup server. When did you contact Cisco with this problem ??

I can´t imagine, replication is not available on CSACS 3.0, so if any other have a solution, tell me about.

Armin Kraus

Community Member

Re: ACS 3.0 Replication failed

We also have ACS v3.0.1 build 40 on two win2k servers. We also have dbase replication problem. Although we configured it according to the provided documentation. Exactly the same error message as Armin Kraus has.

There is a bug-track available for this :CSCdw22345, but this bugtrack shows that the bug is verified (i.e. recognized) and that this is fixed in 3.0.1 build 40. Well, it's not !!

If anyone of you has a solution, please let me know. (sorry, my email is temporarily down)

Community Member

Re: ACS 3.0 Replication failed

I saw this error when setting up replication for our ACS servers. The problem is how you set up the Replication Partners in the Database replication settings.

IE If your primary is 'Server1' and your secondardy 'Server2"

In server1 you should first make sure that server2 is listed on the 'Relication' side of the 'Replication Partners' section.

In server2 you need to make sure that server1 is listed on the 'AAA Server' section.

Restart the services and try to manually replicate.

For more details on the way i have found it best to setup replication, see my posting in the 'ACS 3.0/NT Failover' thread.

Feel free to contact me at if you have any questions.


Community Member

Re: ACS 3.0 Replication failed

The setting on the secundairy server did the trick. Leave the server1 listed on the AAA-server section (on the left) and it works.

Thanks a lot Jason.

We set replication according to our desired schedule (every hour execpt NOT during backup-time) and already saw one replication passing along successfully.

Community Member

Re: ACS 3.0 Replication failed

I had a very similar problem. What I'd done was load the same CD into both servers (rather than unpack the second one)

Maybe cisco put something in the registry to ensure you don't buy one ACS server CD and use two servers.

As soon as I loaded the 2nd CD onto the 2nd server it all worked OK.

Community Member

Re: ACS 3.0 Replication failed

Below a solution taken from jason:

I hace found that it is best to start out with a clean install of the the backup


The steps below assume you are using a primary/seconard approach. Once it is setup all changes should be made on the primary then replicated out to the secondary.

Primary Server

1) you will want to add the backup server in the Network configuration menu (Make sure you click on 'Submit + Restart'

2) Go into System configuration > CiscoSecure Database Replication

3) Make sure that Send is check for all of the items you want to replicate

4) at the bottom of the screen move the backup server from the 'AAA Servers' to the 'Replication' on the right side, then click submit.

Secondary server

1) Install the ACS software will all of the defaults (make sure you select Database replication when prompted)

2) after the software is setup and you have configured an administrator, go into the Network Configuration and add the Primary ACS server to the AAA Server list (be sure you use the same password as you used before)

3) Make sure you submit & restart

4) from System Configuration go into Database Replication

5) uncheck all of the send and check all of the receive. Do not make any changes to the Replication Partners Section (the primary should still be listed as a AAA Server)

Once this is finished go back to the Primary server and go into Database Replication and click Replicate Now. After you do this go into 'Reports and Activitiy' and choose 'Database Replication'. Then choose the first one in the list. This will tell you if the replication has succeeded or not.

We had the same problem, und his solution works fine.

Regards Michael

CreatePlease to create content