Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

ASA 5505 - DHCP relay not working on trunks

Hi,

I recently added a voice network to my ASA. 

I have an external DHCP server on the Data VLAN.

*****Data******

interface Vlan1

nameif inside

security-level 100

ip address 192.168.64.1 255.255.255.0

!

******Voice*******

interface Vlan3

nameif voice

security-level 100

ip address 192.168.200.1 255.255.255.0

**********************

static (inside,voice) 192.168.64.0 192.168.64.0 netmask 255.255.255.0

static (voice,inside) 192.168.200.0 192.168.200.0 netmask 255.255.255.0

***********************

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

*****DHCP Relay******

dhcprelay server 192.168.64.3 inside

dhcprelay enable voice

dhcprelay timeout 90

When I use one of the switchports on the ASA as an access port I can get an IP address from the DHCP scope for the voice vlan, however, when I make it a trunk and try to use it for a phone, I can't get an IP address.

Any ideas the relay is working on an access port and not on the trunk?

Thanks.

805
Views
0
Helpful
0
Replies
CreatePlease login to create content