Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ASA OSPF routes

Below is my setup,

on the router R2

interface Loopback0

ip address 150.1.2.2 255.255.255.0

!

interface Loopback1

ip address 192.168.1.2 255.255.255.0

!

interface Loopback2

ip address 192.168.3.2 255.255.255.0

!

interface Loopback3

ip address 192.168.5.2 255.255.255.0

!

interface Ethernet0/0

ip address 136.1.0.2 255.255.255.0

router ospf 1

router-id 150.1.2.2

log-adjacency-changes

network 136.1.0.0 0.0.0.255 area 0

network 150.1.2.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 0

network 192.168.5.0 0.0.0.255 area 0

routes on the asa,

C 136.1.0.0 255.255.255.0 is directly connected, outside

O 192.168.5.2 255.255.255.255 [110/11] via 136.1.0.2, 0:14:11, outside

O 192.168.1.2 255.255.255.255 [110/11] via 136.1.0.2, 0:14:11, outside

O 150.1.2.2 255.255.255.255 [110/11] via 136.1.0.2, 0:14:11, outside

O 192.168.3.2 255.255.255.255 [110/11] via 136.1.0.2, 0:14:11, outside

on the ASA, I see the host routes instead of the networks, Am I missing something? Thanks in advance

Ganesh

3 REPLIES
Hall of Fame Super Blue

Re: ASA OSPF routes

Hi Ganesh

It's not a problem with the ASA but to do with how OSPF advertises loopback addresses. By default OSPF advertises loopback addresses as /32's regardless of the subnet mask you actually use. If you want to to advertise the subnet mask as well you need to add the following to your config

interface loopback0

ip address 150.1.2.2 255.255.255.0

ip ospf network point-to-point

Do this under all your loopback interfaces.

HTH

Jon

Community Member

Re: ASA OSPF routes

yes, you are right. it worked :-)

Thanks Jon

Hall of Fame Super Blue

Re: ASA OSPF routes

No problem. Glad to have helped.

163
Views
0
Helpful
3
Replies
CreatePlease to create content