Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Assigning mutiple addresses to ASA interface

Is it possible to apply secondary & tertiary Ip addresses to the ASA interfaces as in case of routers

thanks in advance

5 REPLIES
Gold

Re: Assigning mutiple addresses to ASA interface

No - secondary IP is not supported on ASA...

I found following trick how to handle this

http://www.velocityreviews.com/forums/t153418-secondary-ip-address-on-pix-ethernet-interface.html

I hadnt chance to try it

M.

Hope that helps rate if it does

New Member

Re: Assigning mutiple addresses to ASA interface

Actually my requirement is to assign the following subnets to the ASA

192.168.30.0/24

192.168.31.0/24

192.168.33.0/24

I dont have any free interfaces left. Is there any possibilty of creating any subinterfaces and trunk them to a switch so that only one interface is used?

any suggestions

thanks in advance

Silver

Re: Assigning mutiple addresses to ASA interface

Yes, this is one of the BEST features of the ASA... It supports hundreds of VLAN interfaces.. Here is a sample config...

interface GigabitEthernet0/2

speed 1000

duplex full

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/2.15

vlan 15

nameif commsim

security-level 20

ip address 192.168.176.1 255.255.255.0 standby 192.168.176.2

interface GigabitEthernet0/2.50

vlan 50

nameif dmz

security-level 10

ip address 192.168.173.1 255.255.255.0 standby 192.168.173.2

!

****Make sure that the ASA is connected to a switchport that is trunking ALL of the VLANS you want to use in you VLAN interface****

*****If this helps please rate***

Cheers

New Member

Re: Assigning mutiple addresses to ASA interface

Thanks for the response.

I only have a base image so will i be able to achieve this with the above configurations

New Member

Re: Assigning mutiple addresses to ASA interface

Yes. In fact it is a good idea to sub all interfaces from the begginning so that you do have to go back and do this later and thus cause downtime on the interface when you sub it out.

130
Views
7
Helpful
5
Replies