Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

BGP (using 2 ISP) and the configuration

Hi all

Currently we are using one ISP for our site. We are planning to add the 2nd ISP for redunancy, so that if ISP#1 fails than ISP #2 takes over.

I have attached the pre-define configuration, please help me if there is any configuration that its not correct.

Thanks.

Router #2 ISP #2 side

interface Fastethernet 2/0

ip address 203.1.254.52. 255.255.255.252

interface Fastethernet 1/0

ip address 66.28.166.3 255.255.255.0

router bgp 26000

no synchronization

bgp log-neighbor-changes

network 66.28.166.0 mask 255.255.255.0

neighbor 66.28.166.1 remote-as 26000

neighbor 203.1.254.52 remote-as 2914

neighbor 203.1.254.52 route-map AS 2200 in

neighbor 203.1.254.52 route-map AS 2200 out

no auto-summary

ip as-path access-list 1 permit ^2200$

access-list 10 permit 66.28.166.0

route-map AS permit 2200

match as-path 1

set local-preference 150

set as-path prepend 26000

Router #1 ISP #1 side

interface Fastethernet 2/0

ip address 66.28.21.114 255.255.255.252

interface Fastetherne 1/0

ip address 66.28.189.1 255.255.255.0

router bgp 26000

no synchronization

bgp log-neighbor-changes

network 66.28.189.0 mask 255.255.255.0

neighbor 66.28.189.3 remote-as 26000

neighbor 66.28.21.113 remote-as 16000

neighbor 66.28.21.113 route-map AS 16000 in

neighbor 66.28.21.113 route-map AS 16000 out

no auto-summary

ip as-path access-list 1 permit 16000

access-list 10 permit 66.28.189.0

route-map AS permit 16000

match as-path 1

set local-preference 200

match ip address 10

ISP#1-AS 16000

ISP#2 AS 2200

Ours -AS 26000

1 REPLY

Re: BGP (using 2 ISP) and the configuration

Hi,

I think you have posted your question in the wrong forum :-)

Try 'Network Infrastructure' instead of 'Firewalling', because I am afraid you get much response over here.

Best wishes!!

Kind Regards,

Tom

151
Views
0
Helpful
1
Replies
CreatePlease to create content